locked
Router not accepting remote access connections? RRS feed

  • Question

  • Ok, I've searched through a lot of threads and found similar issues but no solutions to the problem I'm having.

    I get all green check marks on my router config details except for the last one "Router is accepting Remote Access connections" I get a red X. WHS is set as DMZ and all ports are forwarded. I'm running a Linksys wrt54g with Tomato 1.07 firmware.

    Also, I haven't been able to access the server from work. They run websense here which I can proxy around for blocked sites but still no luck accessing my external IP either directly or via livenode.com or no-ip.com dns hosts. Help!
    Friday, July 6, 2007 6:15 PM

Answers

  • First off, take the Windows Home Server out of the DMZ.  It is NOT meant to be there and you risk having security issues.

     

    I tried looking up your routers firmware version but could not do so because Linksys made 7 or 8 different versions of the WRT54G.  I suggest checking there website and downloading the latest firmware update.

     

    After you have forwarded tcp ports 80, 443, 4125 to your Windows Home Server, check to see if you can reach these websites,

     

    Monday, July 9, 2007 6:43 PM
    Moderator
  • I reinstalled the latest Linksys firmware. Everything is working fine now and I get all green checks. I can even log in from work (with proxy of course). I may try messing around with DD-WRT at some point in the future though just to see if it works. I've also been eye-ing some of the newer routers lately like the d-link dir-655 and the belkin n1 vision...
    Friday, July 13, 2007 8:18 PM
  • I'm glad you got it working!

    • DMZ places your Windows Home Server ahead of the NAT protection. 
    • 3389 does not need to be port forwarded to your Windows Home Server.  It uses 80,443,4125 from the internet.
    Friday, July 13, 2007 9:23 PM
    Moderator

All replies

  • First off, take the Windows Home Server out of the DMZ.  It is NOT meant to be there and you risk having security issues.

     

    I tried looking up your routers firmware version but could not do so because Linksys made 7 or 8 different versions of the WRT54G.  I suggest checking there website and downloading the latest firmware update.

     

    After you have forwarded tcp ports 80, 443, 4125 to your Windows Home Server, check to see if you can reach these websites,

     

    Monday, July 9, 2007 6:43 PM
    Moderator
  • Ok, well I tried removing from DMZ. I've never had any security issues before with running in DMZ, it's really a port thing.

    To clarify, my model of WRT54G is ver1 (it's so old they didn't even list the version # on the label on the bottom) and I'm running Tomato firmware which is a small, lean and simple replacement firmware for certain linksys and buffalo routers, similar to DD-WRT and hyperwrt.

    All the ports have been forwarded (including 3389) but I still get the red x for the Remote Access connections in Settings.

    http://livenode address/home works from the home server box but https://.../remote doesn't (connection times out).

    I can't get either to load from work even when using http-tunnel to connect via proxy (bypass corporate firewall and websense). Http-tunnel log file says that remote server is refusing the connection.

    I suppose I could try reloading the linksys firmware on the box I just really love Tomato since it allows more simultaneous connections and is more tweakable...
    Monday, July 9, 2007 8:53 PM
  • I reinstalled the latest Linksys firmware. Everything is working fine now and I get all green checks. I can even log in from work (with proxy of course). I may try messing around with DD-WRT at some point in the future though just to see if it works. I've also been eye-ing some of the newer routers lately like the d-link dir-655 and the belkin n1 vision...
    Friday, July 13, 2007 8:18 PM
  • I'm glad you got it working!

    • DMZ places your Windows Home Server ahead of the NAT protection. 
    • 3389 does not need to be port forwarded to your Windows Home Server.  It uses 80,443,4125 from the internet.
    Friday, July 13, 2007 9:23 PM
    Moderator
  • uhh...my router uses 3389 to forward to 4125.  There is no selection for 4125 directly.  Is there something wrong here?

    TMG01

    Friday, July 13, 2007 10:35 PM
  •  TMG01 wrote:

    uhh...my router uses 3389 to forward to 4125. There is no selection for 4125 directly. Is there something wrong here?

    TMG01



    If something isn't working then you may be doing something wrong! 3389 is the terminal services port so externally 3389 should forward to internal 3389 if you want to use that function. Your router should be able to assign 4125 if you wish to use that port, maybe you could post some additional info?
    Tuesday, July 17, 2007 9:08 PM