locked
client computers can't connect to server/dashboard reports clients offline RRS feed

  • Question

  • Yesterday I used a firmware update to fix a problem I had with my Crucial M4 SSD system drive that made my server go offline after an hour. Thanks to all who helped me on that thread.

    However, now, I have a set of different issues:

    • I can't connect to the server via the Launchpad from any of my client computers. They all the report that the server is offline.
    • I can't connect to the server by using "http://<servername>/connect". I get an "Internet Explorer cannot display the webpage" error. Same result when I substitute the internal IP address for <servername>.
    • I can connect to the server by using Remote Desktop Connection from a client--but when I then open the Dashboard to the Computers and Backup tab, it reports that all the clients are offline.

    The server also does show up in the Network dialog box on the clients, and I can get into the files on the server wiothout any problem. My router info page shows the server as being online. I've checked the router settings, and all the appropriate firewall ports are open to the correct internal IP address of the server. I've tried rebooting everything, to no avail. Also tried re-setting up the router from the Server Settings dialog box--succeeds, but doesn't help the problem.

    Once again, I'm looking for any suggestions, thanks!


    Saul



    • Edited by scandib Friday, August 10, 2012 8:00 PM
    Friday, August 10, 2012 7:58 PM

Answers

  • I suggest you also try adding the following ports  to Windows Firewall and see the result. (I assume that you didn't install additional firewall program.)

    Port number

    Description

    65500

    Certificate web service

    65510 and 65515

    Client computer deployment website.

    65520

    Web service for Mac® client computers.

    65532

    Provider framework for server loopback communications.

    6602

    Provider framework for communication between the server and client computers.

    http://technet.microsoft.com/en-us/library/firewall-support-2.aspx

    • Edited by Stan-- Tuesday, September 4, 2012 7:30 AM
    • Marked as answer by scandib Saturday, September 15, 2012 6:09 PM
    • Unmarked as answer by scandib Saturday, September 15, 2012 6:09 PM
    • Marked as answer by scandib Saturday, September 15, 2012 6:10 PM
    Tuesday, September 4, 2012 3:11 AM

All replies

  • Hi Saul, can you post ipconfig /all ? You can also try temporarily disabling firewall to check the result.

    Sean Zhu

    TechNet Community Support

    Monday, August 13, 2012 8:58 AM
  • Thanks, Sean.

    Sending you ipconfig results from the server separately. Please let me know if you'd like to see results from a client as well.

    Also, please see my other message--turning off the firewall worked! At least temporarily...

    Thanks!

     


    Saul


    • Edited by scandib Monday, August 13, 2012 9:58 PM
    Monday, August 13, 2012 3:45 PM
  • Wow, that did it! Turned off firewall on the server and instantly I was able to connect!

    I assume that that's no a permanent fix, correct? Feels a little dangerous to turn off the firewall permanently...


    Saul

    Monday, August 13, 2012 3:50 PM
  • Hi Saul, I have received your email, thanks. Are you using Windows Firewall or third party firewall? By default, Windows Firewall should not block "connect". You can try adding port 65510 in firewall to see if that works. 

    Sean Zhu

    TechNet Community Support

    Tuesday, August 14, 2012 1:44 AM
  • Hi Sean--Using Windows Firewall and only that. I just added 65510 to the Virtual Servers list in my router, and I also allowed Dashboard through the firewall--seemed to me that that makes sense.

    Then I set the firewall to use recommended settings, and for a minute it looked good. But now all the clients have gone offline again.

    I'll kill the firewall again temporarily, but it would be great to have a permanent fix.


    Saul

    Tuesday, August 14, 2012 5:09 AM
  • Hi Saul, instead of disabling firewall on the client computer, what if you also add 65510 port on firewall? You can add it on one of your client and see if it goes offline.

    Sean Zhu

    TechNet Community Support

    Wednesday, August 15, 2012 2:55 AM
  • Hi Sean--

    Actually, I disabled the firewall on the server, not on the clients. I have already opened port 65510 on the server, but I will try opening it on the clients(s), if you think that might help.


    Saul

    Wednesday, August 15, 2012 6:22 AM
  • Do you think that my router could be the problem? It's in the router settings that I open firewall ports on the server. Is that what the "Set up" button is supposed to do under Router on the Remote Web Access page of Server Settings? Is it possible that WHS2011 is not able to set up the router properly, and that's why clients appear offline?

    Saul

    Wednesday, August 15, 2012 9:06 PM
  • Yes, if you enabled UPnP, Set up button should open the required port automatically on your router. If any port cannot be opened on the router, the wizard should pop an error such as port not opening or UPnP is not enabled.

    If we have narrowed down that the issue disappeared after disabling the firewall, we can focusing on server or client firewall settings.

     


    Sean Zhu

    TechNet Community Support

    Thursday, August 16, 2012 5:21 AM
  • Thanks, Sean. Yes, UPnP is definitely enabled on my router, I just checked.

    I have never seen an error message from the wizard -- on the contrary, it always reports that the router has been set up successfully. But despite that, there's no connectivity unless I disable the firewall. So it must be something in firewall settings, as you say.


    Saul

    Thursday, August 16, 2012 6:15 PM
  • So, what would be the next step?

    Saul

    Sunday, August 19, 2012 1:45 AM
  • Hi Saul, I have received your email, thanks. Are you using Windows Firewall or third party firewall? By default, Windows Firewall should not block "connect". You can try adding port 65510 in firewall to see if that works. 

    Sean Zhu

    TechNet Community Support

    Have you tried adding firewall exception on port 65510? 
    Monday, August 27, 2012 5:27 AM
  • I did--here are the ports I've opened on the server:

    I just tried turning the server firewall back on. Waiting to see if it can still see the clients...


    Saul

    Monday, August 27, 2012 7:10 AM
  • And sure enough, as soon as I turned the firewall back on, the server could no longer see the clients, and vice versa. Turned the firewall back off and instantly the server could see the clients again.

    Am I missing any other ports?

    Anything else look wrong about my router setup?

    Thanks!


    Saul

    Monday, August 27, 2012 7:16 AM
  • Isn't that the router setting? What about Windows Firewall? 

    To be clear, here "as soon as I turned the firewall back on", are you referring to route firewall or Windows Firewall? 

    Thursday, August 30, 2012 9:11 AM
  • Yes, that image shows the router setting. And I'm talking about turning Windows Firewall on the server on and off.  That's what seems to control whether server and clients can see each other.

    BTW, I have a Belkin N750DB router. It has something it calls a firewall, but it mainly seems to consist of the ability to open those ports as shown in the image above. In addition, it has this feature, which doesn't seem to be any better than turning off the server firewall:


    Saul

    Thursday, August 30, 2012 3:47 PM
  • Hi Saul, the router setting seems fine. If turning off Windows Firewall on the server and the issue disappears, you can add port 65510 on Windows Firewall: 

    Open a port in Windows Firewall

    http://windows.microsoft.com/is-IS/windows-vista/Open-a-port-in-Windows-Firewall?SignedIn=1 

    Friday, August 31, 2012 2:57 AM
  • Thanks Stan. I'd already done that, doesn't help. This is from the Inbound Rules, but I did the  same for Outbound:

    Saul

    Friday, August 31, 2012 7:29 AM
  • I suggest you also try adding the following ports  to Windows Firewall and see the result. (I assume that you didn't install additional firewall program.)

    Port number

    Description

    65500

    Certificate web service

    65510 and 65515

    Client computer deployment website.

    65520

    Web service for Mac® client computers.

    65532

    Provider framework for server loopback communications.

    6602

    Provider framework for communication between the server and client computers.

    http://technet.microsoft.com/en-us/library/firewall-support-2.aspx

    • Edited by Stan-- Tuesday, September 4, 2012 7:30 AM
    • Marked as answer by scandib Saturday, September 15, 2012 6:09 PM
    • Unmarked as answer by scandib Saturday, September 15, 2012 6:09 PM
    • Marked as answer by scandib Saturday, September 15, 2012 6:10 PM
    Tuesday, September 4, 2012 3:11 AM
  • Wow, thanks! That appears to have worked! I added these ports both to the router virtual server settings and to Windows Firewall on the server itself--not sure exactly which one or ones did the trick, and for the moment, I'm just going to leave well enough alone, rather than trying to nail it down.

    New problem--just installed Win 8 RTM on one of my computers, and then the connector software stopped working. I uninstalled, but I can't seem to reinstall from http://servername/connector (or from https://...) Getting a 404 error. Any ideas? I might need to try to install from a CD, if I can download the proper installation software or find it on the server itself.


    Saul

    Saturday, September 15, 2012 6:13 PM