locked
SQL Error -2147467259 RRS feed

  • Question

  • Dear All,

     

    I am trying to install Zentity. (Using the docs :-)

    I have SQL Express with FStream and Full text search. When I run the installer (server) I get  a SQL Error -2147467259

    If i run the msi with some logging turned on (msiexec /i Zentity.Installer.Server.msi /leavx log.txt)

    Here is the erorr bit form the log.

     

    MSI (s) (2C:0C) [15:39:35:840]: Executing op: ActionStart(Name=AddUsersToGroups,,)
    MSI (s) (2C:0C) [15:39:35:840]: Executing op: ActionStart(Name=CreateLocalUserGroups,,)
    MSI (s) (2C:0C) [15:39:35:840]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=0)
    MSI (s) (2C:0C) [15:39:35:840]: Error in rollback skipped.	Return: 5
    MSI (s) (2C:0C) [15:39:35:844]: Note: 1: 2318 2: 
    MSI (s) (2C:0C) [15:39:35:844]: Calling SRSetRestorePoint API. dwRestorePtType: 13, dwEventType: 103, llSequenceNumber: 18, szDescription: "".
    MSI (s) (2C:0C) [15:39:35:845]: The call to SRSetRestorePoint API succeeded. Returned status: 0.
    MSI (s) (2C:0C) [15:39:35:845]: Unlocking Server
    MSI (s) (2C:0C) [15:39:35:848]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.
    Action ended 15:39:35: INSTALL. Return value 3.
    MSI (s) (2C:0C) [15:39:35:851]: MainEngineThread is returning 1603
    MSI (s) (2C:48) [15:39:35:854]: RESTART MANAGER: Session closed.
    MSI (s) (2C:48) [15:39:35:856]: User policy value 'DisableRollback' is 0
    MSI (s) (2C:48) [15:39:35:856]: Machine policy value 'DisableRollback' is 0
    MSI (s) (2C:48) [15:39:35:856]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (2C:48) [15:39:35:856]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
    MSI (s) (2C:48) [15:39:35:857]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
    MSI (s) (2C:48) [15:39:35:858]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
    MSI (s) (2C:48) [15:39:35:858]: Restoring environment variables
    MSI (s) (2C:48) [15:39:35:859]: Destroying RemoteAPI object.
    MSI (s) (2C:00) [15:39:35:859]: Custom Action Manager thread ending.
    MSI (c) (60:C4) [15:39:35:860]: Back from server. Return value: 1603
    MSI (c) (60:C4) [15:39:35:860]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
    MSI (c) (60:C4) [15:39:35:860]: PROPERTY CHANGE: Deleting SECONDSEQUENCE property. Its current value is '1'.
    Action ended 15:39:35: ExecuteAction. Return value 3.
    MSI (c) (60:C4) [15:39:35:860]: Doing action: FatalError
    Action 15:39:35: FatalError. 
    Action start 15:39:35: FatalError.
    Action 15:39:35: FatalError. Dialog created
    Action ended 15:39:36: FatalError. Return value 2.
    Action ended 15:39:36: INSTALL. Return value 3.
    MSI (c) (60:C4) [15:39:36:844]: Destroying RemoteAPI object.
    MSI (c) (60:74) [15:39:36:844]: Custom Action Manager thread ending.
    

    Any ideas?

     

    I first installed SQL express (not advanced) and hit issues with full text , i reinstalled SQL Express Advanced

    Steven

     


    sjj698
    Monday, July 4, 2011 2:43 PM

Answers

  • Hello,

     

    Yes the error was to do with either named pipes or sql users. I hit this error as I installed SQL Express, then tried to install Zentity. When I hit the full text issue , I uninstalled SQL Express and installed SQL Express Advanced (500mb rather than the 300mb download).

    Of course this meant I had to repeat all the SQL steps in the instructions! Once repeated I could complete the install.

     

    Can you please stress in your docs that SQL Express Adv is required (I never knew they were separate downloads) - for those in this situation you can expand the SQL Express Advanced install download into a dir. Then go to control panel and change/remove the existing SQL Express that is installed, select change and when prompted for the install files use the SQL Express Advanced directory, you can then just add Full Text search and there is no need for a reinstall.

     

     

    Regards

    Steven


    sjj698
    • Marked as answer by sjj698 Tuesday, July 5, 2011 8:35 AM
    Tuesday, July 5, 2011 8:34 AM

All replies

  • Hi,

    Thanks for your post.

    The above issue is caused due to the “Named Pipes” not enabled on the SQL Server(or Express).

    Refer to the attached document for resolving this issue.

    Note: It is also documented in the troubleshooting section of the Zentity Installation Guide.

    Please follow the following link for more details.

    https://skydrive.live.com/redir.aspx?cid=d35123c4171609b2&resid=D35123C4171609B2!110

    Can you please accept the following two threads as closed by accepting the proposed answers.

    SharePoint and Zentity

    Zentity limitations

    -Regards

    • Proposed as answer by Kalnemi Wednesday, July 6, 2011 10:38 AM
    Tuesday, July 5, 2011 7:43 AM
  • Hello,

     

    Yes the error was to do with either named pipes or sql users. I hit this error as I installed SQL Express, then tried to install Zentity. When I hit the full text issue , I uninstalled SQL Express and installed SQL Express Advanced (500mb rather than the 300mb download).

    Of course this meant I had to repeat all the SQL steps in the instructions! Once repeated I could complete the install.

     

    Can you please stress in your docs that SQL Express Adv is required (I never knew they were separate downloads) - for those in this situation you can expand the SQL Express Advanced install download into a dir. Then go to control panel and change/remove the existing SQL Express that is installed, select change and when prompted for the install files use the SQL Express Advanced directory, you can then just add Full Text search and there is no need for a reinstall.

     

     

    Regards

    Steven


    sjj698
    • Marked as answer by sjj698 Tuesday, July 5, 2011 8:35 AM
    Tuesday, July 5, 2011 8:34 AM