none
MAC OS X access to WHS Drives RRS feed

  • Question

  • The Simplified network is as follows
    1 x Windows home server 4 x 1tb disks. 1 user (Guest - No Password)
    1 Windows XP PC running disks formatted as NTFS
    1 POWERMAC G4.

    The whole network is up OK and the WHS mounted on both PC and MAC.
    PC can read/write to WHS and MAC
    WHS can read/write to PC and MAC
    MAC can read/write to PC
    MAC can read from WHS
    The MAC cannot write or copy files to the WHS. When it does I receive an error which states that Finder cannot complete the operation as <filename> cannot be read or written, with an error code of -36
    When I check on the WHS disks a temporary file and a file with the same name have been created, but thwey are 1KB in size and have no contents. 

    I have checked through the group policies on both PC and WHS and can see no difference that is likely to cause this.
    Both the XP volume and WHS volume are mounted with FORMAT:SMB(NTFS).
    I also tried loading macFUSE and NTFS-3G, but could not get thet volumes to mount as NTFS-3G.

    Does anyone have any clueas as to why this is happening.

    This is a copy of a question I raised in the software forum, but realised that this was probably the correct forum for this.

    In Anticipation
    Wednesday, August 12, 2009 1:41 PM

Answers

All replies

  • Rather than mounting manually I would quickly try Go -> Connect to Server
    In the server Address put smb://1.1.1.1    where 1.1.1.1 is the IP address of your WHS

    Choose browse, select a folder and let it mount it – try copying into that folder does that work?

    Wednesday, August 26, 2009 11:05 PM
    Moderator
  • I've  the same problem as MilkyBarkid, I tried the option Go -> Connect to Server and yes I can mount the shares read it copy files from the shares to my macbook pro but I can't copy files from my macbook pro to the windows shares Just got the same error code -36.
    At my work we can transfer files from macos x computers to the windows(ntfs) shares as we use windows small business server 2003,  as WHS is a stripped version of it I though maybe Microsoft also stripped the possiblity of transfering files from macos x to windows shares. At home I've a mixed network of windows and macos x computers just use the best of both worlds ;-)

    I hope that someone knows the answer......
    Monday, December 21, 2009 11:36 PM
  • Please check that you do not accidentally have the wrong credentials saved in Keychain Access -- try deleting those and restarting your Mac OS X, next try to connect to your WHS from your Mac again and try creating a folder on your WHS using your Mac.
    Tuesday, December 22, 2009 3:37 AM
    Moderator
  • Thanks for your reply, I did found some wrong credentials deleted it and restarted macos x. I connected with my macbook pro to the whs. Created a new folder and I can even rename the folder. But if I tried to move a file from my macbook pro to the whs foto folder.  "I receive an error which states that the Finder cannot complete the operation as <filename> cannot be read or written, with an error code of -36"  (what is errorcode -36?)

    I just want to move my huge family photo files of my macbookpro and apple mac G4 to the whs.

    I hope you have another suggestion..




    Tuesday, December 22, 2009 9:43 PM
  • The file or folder you are attempting to move does it contain any contain exoctic characters such as a hyphen, anything that could make SMB angry?

    Might be best for you to check the logs on your Mac OS X for more information or hints about what is causing your problem. You can open the Console from /Applications/Utilities and try and replicate the problem to create a few more log entries, also check system.log and feel free to post anything you think might be related.
    Wednesday, December 23, 2009 4:25 AM
    Moderator
  • Hello Problem solved It was easier than I thoughed.

    Thanks for your help.
    Friday, December 25, 2009 10:45 PM
  • And the answer was?  How did u solve the problem
    Wednesday, December 30, 2009 1:44 AM
  • Answer -- please.  I'm having same issue.
    Tuesday, March 30, 2010 3:20 AM
  • What's the question?  ;-)  Seriously, start your own thread - it's the best way to get an answer.
    --
    Tuesday, March 30, 2010 9:32 AM