none
Lightswitch not displaying as per MySQL database RRS feed

  • Question

  • I am attempting to setup the Visual Studio 2013 Lightswitch assignment and it is causing me some grief.

    I can get almost all of the information displaying correctly but on a few sections it is dragging up the incorrect information.

    The MYSQL Table screen for orders should and does show as follows.

    OrderID          CustomerID    ProductID       OrderDate       OrderQty        ProductPrice   OrderValue

    1                      1                      1                      2016-11-27      2                      450.00             900.00

    OrderID is auto generated in the Orders Table as is CustomerID in the Customer Table and ProductID in the Product Table.

    However when I run Lightswitch I get this information

    OrderValue     OrderDate       OrderQty        ProductPrice   Customer         Product

    900.00                   2016-11-27          2                              450.00                   Richard                 Copper Red Dish 001

    The Customer and Product should actually be CustomerID and ProductID. I can easily fix the orientation of the info but I am having trouble with the rest. I don't understand why it is picking out the 2nd column "CustomerFirstName and ProductTitle" and dropping the first column which is "CustomerID and ProductID".

    Unfortunately I have asked my "teachers" and they have told me they don't know a lot about Visual Studio or Lightswitch. Which is to say the least frustrating.

    I have also run this through Access and had no problem with it showing the correct information.

    Can you guide me in the right direction? Is there a way to get Lightswitch to show the ID columns in the Screens?

    Yours Bryan

    Monday, May 29, 2017 12:58 AM

All replies

  • Hi Brayn5,

    This forum discusses and asks questions related to the current versions of the ADO.NET Entity Framework, Since your issue is more related to Lightswitch, I would suggest that you could post your issue on Lightswitch forum for suitable support.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=lightswitch

    Thanks for your understanding.

    Best regards,

    Cole Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 30, 2017 1:25 AM