locked
Office Communicator r2 RRS feed

  • General discussion

  • I have installed OCE and I am trying to setup the Phone part of it. Yhis is a bit confusing. I am getting Unable to route. Response code 403 will be returned. when I setup my normalization rules. Basicaly I want everyone to be able to dial anywhere anyhow. We do not restrict long distance or any call for that matte. How the heck do I set this up? I also need it to dial 9 to get an outside line first

    Any help would be fantastic
    Cheers
    Sean
    Thursday, May 28, 2009 8:29 PM

All replies

  • I assume that you do not need a 9 to dial your internal extensions, so first create a rule matching that.  For example, if you have 4 digit extensions then create a rule for ^(\d{4})$ with a translation pattern of $1.  Change the number inside the {} to match your extension length.  You can also be more specific if you want, like ^(1\d{3})$ if you have 4 digit extensions that all start with 1.

    Next, create a rule for all other numbers.  The pattern would be ^9?(\d*) translated to 9$1.  Make sure this rule is below the first one.
    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Friday, May 29, 2009 2:46 AM
    Moderator
  • Thanks..I will give it a shot
    Friday, May 29, 2009 1:35 PM
  • Ok I think I have a bigger problem. I have a Nortel BCM version 3.7. Although it seems like it would be supported I am not sure. I got through everything else with no problem but this phone thing is killing me. Any Idea how I tell the BCM to talk to the Mediation server. I know this is a broad question but I do not think I have set it up properley. I have been using the voice route helper and I get an error code returned of 403

    Thanks alot for your help

    Sean
    Friday, May 29, 2009 1:43 PM
  • Ok so here is the big question. My PBX is clearly out of date. What I really want to work is to allow OCM to communicate with my mobile phones. It is working for direct access (text and email) but I cannot get the phone to work on my mobile phone. I do not even see the option.  I assume from what I have been seeing that Ido not need to use my PBX for this?

    By the way the external normalization tests ok but the internal (with 4 digets) gives me the 403 error. I would appreciate your help Mike but do understand if I am too bothersome. The boss is down my neck
    Friday, May 29, 2009 11:23 PM
  • Ok, it sounds like you have a ways to go.  I don't think you can do direct SIP integration with a BCM, so you're going to need a media gateway and an available PRI port on your Nortel to get the telephony integration.  You could also just replace the Nortel with OCS depending on your specific requirements.  If you are trying to get Communicator Mobile up and running you'll also need an Edge server.

    If you're not sure where to start with any of that then plan on spending some time with the docs/forums/blogs/etc or seek outside help if you need something up and running quickly to satisfy your boss.
    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Monday, June 1, 2009 3:06 AM
    Moderator
  • Mike
    I actually have the communicator Mobile running without an edge server. We are going through a juniper which seems to work fine. I had the communicator to communicator mobile icon on the phone and for some reason this morining I no longer have that option??
    Monday, June 1, 2009 6:40 PM
  • CoMo does work from your internal network via wifi as well but to access it from the internet you will need an Edge server.  I hope that you have not opened up ports to route from the internet directly to your OCS server rather than use an Edge - I've seen customers do this from time to time. In addition to being very insecure it also won't function properly if you want all aspects of your deployment to work.
    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Tuesday, June 2, 2009 12:44 PM
    Moderator
  • Hi Mike

    Well I have the Edge server all setup and can connect via my mobile 6 phone. I have enabled enterprise voice with out PBX integration. All I really want to work is the communicator call. I do not seem to see the option on the mobile phone. Is there a way to get it to work with out the PBX? I have looked for some setup information but all I can see is how to configure it with a pbx?
    Thanks'
    Sean
    Wednesday, June 10, 2009 3:01 AM
  • Hi

    Since the CoMo doesn´t have voice integrated you must use some kind of gateway (probably GW+PBX) in order to make connections from OCS environment to CoMo devices. The communicator call to/from CoMo relys on the possibility for the OCS to make the call setup. In the scenario when you call from the CoMo, the OCS Server will call you on the CoMo, when you answer the OCS Server will call the B party (another communicator or external number).

    Prepare yourself for a Mediation Server, GW and PBX integration in order to make this work.

    /T
    Wednesday, June 10, 2009 6:19 AM
  • Thanks

    Then what is the purpose of being able to have enterprise voice without PBX integration. It is not very clear to me.
    Wednesday, June 10, 2009 2:02 PM
  • Hi

    There is no need for Enterprise Voice if you only want to make calls between OCS Communicators.

    As soon as you want to connect to extensions outside OCS or PSTN/Cellular networks you need Enterprise Voice. Simply because in that case you have to use a Mediation Server and GW/PBX.

    Since you want to make calls from OCS Communicator to CoMo the only option today is connection through Mediation Server - GW/PBX in order to reach the phone in your CoMo device.

    /T
    Thursday, June 11, 2009 6:34 AM
  • Thanks for the input

    funny thing is that I can call my mobile using the communicator call and I get the message to please answer the next call and then it disconnects. This leads me to believe that my dial strings are nto right. I am only guessing. excuse my ignorance on this.
    There are so many places that human error can come into play it is mind numbing.

    cheers
    Sean

    Friday, June 12, 2009 12:12 AM