locked
Account merge errors - PLEASE HELP!!! RRS feed

  • Question

  • We have several clients trying to use the Merge feature for Accounts who are all getting the same generic error below.  There is no log file to download.

    The error that shows up in the event viewer is:

    - System
    - Provider
    [
    Name]
    MSCRMWebService
    - EventID 18176
    [
    Qualifiers]
    49152
    Level 2
    Task 0
    Keywords 0x80000000000000
    - TimeCreated
    [
    SystemTime]
    2012-09-27T21:26:17.000000000Z
    EventRecordID 74179
    Channel Application
    Computer CRM2011TEST.thinkwarenet.com
    Security
    - EventData
    e19ee148-df78-44fa-96ed-3bc72102c4b4
    38cbbb1b-ea3e-db11-86a7-000a3a5473e8
    account
    30
    Merge
    Microsoft.Crm.Extensibility.InternalOperationPlugin,
    Microsoft.Crm.ObjectModel, Version=5.0.0.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35
    Microsoft.Crm.Extensibility.InternalOperationPlugin

    Unhandled Exception:
    System.Threading.ThreadAbortException: Thread was being aborted. at
    System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object
    target, Object[] arguments, SignatureStruct& sig, MethodAttributes
    methodAttributes, RuntimeType typeOwner) at
    System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr,
    Binder binder, Object[] parameters, CultureInfo culture, Boolean
    skipVisibilityChecks) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    culture) at System.Web.Services.Protocols.LogicalMethodInfo.Invoke(Object
    target, Object[] values) at
    Microsoft.Crm.Extensibility.InternalOperationPlugin.Execute(IServiceProvider
    serviceProvider) at
    Microsoft.Crm.Extensibility.V5PluginProxyStep.ExecuteInternal(PipelineExecutionContext
    context) at
    Microsoft.Crm.Extensibility.VersionedPluginProxyStepBase.Execute(PipelineExecutionContext
    context)

    PLEASE HELP!!!!!


    Kristen Elliott

    Friday, September 28, 2012 3:38 PM

All replies

  • Hi,

    Please following link which will be helpful to you,

    https://community.dynamics.com/product/crm/crmtechnical/b/crminogic/archive/2009/03/18/how-to-merge-records-in-dynamics-crm.aspx


    Thanks & Regards, MS CRM Consultant, V.Surya. My Blog: http://inventcrm.wordpress.com/

    Saturday, September 29, 2012 6:21 AM
  • Unfortunately that link is not helpful.  I know HOW to merge the accounts I'm just getting the error and can't figure out why.

    Kristen Elliott

    Tuesday, October 9, 2012 1:58 PM
  • Hi Kristen,

    From the event data it looks like problem is coming from the Plug in, is there any plug in register against account (or any other records system is trying to merge?). try disabling relevant plug in to see if it this the cause of error, once you locate relevant plug in need to fix code for the same..

    Thanks


    MayankP
    My Blog
    Follow Me on Twitter

    Tuesday, October 9, 2012 2:19 PM
    Answerer
  • I'm not sure about the plug-in.  I went to Settings/Customizations/Customize the System and looked at the Account entity and didn't see anything.  I also looked under Plug-in Assemblies and there was nothing.  Where else would I look for this?

    Kristen Elliott

    Tuesday, October 9, 2012 2:49 PM
  • Kristen,

    Was this a brand new installation of CRM or was CRM upgraded from CRM 3 or CRM 4 to CRM 2011?

    I ran into an issue after upgrading from CRM 3.0 to CRM 2011 where there were some fields in the database that had null values.  This not only caused the merge to fail but also trying to Deactivate an Active record.  Are you able to "Deactivate" an active Account in CRM?

    We opened a support case with Microsoft on the issue and they were able to provide a SQL Script that we could run to fix the data.

    Jeremy


    Jeremy Winchell
    Avtex
    Visit the Avtex Blog

    Wednesday, October 10, 2012 2:02 AM
  • kjelliott, Did this issue got fixed for you? We are also having the same issue. For us we upgraded form CRM 4 to CRM 2011 and when we try to Merge the records we ge the same error what you got. I'm also not able to deactivate the record which I'm trying to merge. Jeremy, do you know what that SQL was and if you could provide me the SQL so that I can get a brief idea of what's happening.

    Thanks !

    Thursday, December 6, 2012 3:08 PM
  • No, we have never received any help on this issue and we are still having clients experiencing it.

    Kristen Elliott

    Thursday, December 6, 2012 3:11 PM
  • I was able to find a solution for this and it worked. It had to do with the column named 'Merged' in AccountBase table which was NULL instead of 0. Executed this Update statement against the AccountBase table and that fixed the problem. I also ran update against the ContactBase table.

    Update AccountBase set Merged = 0 where Merged is Null
    Update ContactBase set Merged = 0 where Merged is Null

    Thanks !


    • Edited by sqldba20 Thursday, December 6, 2012 4:40 PM
    Thursday, December 6, 2012 4:38 PM
  • This was suggested to me earlier.  I tried it and it did not resolve the issue.


    Kristen Elliott

    Thursday, December 6, 2012 4:40 PM
  • Hi Kristen ,

    I have the exact same issue. Also the Merge column does not have null. How did you eventually resolve the issue? 

    -AJ



    • Edited by AJ15 Thursday, August 8, 2013 12:24 AM
    Thursday, August 8, 2013 12:13 AM
  • AJ -

    No we never did receive a resolution for this and we still have clients experiencing it...


    Kristen Elliott

    Thursday, August 8, 2013 2:10 PM
  • Ok. Thanks for your reply Kristen. 
    Thursday, August 8, 2013 11:56 PM