Whiist - Website Management Add-In RRS feed

  • Question

  • Whiist is a free Windows Home Server Add-In that allows management of websites and links on your home server. Once installed Whiist adds Website Management options to your Windows Home Server Console, allowing you to easily create new links or websites in a few simple steps.

    You can read more, view screenshots, and download the latest version of Whiist from its new page here: http://www.andrewgrant.org/whiist

    • Create new websites on your home server in a few simple steps.
    • Create pages for all the family, or separate pages for individual users.
    • Easily customize your public and private Windows Home Server Homepage links.
    • Fully integrated with the Windows Home Server management console.
    Please note that much of the UI is currently lacking polish, the Wizard and Property pages in particular need some attention.

    Comments welcome, be kind Smile
    Friday, June 8, 2007 4:30 AM

All replies

  • Cool!
    Friday, June 8, 2007 5:07 AM
  • Downloaded it and installed it!


    Did some testing and it works great!


    Am I right that when you remove a website the created content (in an empty folder) is not removed and IIS is also not cleaned up?





    Friday, June 8, 2007 9:17 AM
  • Downloaded and installed no problems, but when I try and create a link I get an error.


    First of all I'm doing this remotely, not sure if that should any difference though?  After successful install of the Add-in, I select the Website Management Tab, select Links, click Add, click Next, select "Create new site..." radio button, click Next, click Browse.


    "Failed to recurse shares: Win32 handle that was passed to Icon is not valid or is the wrong"

    Click OK

    "exception thrown"

    Click OK

    Then I get logged of the console.


    When I do the same from Websites, the same thing happens except the error message is in a smaller fonts and the whole message reads

    "Failed to recurse shares: Win32 handle that was passed to Icon is not valid or is the wrong type."

    Click OK

    Then I get a browse dialog for the shared folders.


    Hope I've given you enough info??

    Friday, June 8, 2007 1:08 PM
  • Fantastic - Downloaded, installed and have setup my home page on the new site - All worked perfectly


    Great work Andrew


    Friday, June 8, 2007 1:14 PM
  • I get exactly the same thing here.
    Friday, June 8, 2007 2:58 PM
  • Hey.. This is great stuff... but here is a good question.


    Does this proxy the webpages thru the WHS or just it like having a book mark?



    Currently I have my WHS server and a Exchange server on my network.  My router has port 443 forwarded to the exchange server so I can access my webmail.  I would love to have my WHS on the internet rather then the exchange server.


    What I want to be able to do is connect to the WHS then have it make a proxy backend call to the exchange server and present the webmail login.   This way I could have all my files and email available to me with just one port forwarded.


    Dunno if it is possable, just something that would be really nice if it would work.

    Friday, June 8, 2007 3:06 PM
  • Hi Danee,

    The content for a website is left untouched. This is intentional, though I may add deletion as an option later.

    IIs should be correctly cleaned up. After deletion the relevent alias (e.g. http://yourserver.livenode.com/site) should no longer function and there should be no entry in IIs. Are you experiencing otherwise?

    Friday, June 8, 2007 3:33 PM
  • Hi WhatBackHand, Michael J Weldon,

    That's a very strange error and isn't one I've seen. It's the piece of code that attempts to retrieve an icon from Windows for each folder.

    I've uploaded a new version (0.5.1) that instead uses icons contained in the plugin. It turned out there wasn't much benefit to retrieving the actual icons because they'll never be customized by the user!

    If you have time to try this new version it'd be appreciated.


    Friday, June 8, 2007 4:06 PM
  • Hi Pugsly,

    That's probably beyond the scope of this plugin, however you may be able to achieve your aim by playing with IIs directly on your home server.

    Alternatively you may be able to configure Exchange to use a different port for SSL.
    Friday, June 8, 2007 4:10 PM
  • Andrew,

    downloded 0.5.1 and installed, no longer get the error, thanks.


    Sorry for the basic question but I can't obviously tell what options I should be using if I want to add a link from WHS to a site that I've just copied under inetpub.  I also guess I need to do something to IIS to get it to see the "site" in addition to the cahnges that Whiist makes to the XML files.  You might have guessed I've never used IIS before!!!  Pointers to IIS for dummies would probably help????

    Friday, June 8, 2007 5:40 PM
  • There's currently no way to add links to sites that you've created yourself, only sites that already exist on the inernet.

    The best solution is to use Whiist to create your site (which will then be placed on a share, which IMO is a better place than inetpub) and which you will then have the option of creating a link for.

    Friday, June 8, 2007 5:57 PM
  • I also downloaded the new version but am still experiencing difficulties with the option of public vs private.  The only option made avaiable to me on instantating a new website is public as private is greyed out.  Inasmuch as WhatBackHand is stating that it now completely works for him, I'll try to uninstall everything and let the system balance itself before re-installing and recreating the websites.


    For what it's worth, I have created a shared folder called websites and inside that folder, I have two blank subfolders called external and internal.  These are the folders I am trying to use to create an external (Homepage display) vs internal (Logged in and private display).  My procedure is as follows: 1. logon to console 2. click on website mgmt console 3. make sure websites is displayed rather than links 4. click on ADD 5. click on NEXT 6. leave top selection in place of "Create a new site...." 7. click on NEXT 8. type internal in top box (lower box is greyed out) 9. click on browse 10. On choose website root screen select the website/internal empty folder and click ok 11. The screen reverts back and in the greyed out area I see myserver is named as follows: \\myservername\websites\internal & I click on NEXT 12. The next screen shows that the "make this screen public..." is checked and the second choice of making it private is greyed out plus the add a link to the WHS homepage is checked. I cannot do anything to change the public/private selection but I can uncheck the homepage selection...but for right now, I don't instead I select NEXT 13. On the next screen, I change the name from My New Site to external and I select my private home page (my public homepage was already selected and the "enter the url for this link" was greyed out but contained the language "internal". Also, the "Choose an icon for your link was equally greyed out containing "Default Image" 14. I click on Finish and the system immediately opens a new separate browser page which contains the placeholder webpage content. I close this page and check the console where I see displayed under websites : Internal with a source directory of \\myservername\websites\internal and PUBLIC. 15. I switch to links on the console and see the following: external  http://myservername/internal   PublicHomepage

    16. I close the console and open a browser to log onto my server and when it opens, I see a link named external which takes me to the pageholder which I then close17. I logon to WHS and find NO icon for the website! 17. I log back onto the console and choose links instead of website and click on external and then properties. 18. I see external in the top block and I change this to internal (the 2nd box is greyed out but does show /internal and the Choose icon selection is also greyed out but shows Default icon as well 19. I change the selected place this link on from public to private and click on OK. 20. On the console I see displayed: Internal  http://myservername.livenode.com/internal  Private Homepage & I close the console 21. I open a browser and connect to WHS, the homepage shows no websites available and I continue to logon and once I do, I see the websites block and the internal website icon and name which works when I click on it. 22. Finally, I open a new browser window and enter http://mysevername.livenode.com/internal and the page shows up! ! !

    I am more than a little puzzeled by this....any ideas?

    Friday, June 8, 2007 6:49 PM
  • Hi Michael,

    The simple explanation is that creating a private site (i.e. that which can only be accessed once you have logged in) is not present in this version. In an upcoming version the "Make this site private" option will be available and will result in the site only being accessible to people who are logged into your server.

    The public/private settings for "place this link" control where the link to the site is created. Links may exist on either the public homepage or private homepage.

    Also the reason you cannot change the icon when creating a page is that the link automatically uses the favicon that's created for your new site.

    Hope this helps,


    Friday, June 8, 2007 7:14 PM
  • Hi Andrew,


    In my case I used an empty folder, so the placeholder page (and a favicon) were created when I added a website, I'd prefer added content being removed when removing a website, leaving docs that are already there at creation untouched.


    Thinking IIS wasn't cleaned up was my mistake, I tried it again, but this time I closed the IIS mmc  before deleting and opened it again after deleting and all looks good, should have thought of this as the IIS mmc fooled me before.


    I do have a suggestion/request for usability: I would like to be able to use the right mouse button and get a relevant context menu.





    Friday, June 8, 2007 7:38 PM
  • The context menu is a good suggestion, thanks.

    As for removing the content automatically there are a few issues that I can see with this. What is currently missing however is a deletion prompt for websites. This prompt will likely mention that the website content will be left untouched but give an option for removing this too.

    Friday, June 8, 2007 7:52 PM
  • OK, got it!  Now that you mention the private site election not being present in this version, I remember reading about that on your site this morning but forgot about it in the heat of the battle!  Although I'm now a little less "hairfull"  I'm glad it was what it was rather than something corrupted on my system.  I await your further endeavors with this add-in and thanks for the support.  I sincerely appreciate it and your erstwhile efforts with the development process.  ! !
    Friday, June 8, 2007 7:55 PM



    Question: am I supposed to be able to view the files in the folder.?


    I am only able to see the PLACEHOLDER CONTENT page.

    Friday, June 8, 2007 9:04 PM
  • Hi Rouza,

    I'm not sure what you mean... The files are located in the shared folder you chose for the website. The placeholder page is just a, well, placeholder for you to replace with your own content.

    Friday, June 8, 2007 11:21 PM
  • Thanks for making a cool Add-in, you get my vote for the best one yet!  Why would you want to pay to host your website ( in this case, Homesite) or upload your photos to another site when you can use your own server to do both?  Taking advantage of having a Home Server is the way to go.  Looking forward to version 1.0 and whatever else may come.


    Friday, June 8, 2007 11:33 PM

    I assumed that your Add-In created a website and allowed all my files in the folder/share to be viewable via IE.


    is the result I should get.



    Saturday, June 9, 2007 3:05 AM
  • Rouza,

    This is because IIs uses index.htm as the index page for a website. Replace the default index.htm with your own page (or delete it and use default.htm, default.asp, default.aspx).

    This should probably be explained better on the default content page.

    Saturday, June 9, 2007 3:25 AM
  • Andrew,

    came back to this this morning to try and understand/configure more and the first time I went to add a website I got an error, now it's still a bit early (for the weekend!) so I didn't make a note of the error (sorry!).  I was trying create a placeholder so I could copy an existing wesite into it. Again I got the error when I clicked Browse, when I OKed the error I was presented with the Browse windows but I had a "limited" list of available directories.  I cancelled the creation and tried again this time no errors and a "complete" browse window. I then went on to create a website, replaced your placeholder files with my "web site" and it works a treat!


    Sounds as if something isn't initialised on first run??

    Saturday, June 9, 2007 11:13 AM
  • Andrew,

    First, I must commend you on a job well done! This will be a sweet Add-In once de-bugged!

    I too get several error types when I try to browse to the folder I wish to use for the web sites. Here they are:

    1. Error box that says: Failed to recurse shares: exception has been thrown by target of an invocation. Clicked OK and waited...... then get another Error box that says: Exception thrown. Clicked ok and get kicked out of Console.
    2. Rebooted and tried again. This time a different box with larger font pops up. Failed to recurse shares. There are no more..... and it 's cut off. Click Ok and get kicked from Console.
    I did get through the process to the Root Shared folders when I clicked browse. (I got the first error above but did not get kicked. After 30 seconds the Root Shared folder option opened up.) But the Add-in does not allow you to create a new folder. So I had to cancel the process, add the new folder for the web sites to live in, grant accesses and tried again. Then I got the errors above again. Afterward, I did several reboots and reinstalls of the Add-In and cannot get the Browse to root to work.

    NOTE: I do have Steve Vanhorn's Web Site Link Add-in installed as well, which also creates a Links list once logged into WHS. When I select Links in your Add-In, it shows the same Links I have set up with Vanhrn's Add-in. Could this be a conflict and is causing the problems????
    Also, once I installed the Add-In and the new web folder, WHS decided to go into a Massive "Balancing Storage" session. I'll wait until it's done before trying one last time, but it could be several hours.

    It looks like a sweet Add-in, but there is something not quite right yet. It's beta, so it's to be expected. Hope this helps out.

    And yes, this will get my vote as the best Add-In to date! Seems most of us want this "All in one" add in.
    Saturday, June 9, 2007 2:31 PM
  • judgeschambers . . .


    I would like to confirm that I too have had the same experience as you with the add-in in it's present state of development.  All of the items you mentioned were duplicated here as well.  I too had Steve Vanhorn's web site link add-in installed and wondered the same as you if it were conflicting or not.  After straining what's left of my gray cells by pondering about this issue, I decided to uninstall it basically because I couldn't easily confirm one way or another if it was in conflict with Mr. Grants add-in.  My thoughts were uninstalling the Vanhorn add-in reduces complexity/redundancy and allows for a cleaner appraisal.  As it stands now, Mr Grants add-in is semi-functioning for me but I expect it will only get better as he has time to add more functionality...not that I want to speak for him, he certainly can do that for himself.  I am eagerly looking forward to newer iterations of the add-in, especially when he cobbles together the ability to utilize the private web site features.


    On another note, I remain interested in seeing how this add-in will work with the "Simple Photo Gallery in a few minutes" album handler mentioned by dt42 in the thread of the same name that he started.



    Saturday, June 9, 2007 4:30 PM
  • Hi Judge, Whatbackhand

    First thank you for the informaton about the problem you've been having. I've got to admit I'm puzzled as I've never seen this before on either my server or the virtual machines I use for testing. I've also tried installing the plugin you've mentioned and had no problems (I'd have been surprised if this was the issue, but I wanted to be sure).

    I've uploaded a new version (0.5.2) with two changes. Firstly the code that finds your shared folders is improved, and secondly the code for the browse dialog has been changed to (hopefully) make any error easier for me to track.

    If you get a chance to try it I'd appreciate your feedback.



    Saturday, June 9, 2007 5:18 PM
  • Michael and Andrew,

    I too just started to delete both Vanhorn's and Grant's 5.1 then reinstall just Grant's 5.1 to see if the two were conflicting. Did that solve the issue for you?

    Now it seems that Grant has a 5.2. Maybe since I've done about 20 reboots and 4 reinstalls with 5.1 I'll just move on to the 5.2 without testing 5.1 by itself. Do tell how you faired with the uninstall of Vanhorn's and the reinstall of 5.1.

    Andrew, I also noticed with 5.1 that as soon as I got the errors my system went into Balance mode. This would last for an hour or so. Hmmm???

    Also, I noticed that with 5.1 if I used the console from one of my pc's the error would drop my Console connection. But if I logged into the server via Remote Desktop and then opened Console from there.... Sometimes I'd get the Root folder list AFTER I got the error. But that happened only twice. And it would only let me see the primary WHS default folders. Hope that helps more.

    Now that I've unistalled Vanhorn's and your 5.1 I'll just move to the 5.2. Same as with Michael, I really look forward to the private web options..... and the photo pages are of a big interest to me too.

    Good work! You'll get it.
    Saturday, June 9, 2007 6:27 PM
  • Andrew,

    OK 5.2 worked like a charm from the Console of one of my pc's.

    Cool part is that it even though I uninstalled the Vanhorn web link add-in and Grant's 5.1....after installing 5.2 my Vanhorn Web Links are still built into Grant's 5.2. Must not delete the files. That's cool, now I don't have to rebuild them..... LOL.

    Also, now I see all my files on WHS. So now I was able to select the new folder I set up for these websites. /server/websites/public. Nice!

    I have the landing page now and the private link once logged in. I'll have to try one now that posts a link on the main WHS landing page. Once sorted out, I'll put content on it.

    Andrew, looks like that was it.......at least for me.   Nice job!
    Saturday, June 9, 2007 6:40 PM
  • Andrew,

    The link you posted today works fine, but the link on your actual web site does not work and it says vs 5.5.....
    Saturday, June 9, 2007 6:54 PM
  • Judge and Andrew


    Unloading the Vanhorn add-in reduced the balanceing that was going on for me & the system became stable thus allowing me to get to appropriate folder selection etc..  Also, I actually cleaned my add-in environment totally by uninstalling all add-ins; let the system complete balancing; and then reloaded & reconfigured Andrew's add-in.  Once that was completed, I added back all add-ins with the notable exception of the Vanhorn add-in and everything really settled down. And...yes Judge, I too observed the quirky behavior utilizing console vs remote desktop.


    I now have the new version 5.2 installed and everything is as it should be (so far as the add-in development cycle has activated the feature set.).  There is but one exception to this and that is that the selection of an icon other than the one supplied during the placeholding routine doesn't seem to be fully functional yet...Is that intended Andrew?


    PS Andrew the new version file search finds the folders much faster now with no problems Good Work!



    Saturday, June 9, 2007 6:59 PM
  • Nice info Michael. That is the same things I found. The server has settled down now.
    Yes, the icon options are not as nice as Vanhorn's, but Andrew may get to that later.

    I started looking at the Simple Photo album that Dimitry published. The simple one works well. But it just that...simple. The modified version of Dimitiry's looks nice. I tried the other one with some more ASP 2.0 business, but I'm lost LOL. I think if I could find the Root Bin folder it might work... Maybe we can hear some more later on that one on the correct thread. 

    Dimitry's simple:

    WHS Blog ASP:
    Saturday, June 9, 2007 7:50 PM
  • A quick how-to for using Whiist to create a photo albm.

    How to create a Windows Home Server photo album in minutes

    Saturday, June 9, 2007 8:09 PM
  • Michael,

    Good to hear.

    When you create a link for a local website the icon used is the favicon from the directory (e.g. \\server\websites\mysite\favicon.ico). In the current verson this cannot be changed, but it will be available in the future.

    Saturday, June 9, 2007 8:22 PM
  • Andrew,

    Just installed 5.5 and did the photo album creation and installed the 2.1 handler. But when I try to view it in IE or FFox I get the Runtime Error page.

    I noticed in your screen shot that you show a Bin file. I have no bin file in the folder....
    I'll try to recreate in case I messed up.
    Saturday, June 9, 2007 8:38 PM
  • I would re-try the steps, also be sure to check "Allow site to run ASP Applications".

    The bin folder is in the 2.1 Photo Album Handler zip

    Saturday, June 9, 2007 8:47 PM
  • Ok, I found my error. Never drag and drop files from Winzip... cause what you see is NOT everything. Always do an Extract! LOL. Now the Bin file is on WHS. And the photo album works nicely!!!!!

    I tried to use the 2.1 on my own about an hour ago with no success, but I was not extracting the files from Winzip. So that's why it probably did not work.

    Works and looks just like that of Bertrand Le Roy's layout?

    Nice! Very Nice! Great Job, Andrew!

    Small item--Favicons.   When we set up a Default page it does create a favicon next to the link in the WHS page, but when I delete it and insert my own I use on an outside web site...it does not show up.  Also, I noticed that on the photo album page it does not offer a favicon next to the link in WHS. Any ideas?
    Saturday, June 9, 2007 9:00 PM
  • Andrew and Judge...


    This is not fair ! ! !  I had to run around town for awhile doing some Saturday chores and just return to find out that you and Judge have not only been playing with a new version of the add-in but you went a step further an added the album capability to the mix as well.  So...not one to be left behind, I quickly upgraded and as the English often say, "It works a treat"!  I just only played with it a tad before returning here to confirm that it all works as advertised.  This is a very NICE addition to the mix!


    PS  From the Judges post, I think you made his day and I know you've made mine!


    Thanks Andrew


    PPS Now I'll have to go read about the album software to see what types of files it supports besides jpg


    Saturday, June 9, 2007 9:38 PM
  • Michael,

    Sorry you missed out . Yes, it is very nice and it did make my day! This is exactly what I've been waiting to see. I'm just not sharp enough to make it myself ....LOL. You and I cracked the whip and Andrew did all the fabulous work...

    I made a test album with individual pics and folders of pics. Love it. Now I have to make my own custom Home page then include link(s) to the new photo album(s).

    Nice, nice, nice, nice, nice..... Thank you Andrew!

    Saturday, June 9, 2007 9:51 PM
  • Andrew,

    downloaded 0.5.5, removed 0.5.1 and installed 0.5.5.  From both Websites and Links when I hit browse I no longer get any errors!  Did notice that you've restructured the directory view, included all of the user directories in the "top level", is there any particular reasoning behind that?  Doesn't make any difference to me, just wondering why go to the bother of working it out?  For info on my current WHS setup it takes over a minute to generate the browse window.


    That sounds like I'm not pleased, be assured I like this add-in and can't wait for you to get to version 1, which reminds me anybody seen an RC running around anywhere.  My DVDs are gathering dust waiting....


    As the Judge says, "Nice, nice, nice..." and my thanks also!

    Sunday, June 10, 2007 11:28 AM
  • This is sort of off, but is also on topic: Web bots and their access to new web pages on WHS.

    Now that you have created new Publicly accessible web sites that can be seen and scanned without a password anytime your WHS is turned on. It might be a good idea to create a Robots.txt file to deny access to search bots on all your web pages and photo album web pages on WHS!

    For more info on what, where and how.....please see my new thread on this topic.

    Sunday, June 10, 2007 11:47 AM
  • I agree!


    Would be a good addition if we could have a robot.txt (optionaly) created when creating a new website.





    Monday, June 11, 2007 12:55 PM
  • Hi Andrew,


    I have another suggestion:


    When creating weblinks I had some I wanted to have both Public and Private.

    The current UI forces me to make them 2 times, I would like it if Public and Private would be checkboxes letting me choose where to display without having to make 2 entries.





    Monday, June 11, 2007 1:54 PM
  • Great add-in Andrew...
    Tuesday, June 12, 2007 4:44 PM
  • I just installed the add-in and have a problem.


    When I add a website, the URL field is greyed out - I can't enter the link URL.


    Once I click finish and go back in (properties), the URL field displays http://http://


    If I clear the field, retype the url (ex. http://www.michiganfan.com), it displays http://http://www.michiganfan.com


    If I clear the field and type www.michiganfan.com, it does not include http://, but the link from the home page doesn;t work - the link become https://<myusername>.livenode.com/home/www.michiganfan.com


    I downloaded today. Version 0.5.6


    Has anyone else seen this?

    Friday, June 15, 2007 1:34 AM
  • I had the same issue when I put in a ssl url - HTTPS://, it would default to http://https://link.com
    Friday, June 15, 2007 2:26 PM
  • Yes, this is a known issue. Due to a silly typo on my part you must enter the address for external links without an http:// prefix.

    An updated version will be released in the next day or two which has a fix for this issue as well as several improvements.

    Sorry for the inconvenience!

    Friday, June 15, 2007 6:10 PM
  • Yup, that's what I did when I first ran into the issue the other night when I installed RC1.  Still works great.....still totally cool addin.

    Andrew, i'll take it with the typo....LOL LOL...


    Standing by for next update



    Friday, June 15, 2007 8:00 PM
  • I've just put up 0.6, let me know how you find it Smile
    Saturday, June 16, 2007 6:54 PM
  • 6.0 Works great! 

    • Thanks for putting my Robot.txt file idea into the mix....now we don't have to paste one in.
    • Icon choices are nice.
    • Both public and private web page links work nicely.
    • Look and feel is nice too!

    I'll play with it more and see how all the new options work.




    Not working

    1. When choosing icon for your link- If I choose Get Icon from Website, Whiist says, "Could not retrieve image."  Is there a problem or is this normal.  I was thinking it would let me enter a URL of a remote location to get the icon....say on another remote server....or is the item supposed to be in the newly created folder?


    1. Is there a way you can add the ability to set the order of the links on both public and private listings? Currently they default to the order in which they were created. I know, it's knit picking...


    Saturday, June 16, 2007 8:04 PM
  •  Works great, i agree with judgechambers that it would be nice to be able to put the links in order, other than that great addin.




    Saturday, June 16, 2007 8:52 PM
  • The "Get Icon From Website" option will attempt to download the favicon from the site. This works with a lot of sites (Google, Live, Amazon, Ebay etc) and not at all with others.

    I think the name (and error) need to be a little more descriptive.

    With respect to sorting links; This is definitely coming and something I very much want too. Along with some redesigned dialogs this is likely to be the main addition to the next version.

    Saturday, June 16, 2007 9:17 PM
  • Andrew,

    I don't understand how to get the link icon function to work using Whiist.  Shouldn't there be a place to "tell" Whiist where to get the icon?  You have to tell it where it's supposed to get it.  Am I missing something here?

    You know what? I think I understand now. This is only for External web pages out on the web.... Say you make a link for Ebay, then it will attempt to get Ebay's fivico.   Not for a newly created WHS web page.

    I was thinking in terms of the other Web Site link Manager Add-in where you could put in a URL to a remote server where a fivico file was stored.

    Saturday, June 16, 2007 10:12 PM
  • Andrew,


    I downloaded the latest version of your add-in and installed it.  Once installed, I opened the windows console, which took forever, and saw the following message alert:


     Could not load file or assembly "Interop.WHSInfoIF, Version=, Culture=neutral, PublicKeyToken=null" or one of its dependencies.  The system cannot find the file specified. at Microsoft.HomeServer.HomeServerConsoleTab.WOLTab.HomeServerTabExtender.BuildComputerList() at Microsoft.HomeServer.HomeServerConsoleTab.WOLtab.HomeServerTabExtender..ctor(Int32 width, Int32 height, IConsoleServices consoleServices)


    Upon seeing this I performed the following:


    1. Deleted all websites/links created by your add-in
    2. Unloaded all addins and deleted them fromWHS
    3. Reloaded your add-in and recreated websites/links
    4. Opened web console to test and it responded as it should
    5. Populated newly created "webalbum" public page with photos etc as described on your "How-to page"
    6. Opened a browser window and was able to successfully see the page
    7. Added other add-ins back into WHS and installed same
    8. Opened WHS console to determine if it throws the previously described alert message or not and found all was well

    Conclusion:  Apparently a conflict existed between the new add-in and previously loaded software add-ins (at least on my system)


    There are a couple of other things I need to tell you about but can't right now as I need to rush out for a bit....but when I return, we'll continue this..






    Saturday, June 16, 2007 11:38 PM
  • I had the same problem. Apparently when the older version of Whiist was uninstalled it deleted the Interop file that was being used by the WOL addin I also had installed. Thus, to resolve the problem I simply uninstalled the WOL addin and then rininstalled it. That worked just fine.
    Sunday, June 17, 2007 12:46 AM
  • Yeah, I thought I'd set the interop file to be left upon installation but unfortunately hadn't. This isn't a problem in 0.6 as Whiist now uses the interops that are included with RC1 and up.


    It sounds like you've found a workaround, but sorry for the inconvenience!



    Sunday, June 17, 2007 3:21 AM
  • Hi Judge,


    Yes, the "Get from website" option is intended for external links. For local links it should also fetch the favicon if one exists, but I think this may be broken at the moment.


    If you enter the URL of an icon in a web-browser you can right-click and copy it, then paste it in. That's how I provide most of my icons. I can add a "Enter an address..." option pretty easily if that's the sort of thing you're after? I've also thought about including some default icons that could be selected from, but again I'm not sure if that's something people would use.


    I'm completely open to suggestions about this area, so feel free to fire away Smile



    Sunday, June 17, 2007 3:28 AM
  • Andrew,

    I guess that the copy and paste option was not intuitive to me... I was thinking of pasting an actual file and not a URL to a favicon. Same with the "get from web" option. Both were not obvious to me LOL. I look for things to be clearly labeled and/or marked. But that does not mean it has to be as long as there are instructions on the how to's.... Besides, your current config covers most of what I need anyway. Icons whether included, pasted or from a URL are not that important to me. I could live without them, but they make for an even more cool presentation. But honestly, the more you add and the easier it is to set up...the more I and everyone else will use all those options.

    On your request, you could put actual boxes or drop downs that are more descriptive, that may help with others that see it like me .

    Included Icons? Heck, I think that's cooler still. Sure, give us a bunch to choose from. And if they are not enough then we can still tell Whiist to get it from and alt URL or the newly created URL once we load the favicon file to the new folder.... Personally, the less I have to mess with it to look cool...the better. But have plenty of options for customization for those that want to.... 

    I'm one for function first, which Whiist seems to do really nicely!  Keeps getting better and better!


    Sunday, June 17, 2007 3:31 PM
  • >> I guess that the copy and paste option was not intuitive to me...
    >> I was thinking of pasting an actual file and not a URL to a favicon.

    That is actually what it does, I meant that I usually view the icon in a browser, right-click the image and then paste it in Smile

    Thanks for the feedback, I think this is an area I'll definitely revisit and tweak in future versions.

    Sunday, June 17, 2007 4:00 PM
  • Sounds good, Andrew. I think I get it now....

    I'm really looking forward to your future update that allows us to make web pages truly private and assign them to specific log on profiles   Ooooh yeah!

    Awesome job!  And Thanks for the hard work!

    Sunday, June 17, 2007 8:02 PM
  • Downloaded and installed, this let me set up links to existing sites with no hassle.  Wonderful stuff, just the job as I was wanting to set up a home web site to allow people to see photos and such like.


    However, I hit a snag.  If I use the Create a new site option, I can't enter a path to a shared folder in the text box and pressing the Browse button leads to an error message "Exception Thrown".  Clicking OK (the only option) drops the Console.


    Two things which may be of use:

    • I'm using the CTP release of Home Server
    • I only tried this from the console running directly on the server itself (ie. not from a workstation)

    So is this just me, or has anyone else seen this?  It's a shame as it'd be a big kick in the butt for me to get the website set up



    Monday, June 18, 2007 5:14 PM
  • Hi Lee,

    This is due to the fact you're using the CTP. The latest version of Whiist requires the assemblies that shipped with RC1.

    Unfortunately I don't have any old versions to send you, but if someone has a copy of 0.5.6 that should work fine with the CTP.

    Monday, June 18, 2007 5:29 PM
  • Andrew,


    Sorry for the delay in reporting back, as Paul Harvey says, "The Rest Of The Story", but here goes:


    1. Issue: When selecting the creation of a new site (and not pre-creating a shared folder for it) , you are led down the logic path to the point where you can browse for the shared folder that you wish to utilize.  At this point, you can create a new folder, but only if such creation is a sub-folder for previously created shares.  In essence, you cannot add a completely new share from here.  In saying this, I understand that your help screens do point out before this that if this is to be a new site that you have to specify a shared folder but it does not say the folder has to exist already.  Also, I iknow we discussed the creation of a new share like "websites" previously but I am discussing the experience a new user would have following the logic chain.
    2. Issue: The public vs private website is still a little quirky but that may be due to the beta stage your add-in is at?  I can create a website and make it private but the website screen on your add-in shows it as Public and not Private

    Those are the only issues at this point for me. Hopefully they are helpful to you in your design process.


    Now, back to my wife's "Honey-Do" chores...Enjoy!


    Monday, June 18, 2007 10:06 PM
  • Andrew,

    Mike has an good point on #1, but I simply created a "Websites" share first before starting. Then I can add albums or any website with it's own dedicated folder. Though it would be nice to have a "One stop" deal to create the initial share through Whiist.

    Also, What do you think about setting up the web links so that when you click on it, it opens a new instance of the browser? Heck, I bet most of us use IE7 by now or Fire Fox, so that would automatically open a new tab. Way cooler than having to hit the back button to get back to WHS log on page.

    I have not looked at the coding of the page, but would it be similar to using the <a href="http://www????????.com/" TARGET="_blank"> tag in an HTML page? I use it on many of my personal HTML pages.

    Tuesday, June 19, 2007 12:46 AM
  • Ah, sounds fair enough.  When I get RC1 installed I'll try again.  Thanks for the quick answer, Andrew.
    Tuesday, June 19, 2007 10:08 AM
  •  Good Job Andrew - installed, up, running - very happy as I had been [slap] hacking the inetpub directory
    Wednesday, June 20, 2007 5:23 AM
  • Hi, I installed and got the add-in working in one time. Tried to install the photo tool and also that worked. Only when you try to access from the outside with the link xxxx@livenode.com/picturefolder there is no picture to been seen. A friend helped me and the link xxxx@livenode.com/picturefolder/default.aspx did the magic work! I did not see this anywhere in the help file. Can you change somewhere the WHS server that it accepts other defaults? Or have I somewhere made a mistake or missed something?


    Greetings, Ruud 

    Wednesday, June 20, 2007 4:34 PM
  • Hi Judge, Mike

    There are two problems I see with your suggestions;

    Firstly, while it would be great to be able to create a share in the browse dialog this would likely require a LOT of code to do so. Creating a new share (programatically) is quite involved and I would either have to re-implement the same code that exists in the User tab, or figure out ways to hook into that code. It seems like a lot of work for only a little benefit.

    As for opening links in new windows, this is something outside of my control unfortunately. I only supply the link to WHS (in the form "http://blah"). The actual tag is generated by WHS.


    Wednesday, June 20, 2007 4:39 PM
  • Andrew,


    OK, I understand the rationale. On the other hand, user experience might be enhanced if the first screen presented to them states this:


    "If you wish to create a new website you have the option of utilizing an existing shared folder; creating a subfolder under an existing share; or creating a new shared folder by first utilizing the shared folders icon on the windows home server console before adding the new website. The folder you create will be where the contents of the site live."

    What are your thoughts?


    Wednesday, June 20, 2007 10:23 PM
  • Andrew and Mike,

    Ok, I understand about the new tab thing. Maybe if I study the way it works I can apply my own tag after the fact.

    On Mikes suggestion. It seems that it is a big deal for a small return on creating a share from the add-in. But I think Mike hit on the same topic I mentioned a few posts earlier. Some of the required settings are not that intuitive and don't have a lot of instructions while in the heat of setup. I feel many of us are tweakers and understand basic web site configs or can figure it out in a few minutes. But there will be many that will want to unwrap this Add-in and have it work in 2 minutes. Maybe a little description regarding the share should be put in in a pop-up or something. Just to help out with the website challenged.

    Since the shared folder set up is the foundation for all webs created, maybe it should be the first message you see when you go to add a web page. Maybe even have a "Don't show this warning again" check box..????

    Don't get me wrong. 99% of Whiist is well documented. There are just a few areas that are not very clear and could use some more directions.

    Wednesday, June 20, 2007 11:46 PM
  • I love this add-in..looking forward to the next release but the point made above is hugelycritical for those who (like me) were not aware of that default. My problem was also compounded by my ISP blocking port 80 which I had to get round..


    Very worthwhile adding in the comment on index.htm to the guide though and also some reference to the , what is supect is the norm , ISP's blocking port 80 will be useful for noobs...and others less in the know re. IIS server..


    The only thing I have found is not right is that when i click on a pciture to display it in full nothing seems to happen yet I see the javascript thing.. I assume it's probably as a result of the javascript though on my machine ..since no-one else has seen this...


    GREAT Work mate ..cheers...

    Saturday, June 23, 2007 11:38 AM
  • This very nice add-in seems to be working fine - and thanks for  that - but can anybody explain why some of my friends can reach my domainname.livenode.com and others not?
    Troels Bjerre

    Monday, June 25, 2007 12:45 PM
  • The EXACT same thing happens to me and it is very frustrating.


    Only about 25% of the folks I invite to view our home server's web site can actually view it. The remaining 75% simply get an error in their web browsers stating that the page doesn't exist. It's really hard to get my wife on board with the WHS when more than half of the folks she invites to view our pictures remotely can't even access them. It's so maddening that it makes me want to toss the server out the window. I have to keep reminding myself that it is still a beta product and simply hope that Microsoft will get the problem fixed for the final release.
    IMHO, it is either a problem with the livenode.com service or it is a problem with the certificate error that folks get when visiting the site (perhaps our friends and family are using an older browser that can't cope with the invalid certificate???). Personally, I think Microsoft is crazy if they are going to allow WHS to go RTM with the certificate error problem. I know they claim that it is "by design", but it's ridiculous if it results in the majority of your friends and family not being able to access the server remotely.
    For some of our friends and family members I've been able to help them access the server by simply having them go into the Internet Explorer Options dialog and reset all of the zones on the Security tab back to their defaults. It's funny how all those settings get changed away from their defaults on their computers when 99% of them have absolutely no idea what any of the settings mean or what they even do (i.e. there must be a lot of software packages out there that are going in and changing the security settings away from their default values and that in turn prevents the users from being able to access our WHS remotely).
    Sorry to ramble on about this one, but at least you know that you are not alone with your problem.

    Monday, June 25, 2007 4:26 PM
  • WOW - same/similar thing with me too....



    I found that when i go to the WHS Console , click on settings ....click on Remote Access , Click on details in the Domain Server section...it runs through it's tests and puts a big tick up...then go to your browser , retype the url and lo it works....do it several times more and it stops finding the site. Go back and repeat the above..it works again for a fw refreshes beforeit loses itself again...


    It's a serious problem and one that warrants some investigation.


    Don't know if it is ISP or router specific but in my case I am running BT's Internet service with their Homehub router....is that familiar?

    Monday, June 25, 2007 5:48 PM

    I agree that the certificate error is VERY ANOYING and should be fixed .


    As to  my XXX.livenode site it has never been unavailable at anytime since I set it up.


    A possible approach might be to set  up your site using DYNDNS ( its free) and see if you continue to have the same problem.


    I think a thread should be started on the subject of the Certificate Error and hopefully we can get The WHS team to respond on how and When this will be fixed.


    Monday, June 25, 2007 6:13 PM
  • I have the lest issue with Fire Fox. It gives me a little box to view the certificate or continue to the site.

    Now, IE-7 sucks!  Every time I open a new instance of the browser and try to go to my Log on page or my Whiist pages, I get the error page that gives me the option of continuing to the site or not. Also, I get the certificate error, which I installed the certificate, but makes no difference. But after that I can see aaaaalllll my web pages on WHS as long as I don't close that browser instance.

    I also added my Livenode site to "Trusted Sites" under Tools>Security>trusted sites. Uncheck the "Require server verification (httpsSmile for all sites in this zone" or it will not allow you to add a site that starts with Https:.

    Oh, I have always had a DNS account forwarding to WHS as a redundant address in case Livenode failed, but it makes no difference. You still get the same certificate error using IE or FFox.

    Basically, I have the least trouble with FireFox 2.0 and up.

    WHS Team should address this certificate issue......soon. .
    Monday, June 25, 2007 11:12 PM
  • I had lots of problems in this area and found that in my case (Linksys WRT 54G) it was down to upnp and traffic not being correctly forwarded.

    I turned off the router configuration in WHS, gave my server a fixed IP on the LAN, and then manually configured my firewall to forward the correct ports.

    Haven't had a problem since! (touch wood).
    Tuesday, June 26, 2007 2:05 AM
  •  Andrew Grant wrote:
    I had lots of problems in this area and found that in my case (Linksys WRT 54G) it was down to upnp and traffic not being correctly forwarded.

    I turned off the router configuration in WHS, gave my server a fixed IP on the LAN, and then manually configured my firewall to forward the correct ports.

    Haven't had a problem since! (touch wood).
    Well I done the same as you Andrew and it still has problems..it's not your software I know that much. I just find it odd that a number of us fails to have their sites resolved ..

    I think it's a bug in Livenode tbh but thats just a guess.....

    Tuesday, June 26, 2007 9:46 AM
  • Yes, I did the same thing as Andrew some months ago. Dedicated IP on WHS and forwarded ports accordingly. I have little issues and I always get to my site!

    I really don't think its LiveNode because (Like I listed in my last post) I have a separate DNS address and I get the same thing.  I believe it's the way WHS creates and handles the security certificates.

    Read my last post on adding addresses to Trusted Sites in IE. That may help. At least you only have to click the Ignor button and you should get in.  FFox is easiest. Just click acept cert and I'm in.

    I'm no certificate guru, but this is what I've found...
    Tuesday, June 26, 2007 11:23 AM
  • Andrew,

    been a bit busy since I installed RC so haven't updated...   I haven't had any recent issues with Whiist, all websites and links created work a treat! 



    Thanks again.

    Sunday, July 1, 2007 1:29 PM
  • This is an excellent add-in and just what I was looking for.


    Is there any way of making it (the photo album) work with RAW (Nikon) files?  Probably a cheeky ask, but...



    Wednesday, July 4, 2007 8:54 PM
  • Andrew,

    I really like your Add-In and think it provides the solution for which I have been looking for a long time. I have had problems, though, getting my websites up and running. I go through your webiste wizard and it creates a placeholder for me; no problem so far. But, when I go to replace the placeholder index.html file in the sub-folder with my own index file, I get the following error report when I try to view the page on the site:

    Directory Listing Denied

    This Virtual Directory does not allow contents to be listed.

    When I click on the index.html file in the sub-folder, the site comes up just fine. What am I doing wrong here?

    Thanks, Ford
    Thursday, July 5, 2007 12:51 AM
  • Ford,


    Can you get to the page by typing in the entire url in your web browser...ex...www.test.com/index.html .  If you can get to the page that way then your IIS settings need to be changed, check out this article from Microsoft about what is called the default document file and how to change it:  http://support.microsoft.com/kb/185380  , if you don't see a index.html in your default documents file you will have to add it.  Hope this works out for you......

    Thursday, July 5, 2007 1:33 AM
  •  judgeschambers wrote:
    Yes, I did the same thing as Andrew some months ago. Dedicated IP on WHS and forwarded ports accordingly. I have little issues and I always get to my site!

    I really don't think its LiveNode because (Like I listed in my last post) I have a separate DNS address and I get the same thing.  I believe it's the way WHS creates and handles the security certificates.

    Read my last post on adding addresses to Trusted Sites in IE. That may help. At least you only have to click the Ignor button and you should get in.  FFox is easiest. Just click acept cert and I'm in.

    I'm no certificate guru, but this is what I've found...


    Good write up on Certificate issue



    Thursday, July 5, 2007 5:35 PM
  • Trowhill,

    Thanks; I cannot get to the site by entering the entire URL. I will check out the link you cite and report back if that solves the problem. I should note that I did the photo page as Andrew outlined and no problem with it. That's why I am confused.

    Best, Ford
    Friday, July 6, 2007 12:14 AM
  • Trowhill,

    I have been able to post the site to other servers with no problem at all. Only with Whiist and WHS I am having problems.  Just to make sure I am doing this correctly:

    - I use the wizard in Whiist to add the site to WHS in a sub-folder (//server/public/websites/homepage),
    - I delete the index file placeholder that Whiist put in the sub-folder (homepage),
    - I add the site to the sub-folder (homepage).

    Am I doing anything wrong? Should I place the site in a different sub-folder?

    Friday, July 6, 2007 3:46 PM
  • Andrew,

    I have been using Whiist for a couple weeks now and it works great.  I just have 1 small issue.  I was testing out some things and trying to setup a few websites.  I set them all to have a link on the public WHS page.  I ended up deleting all of the test sites I created using the remove button in your tool, however, the links on the public page are still there.  It seems that it didn't clean everything up when I did the remove.



    Friday, July 6, 2007 3:59 PM
  •  ROUZA wrote:

    judgeschambers wrote:
    Yes, I did the same thing as Andrew some months ago. Dedicated IP on WHS and forwarded ports accordingly. I have little issues and I always get to my site!

    I really don't think its LiveNode because (Like I listed in my last post) I have a separate DNS address and I get the same thing. I believe it's the way WHS creates and handles the security certificates.

    Read my last post on adding addresses to Trusted Sites in IE. That may help. At least you only have to click the Ignor button and you should get in. FFox is easiest. Just click acept cert and I'm in.

    I'm no certificate guru, but this is what I've found...

    Good write up on Certificate issue



    Yeah, already seen this. It only works on PC's that don't have console installed. I tried it on one of my pc's with console installed anyway thinking it might work...big mistake. It actually blocked me when using IE7.  Had to get Philip to show me how to remove the certificate...LOL.
    Friday, July 6, 2007 8:38 PM
  • Hi Fordvw,

    Perhaps this will help:


    In particular check out the part about index.htm in "Working with your site". The main page of your site must be called index.htm or default.htm (or default.asp if it's an ASP page).

    Sunday, July 8, 2007 2:24 AM
  • Hi Buzz,

    Yes this is a known issue. A future version will have more options relating to cleaning up links and content when you remove a site.

    You can remove the links using the link interface, sorry for the inconvenience.

    Sunday, July 8, 2007 2:25 AM
  • Andrew,

    Thanks. I think I'm on to the problem; I have created a website with PowerPoint and it works great with Whiist on WHS - no problems.

    I have created a different one using iWeb on  Mac. It works well on other servers. However, with Whiist is doesn't work. I get a Directory Listing Denied error. I have followed all the instructions correctly and can get it to work elsewhere. There is something going on between iWeb, Whiist and WHS. Any thoughts?

    You can see for yourself at vonweise.livenode.com. I really appreciate your help and do really like Whiist.
    Sunday, July 8, 2007 3:54 PM
  • Hi Fordv,

    Can you zip the contents of the website (everything you place in the folder) and email them to me at mail@andrewgrant.org?

    I'll take a look and see what's going on.

    Sunday, July 8, 2007 4:42 PM
  • Hello Andrew!


    I am using the Bertrand Le Roy’s Album Photo Handler with whiist, and i am wondering about something. May be a little off topic.


    I was at a car show the other day, and took many pictures. I have renamed them so that pictures of one car has the same name tag and a number. This makes viewing the pictures less confusing. But I see that the photo handler sort by date. Is it possible to edit some of the files to sort by name?






    Sunday, July 22, 2007 11:32 AM
  • Hi Ford,


    I checked out your WHS website and now I'm green with envy.  Here's a question for the group: How do you change the WHS default Home Page to a personal Home Page?  Andrew's add-in works fine, and I have links on the default page to photo albums and a test website, but I'm stuck looking at someone else's nice family on the WHS default page.  Any suggestions to this site builder noob will be greatly appreciated. 


    Andrew......I have you as the current favorite in the Code2Fame Challenge.



    Thanks, Fred

    Tuesday, July 24, 2007 2:39 PM
  • Fred,

    It was really simple; I replaced the index page of the the main public page that came with WHS with my own. I put links on it for Remote Access and my own pages. Andrew's Add-In makes it simple, as it gives you the page references in the console (I actually did a drag and drop with it).

    Also, I made the site with iWeb on a Mac which is really easy to do. I used Hamachi to connect the Mac to the WHS machine and uploaded the files for the site.

    Hope this helps.

    Best, Ford
    Tuesday, July 24, 2007 11:08 PM
  • Thanks Ford...I found the default htm using IIS.  Now I'll get my 12yo working on a suitable replacement to pass off as my own work!.......Fred

    Thursday, July 26, 2007 1:33 PM
  • k.i.s.s.

    Saturday, July 28, 2007 8:13 PM
  • hi,


    I've got a little problem with creating or editing websites with whiist.

    Everytime I click the browse button I've get the error "Exception thrown" and the console shuts down.

    Does someone knows a solution for this?



    Friday, September 28, 2007 8:11 PM
  • What version are you using?




    Friday, September 28, 2007 11:35 PM
  • Andrew,


    I am having the same problem except I do not get an error. I can write the name of the site (or link) I am trying to create, but when I click the browse button, it locks up and then I loose connection to me server. If I RDC in to my server, and try it through that console, the consle jsut shuts down.


    I am using 0.7.8 with WHS RC1.




    Saturday, October 6, 2007 6:12 PM
  • Hi,

    Please see this thread;


    If you could post followups to that thread that would also be great.

    Sunday, October 7, 2007 12:25 AM
  • Is there any way to allow http connections to the sites I create. I dont want people to get a certificate error when they are viewing a photo album I create. I can see MS wanting ssl on the login page, but it seems stupid to require it on every page, especially when they havent fixed the error.
    Tuesday, October 23, 2007 7:50 PM
  • I first posted this to the general software forum, but then realized that this thread would be more appropriate...


    Has anyone had any luck installing Whiist on the HP MediaSmart? I tried unsuccessfully twice. Both times the installation deleted my HP software-based Webshare and I could not log into some portions of the site. Both times I had to perform a server restore. My guess is that the installation files for Whiist share some of the same names as the HP installed files.

    I thought I'd check to see if anyone else had the same experience and what people would recommend as a program to host additional webpages (besides the Webshare) on the HP MediaSmart servers without altering the Webshare that I would like to retain for sharing photos with family.


    Thanks for any suggestions.


    Sunday, November 25, 2007 8:51 PM
  • I can tell you that i have successfully installed Whiist on MediaSmart without any problems. The only noticable difference though from Whiist on the MediaSmart vs. Whiist on my RC is that in MediaSmart, it has the HP sites and links listed in  the Whiist control panel. So as long as you dont mess with those, you should be all right.


    In terms of installation, i didnt do anything special. I have the default/homepage site set as the WHS homepage and not one of the HP sites - its possible it could be that but i'm not a developer so i'd have no idea... besides that i really dont have anything eles to say other than make sure you have the latest version of Whiist (so if your using a copy you downloaded over the summer then perhaps try to download a new msi)


    Good luck



    Monday, November 26, 2007 3:47 AM
  • Hey jpearl,

    Can you tell me the names of the HP sites in Whiist? I'll add some code to "hide" them to avoid accidents, the same as I do for the regular WHS sites.


    Tuesday, November 27, 2007 12:19 AM
  • Tuesday, November 27, 2007 12:54 AM
  • Thanks Andrew and jpearl,

    I appreciate your feedback.  Maybe there is some credance to your proposal that you had a different experience because you "have the default/homepage site set as the WHS homepage and not one of the HP sites."  I, on the other hand, had my default page pointing to the HP site. 


    It could also be something specific to my machine.  I may wait until Whiist is updated to include the code that hides the name of HP sites.  


    Looks like a good product and everyone has great things to say about it, so I will likley try for a third attempt.





    Tuesday, November 27, 2007 4:52 AM
  • Here is a link to another forum where a user had the same experience installing Whiist on HP MediaSmart. 



    Tuesday, November 27, 2007 4:57 AM