locked
"Connection Disabled", trying to connect to remote pc RRS feed

  • Question

  • WHS PP1
    Home machines run Windows Vista Ultimate SP1, no firewall software (except the one that comes with Vista) - the "Remote Desktop" port is open on the fw.

    I have searched and found the common answer that I need to enable Remote Desktop for my home pc in order to connect to it remotely through the web interface. I have done this, and yes, I can connect using RDC from another PC to my HOME PC.

    I also searched and found the requirement that I need to set the Remote Desktop to allow any type of connection (less secure). 

    But yet, when I log into WHS' web interface, it shows "Connection Disabled".  I can connect to my WHS by using the "Connect to your Home Server" option.  But all of the home pcs show "Connection Disabled".

    How do I get it to change this status?

    I have rebooted the home pc several times.  Tried loggin in and sitting idle.  Tried logging out, and letting the pc sit idle.  Etc.



    Bonus points to the person that tell me how to leave my home pc in a "suspended" or "Vista Hybird (as I use)" state, and wake it up remotely when I want to connect.

    Eric A. Duncan http://eduncan911.com
    Monday, October 20, 2008 3:07 AM

Answers

  • eduncan911.com said:

    Sorry I did not mention it before, but I already have "Allow remote connections from my computers running any version of Remote Desktop (less secure)" selected.  Always been at this setting.

    And yes, I can connect to my clients internally from one client to another client using 3389 - it is how I verified everything is working.


    Now, what does "from outside your LAN" mean?

    I believe what brubber means is did you try the Remote Access website from somewhere other than your household (friend's house, Starbucks, etc)?

    eduncan911.com said:

    I have 3389 and 4125 open to my WHS (as well as 443).

    Opening 3389 in your router is not necessary.  The only ports that you need to forward to your server are 80, 443 and 4125.  I would recommend you close port 3389 in your router.

    eduncan911.com said:

    I cannot have 3389 open pointing to each internal client machine as 3389 can only be routed to 1 IP obviously.

    I thought WHS's web interface for connecting to other PCs would pipe or route that RDC through the web's interface?

    That's correct.  It uses port 4125 (Remote Web Workplace).

    eduncan911.com said:

    Or are you saying that WHS' web interface for connecting to clients actually needs 3389 open to each client!?!?!  No way.

    No, that's not correct.

    eduncan911.com said:


    http://eduncan911.com



    Friday, October 24, 2008 4:10 AM
    Moderator

All replies

  • eduncan911.com said:

    WHS PP1
    Home machines run Windows Vista Ultimate SP1, no firewall software (except the one that comes with Vista).

    I have searched and found the common answer that I need to enable Remote Desktop for my home pc in order to connect to it remotely through the web interface. I have done this, and yes, I can connect using RDC from another PC to my HOME PC.

    But yet, when I log into WHS' web interface, it shows "Connection Disabled".  I can connect to my WHS by using the "Connect to your Home Server" option.  But all of the home pcs show "Connection Disabled".

    How do I get it to change this status?

    I have rebooted the home pc several times.  Tried loggin in and sitting idle.  Tried logging out, and letting the pc sit idle.  Etc.



    Bonus points to the person that tell me how to leave my home pc in a "suspended" or "Vista Hybird (as I use)" state, and wake it up remotely when I want to connect.


    Eric A. Duncan http://eduncan911.com




    First thing I would check is make sure Allow remote connections from computers running any version of Remote Desktop (less secure) is checked on your Vista PCs.  Once you've done that, try rebooting both the clients and the server.
    Monday, October 20, 2008 3:12 AM
    Moderator
  • Did you try the remote access from outside your LAN? If not please do. Also please check if port 3389 is allowed in the Vista firewall and if there are any users that are allowed remote acces.


    For you other question, there's many utilities, free and commercial that will allow remote wake up. Just search the web for WOL or Magic Packet.
    Monday, October 20, 2008 5:29 AM
    Moderator
  • Sorry I did not mention it before, but I already have "Allow remote connections from my computers running any version of Remote Desktop (less secure)" selected.  Always been at this setting.

    And yes, I can connect to my clients internally from one client to another client using 3389 - it is how I verified everything is working.


    Now, what does "from outside your LAN" mean?  I have 3389 and 4125 open to my WHS (as well as 443).  I cannot have 3389 open pointing to each internal client machine as 3389 can only be routed to 1 IP obviously.

    I thought WHS's web interface for connecting to other PCs would pipe or route that RDC through the web's interface?  Or are you saying that WHS' web interface for connecting to clients actually needs 3389 open to each client!?!?!  No way.


    http://eduncan911.com
    Thursday, October 23, 2008 10:54 PM
  • eduncan911.com said:

    Sorry I did not mention it before, but I already have "Allow remote connections from my computers running any version of Remote Desktop (less secure)" selected.  Always been at this setting.

    And yes, I can connect to my clients internally from one client to another client using 3389 - it is how I verified everything is working.


    Now, what does "from outside your LAN" mean?

    I believe what brubber means is did you try the Remote Access website from somewhere other than your household (friend's house, Starbucks, etc)?

    eduncan911.com said:

    I have 3389 and 4125 open to my WHS (as well as 443).

    Opening 3389 in your router is not necessary.  The only ports that you need to forward to your server are 80, 443 and 4125.  I would recommend you close port 3389 in your router.

    eduncan911.com said:

    I cannot have 3389 open pointing to each internal client machine as 3389 can only be routed to 1 IP obviously.

    I thought WHS's web interface for connecting to other PCs would pipe or route that RDC through the web's interface?

    That's correct.  It uses port 4125 (Remote Web Workplace).

    eduncan911.com said:

    Or are you saying that WHS' web interface for connecting to clients actually needs 3389 open to each client!?!?!  No way.

    No, that's not correct.

    eduncan911.com said:


    http://eduncan911.com



    Friday, October 24, 2008 4:10 AM
    Moderator