locked
Server 2010 Working Hours RRS feed

  • Question

  • Hi,

    I'm having trouble with the working hours in Project Server 2010 and Project Professional 2010.

    I originally created projects in project 2010 then tried to move them to server. I had changed the working hours in server to 9-5 but didnt think of changing them in project as well, and it turned out that they were 8-5. So when i tried to save them to server, the dates all changed.

    So, I changed the calendars in project to 9-5 to match server and re-created my projects using project but via server.

    Everyhting worked fine until i tried to save a project made by a colleague into server. Her project instance is set to the standard 8-5 calendar, so the dates all messed up when i tried to save to server which is on 9-5.

    So, i decided to change back to 8-5 in server and project so that i could easily import projects created by other people. In reality the working hours are not important here as we will not be completing hourly timesheets or hourly work allocations.

    The reaosn i'm asking for help is that now even though both sides should be saying 8-5 i'm still getting instances where i choose a date range but project thinks that the date range i choose will take more days than are in that time period. I must have missed a field somewhere but i dont remember another place i changed it last time. Can anyone tell me all the fields that i need to check to ensue they are all saying the same working hours please?

    Thanks, Bonita.

     

    p.s. not sure if this will help, but it seems to be fine with my simple projects, but the ones where i have allocated resource or where there are sub tasks under a summary task seem to be the ones which are going wrong...

    • Changed type BonitaD Monday, February 7, 2011 9:14 AM
    Friday, February 4, 2011 4:35 PM

Answers

All replies

  • Bonita,

    Apply the enterprise calendar with the change working hours to the task in your project and publish.

    also you might consider it to convert this post to the Question to attract more users to response.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Sunday, February 6, 2011 1:36 PM
  • Hi Khurram,

    Thank you for your response.

    I can only see one calendar available which is the standard calendar. It was the standard calendar that I edited in enterprise calendars in server, but it doesnt call it an enterprise calendar in project. Is this right or should i be looking somewhere else?

    Thanks.

    Monday, February 7, 2011 9:46 AM
  • Hi Bonita,

    If you have made the changes in the Standard calendar, apply the same calendar to your tasks in the project. I was calling it enterprise because your Project Prof is connected with the Project server. Let me know if its helps, thanks.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Monday, February 7, 2011 9:58 AM
  • OK, thanks. I had applied that calendar to the project already and when i go back inot the project and look at the calendar, it shows the correct 8-5 hours, but in the options it says 9-5. When i change this back to 8-5 this is when the dates change. Should i let them change and then publish? Will it then sort itself out?
    Monday, February 7, 2011 10:00 AM
  • Bonita, i hope you have already followed the below mentioned steps to do the change in calendar, just to verify please go through the steps to create/change calendar.

    To create/change Enterprise calendar:

    1. go to the PWA 
    2. Server settings
    3. Under the heading Enterprise Data,
    4. click Enterprise calendar
    5. Select the calendar and click Edit Calendar
    6. the calendar will be open in Project professional for you
    7. do the changes in the calendar, save and checkin back to the server.

    Once you will do this, you PM has to follow the steps to apply the changed calendar:

    To apply the changes your PM needs to;

    1. open the project,
    2. rite click on the task,
    3. open the task information
    4. select the Advance tab, and select the calendar from the drop down
    5. repeat this for all the task in the project
    6. the change tasks will be highlighted
    7. save and publish the project to reflect the changes to the reports.

     

    The best is to make a copy of standard calendar and do the changes in that calendar and call it may be Standard Calendar (9-5). This way the PM could have both the options and will use as per his need.

    Let me know if this help mate.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Monday, February 7, 2011 10:12 AM
  • I had followed your original steps to edit the standard calendar, but when i was applying it in project i went to 'change working time' in the project tab.

    I have now updated the calendar to the standard calendar in all the tasks as you described.

    However, the dates still aren't the same as they used to be.

    e.g. I have a task which i have given 2 weeks as a timeframe for. It started on tues 01/02/2011 and ended mon 14/02/2011

    now that i have updated the calendar, it says it will still start on tues 01/02/2011 but it will end on fri 11/02/2011 (we work from mon - fri)

    I have checked the options tab in the change working times window and it still says 9-5 (i changed everythig else to 8-5 and it shows this in the first window of the change working times  section as it pickes this up from the stadard calendar) if i change this to 8-5, my dates change again.

    If i manually change the dates to 01/02/2011 - 14/02/2011, it says the duration is 1.98 wks.

    If I manually change the duration to 2 weeks, it changes the dates to 01/02/2011 - 15/02/2011.

    Any ideas?

    Monday, February 7, 2011 11:27 AM
  • Bonita,

    Try this:

    1. Double Click on the task.
    2. On the task information box, click Advanced
    3. Check the box which says "Ignore Resource Calendars"
    4. Say OK, and see if this fixes your dates.

    This may not be a best practice long term, but atleast you will know if this is the issue.

    Monday, February 7, 2011 3:43 PM
  • Thanks Prasanna.

    I assume that the resource calendars would be looking at other requiremnts for this resource in other projects. If this is the case, this wont help in this project as no resource has been allocated in it.

    When i wrote this question it only seemed to be happening to ones with resource allocated but it is also happening in this project which has no resource or sub tasks.

    Monday, February 7, 2011 4:25 PM
  • Bonita:

    Unfortunately, the system doesn't recalculate work for tasks when you change the calendar, rather it adjusts duration as you have seen. So, what's happening is your schedule is just getting all messed up. In order to fix this, you need to display your date fields with time showing, as you may need to adjust date and time, not just dates. Futher, you need to be keeping an eye on work values. Even if you do not care to use work, the system calculates it and recalculates it when you make certain changes.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Tuesday, February 8, 2011 3:06 PM
  • Thank you Gary. Sorry, how do i get it to show the time as well?
    Wednesday, February 9, 2011 11:05 AM
  • Click the File Tab and the back stage should open to the General page where you can set the date format. While you are there, click the schedule tab and make sure that this matches your standard calendar.
    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, February 9, 2011 1:58 PM
  • Yay! It works!

    Thank you everyone!

    :)

     

    Wednesday, February 9, 2011 2:15 PM