locked
PowerShell cmdlet Import-CrmOrganization RRS feed

  • Question

  • I am not able to import an organization via the PowerShell cmdlet Import-CrmOrganization. Here is more info regarding how I am using this cmdlet:

    1. Have a CRM database - to be imported - ready in SQL Server.

    2. I am myself a deployment admin

    3. I have provisioned multiple CRM orgs on this SQL Server without any problem. Just the cmdlet is not working.

    4. I have launched the PowerShell command prompt with Administrative permissions.

    Here is the error that I am seeing. I have tried UserMappingMethod of both ByAccount and KeepExisting:

    Import-CrmOrganization : The Deployment Service cannot process the request because one or more validation checks failed
    .
    At line:1 char:23
    + Import-CrmOrganization <<<<  -SqlServerName "d-crmdb" -DatabaseName "Testblank_MSCRM" -SrsUrl "http://d-crmdb/ReportServer" -DisplayName "TestBlank" -Name "TestBlank" -UserMappingMethod "KeepExisting"
        + CategoryInfo          : NotSpecified: (:) [Import-CrmOrganization], FaultException`1
        + FullyQualifiedErrorId : System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.Deployment.DeploymentServiceFaul
       t, Microsoft.Crm.PowerShell, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]],Microsoft.Crm.Pow
      erShell.ImportCrmOrganizationCmdlet

    I have tried two versions of this command but both throw the exception above:

    Import-CrmOrganization -SqlServerName "d-crmdb" -DatabaseName "Testblank_MSCRM" -SrsUrl "http://d-crmdb/ReportServer" -DisplayName "TestBlank" -Name "TestBlank" -UserMappingMethod "KeepExisting"

    Import-CrmOrganization -SqlServerName "d-crmdb" -DatabaseName "Testblank_MSCRM" -SrsUrl "http://d-crmdb/ReportServer" -DisplayName "TestBlank" -Name "TestBlank" -UserMap "KeepExisting"

    Has anybody had success using the PowerShell cmdlet above?

    Thanks,

    Adhish


    Adhish Gupta

    Wednesday, October 10, 2012 8:23 PM

All replies

  • Hi,

    have you also tried importing the organization using the Deployment Manager and was it successful?

    If the error occurs only in the Cmdlet, then I would suggest turning tracing on the CRM Server on, so that maybe you can see what the exact error is.

    In case you are not familiar with tracing, you can find some info here.

    Greetings,

    Pavlos


    Please mark this reply as an answer and vote it as helpful if it helps you find a resolution to your problem.

    Thursday, October 11, 2012 6:56 AM
  • Hi,

    You running the powershell with a user account that is the deployment administrator?


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Thursday, October 11, 2012 8:23 AM
    Answerer
  • Thanks! I was hoping to get quick tips before I start doing that. But thats not a problem.

    Adhish Gupta

    Thursday, October 11, 2012 6:40 PM
  • Yes.

    Adhish Gupta

    Thursday, October 11, 2012 6:41 PM
  • Has exact same issue. 

    CRM 2013 on prem.

    That is what I have in event log.

    Microsoft.Crm.CrmException: The Deployment Service cannot process the request because one or more validation checks failed. at Microsoft.Xrm.Sdk.Deployment.DeploymentRequestChecker.Validate() at Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationRequest.PerformUserMapping() at Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationRequest.PerformDeferredProcessing() at Microsoft.Xrm.Sdk.Deployment.QueuedOperationProcessor.ProcessingMethod()

    Wednesday, May 28, 2014 3:54 PM
  • Are you able to Access Deployment Service , if not did you check XRMDeployment settings in IIS

    you need to check your CRM web server IIS settings and make sure XRMDeployment is not configured in Hidden Segments in IIS, Follow below steps to remove/add XRMDeployment setting in IIS

    •Open Internet Information Services(IIS) Manager
    •Expand Server on left navigation
    •Expand Sites on the Left Navigation
    •Click on Microsoft Dynamics CRM
    •Click on “Request Filtering” icon in IIS on right side window
    •Click on “Hidden Segments” tab on Request Filtering window on right side
    •If “XRMDeployment” exists then select “XRMDeployment” and right click on “Remove” and say “Yes” to remove “XRMDeployment” from Hidden Segments

    Monday, June 9, 2014 3:42 PM