none
can of worms, i swear. -_- ... RRS feed

  • Question

  • the following is my post in the Amazon Support forums:  this Taxmas, i decided to get for myself my first tablet.  i got a Fire HD 10, and i'm loving it.  small problem, though:  i plugged it into my HP 15 [Windows 10] laptop, and ... nothing but a notification on my Fire HD 10 ["Low Power Charger Connected:  Your Fire may not charge while in use." ... ... ...  i'm even using the usb cable that came with my Fire, and i have it plugged into a powered usb hub right now [i've tried it directly in my onboard USB 3.0 slots and in my onboard USB 2.0 slot]; nothing but that notification on my Fire HD 10.  my computer won't even pick it up just enough to install any drivers or software for it, and every forum post i've read elsewhere has expressed this, kind of, feud between Windows and Amazon--they blame each other, and neither will address let alone fix the problem.  fortunately, i have a program called Snappy Driver Installer:  i opened my Computer Management console, on Windows 10, and checked my device listing; as expected, i see yellow "Warning" triangles next to what are supposed to be the drivers for my Fire HD 10.  before using Windows to install/update these drivers, though, i checked Snappy Driver Installer; made certain i updated all of the driver packs that i have on my computer and downloaded the driver pack(s) i need for my Fire HD 10.  it comes up as "MTP Device", and when you try to update it through Computer Management [most people use Device Manager, which is a separate app], Windows says:  Windows found drivers for your device but encountered an error while attempting to install them; a service installation section in this INF is bad. ...  i imagine it's this error that's preventing Snappy Driver Installer from installing/updating this driver, also. ... ... ...  when i checked for my Fire HD 10 in my device listings, in Computer Management, it came up as both Fire [a "removable" media device] with a corrupt driver and MTP Device ["removable" media "tethered" with USB cable] with a corrupt driver.  when i read the error, "MTP Device:  a service installation section in this INF is invalid." my first thought, after posting it for help, was to run the System File Checker.  my system Command Prompt doesn't open up, today, so it's a good thing i have a copy of Command Prompt Portable from portableapps.com.  i ran that "as Administrator", tried to run SFC, and got this error, "Windows Resource Protection could not start the repair service," so i ran * C:\>DISM /online /cleanup-image /scanhealth * and that returned, "No component store corruption detected."  i tried SFC again, got the same error, and i'm running * C:\>DISM /online /cleanup-image /restorehealth * now, without too much hope.

    Thursday, March 15, 2018 11:43 PM

Answers