locked
Problem with Date Picker of Date Time field RRS feed

  • Question

  • I am facing an issue with the Date Picker(calender) on the CRM Form.Here is the issue.

    I have a custom date field attribute added on the account form which is aligned on the right most side of the form.Whenever i maxmize the form and when i select the date picker some part of the calender hides in the screen and is not visible to the user for e.g for 1 row in the calander user and only view and select only 5 days ,other 2 days hides behind the screen.

    I hope i have xplained the issue correctly.

    Any help regarding this issue is highly appreciated

    Thanks

    Mitesh

    Wednesday, November 10, 2010 9:29 AM

Answers

All replies

  • Dear Mitesh,

    I guess you need to specify fix width to your calendar control to have the full visibility of the whole control.

     

    Wednesday, November 10, 2010 12:16 PM
  • Ankit,

    Thanks for your response,

    How can we do that in Microsoft CRM?

    Wednesday, November 10, 2010 12:18 PM
  • Can you change the possition of an attribute on the form?
    Wednesday, November 10, 2010 12:21 PM
  • No..I cannot do that.It has to be Right Aligned
    Wednesday, November 10, 2010 12:23 PM
  • Do you have a Form Assistant on account form. If no then enable it.
    Wednesday, November 10, 2010 12:33 PM
  • Which browser are you using?

    Jai Ho CRM http://mscrmkb.blogspot.com Skype - amol.gholap

    Mark as answer if a post has answered the question
    Wednesday, November 10, 2010 1:16 PM
  • It looks like you're getting the IE 8.0 bug.  It can be fixed.  Check this link:

    http://blog.customereffective.com/blog/2009/11/date-field-lookup-cut-off-in-ie8.html

    • Proposed as answer by NateOne Wednesday, November 10, 2010 1:23 PM
    • Marked as answer by mitesh.mehta Wednesday, November 10, 2010 1:28 PM
    • Unmarked as answer by mitesh.mehta Friday, November 12, 2010 5:43 AM
    • Marked as answer by DavidBerryMVP, Moderator Saturday, December 11, 2010 1:16 AM
    Wednesday, November 10, 2010 1:23 PM
  • Natone,

    I visited the link provided by you and also the link which has hotfix -974455 . i could not find any msi for that hot fix.I also tried to re-install the Internet Explorer 8 but still the problem persists

    Please help me in getting this resolved.

    Thanks

    Mitesh Mehta

    Friday, November 12, 2010 5:47 AM
  • Mitesh,

    Did you do this on your users machines? (at the bottom of the Customer Effective blog posting)

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
    Create a new Key, and name it as follows:
    FEATURE_FORCE_POPUPS_ONTO_MONITOR_KB974537
    Within this key, point to New , and then click DWORD Value
    Type iexplore.exe for the name of the key
    Right-click iexplore.exe , click Modify and then type 1 in the Value data field

    Friday, November 12, 2010 9:21 AM
  • Hi

    Any help on this issue is highly apreciated..

     

    Thanks

    Mitesh Mehta

    Monday, November 15, 2010 9:56 AM
  • Mitesh, Did you make the registry tweak that I wrote above (which is also covered in the linked article above)??
    Monday, November 15, 2010 10:00 AM
  • yes i did that.But Its the same

    -Mitesh

    Monday, November 15, 2010 10:10 AM
  • If you've done that, and installed this update http://support.microsoft.com/kb/974455 then I don't know what else to try. 
    Monday, November 15, 2010 10:27 AM
  • Thannks for the response.

    I could not find any .exe file in this link which needs to be installed.

    Can you help me how i can install this hot fix.

    Thanks in advance

    -Mitesh

    Monday, November 15, 2010 10:34 AM
  • That update is included in the most recent update from MSFT because they are cumalative.  This posting describes how to check for updates on your computer:  http://blogs.msdn.com/b/ukdynsupport/archive/2009/10/26/calendar-control-cut-off-within-ie8-in-crm-4-0-web-clients.aspx
    Monday, November 15, 2010 10:40 AM
  • I am having the same issue here with IE8. I've done the reg fix but still no joy.

     

    How can I check on my computer that I have this fix installed?

    Thanks

    Monday, November 7, 2011 3:16 AM
  • Don't worry, I have fixed this issue. Just had to close down all my open IE windows and reboot after applying the reg fix.
    Tuesday, November 22, 2011 4:20 AM