none
Webservice response not getting assigned RRS feed

  • Question

  • Techies,

    I am calling a third party Guidewire Webservice in a C# windows application. I am having an issue where the response object/variables are always null even though i get the response logged in trace file. Also i see the response in SOAP UI.

    I have tried many different approaches here, but for some reason the response wont be assigned to output variables.

    I tried adding it as Service Reference with no luck.

    I tired generating proxy class files using SVCUtil and WSDL.exe, still no luck.

    I verified all the request and response headers to see if there is any mismatch and it seems to be matching. i am not sure why the responses wont get assigned to output variable.

    Trace file doesn't have any errors.. Can you please help on how we can proceed on this?

    Any pointers will be appreciated.

    Thank You!


    Wednesday, August 2, 2017 5:06 PM

All replies

  •  

    third party Guidewire Webservice

    I suggest that you contact the 3rd party vendor about your issues. You can post to the forum.

    https://forums.asp.net/28.aspx/1?WCF+ASMX+and+other+Web+Services

    Wednesday, August 2, 2017 7:54 PM
  • Hi Viral,

    According to your question is more related to Webservice , you could post a new thread to WCF, ASMX and other Web Services forum  for suitable support.

    The Visual C# discuss and ask the C# programming language, IDE, libraries, samples and tools.If you have some grammar or code errors, please feel free to contact us. We will try our best to give you a solution.

    Best Regards,
    Feih-7


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, August 3, 2017 7:03 AM