locked
Links to deletes accounts are not removed from custom entity RRS feed

  • Question

  • Hi

    I'm not sure what to make of this but perhaps someone can inlighten me. I have created a custom entity that has a lookup where you can select an account. If an account is selected and that account is later deleted the account link is removed from the custom entity view list but the (now broken) link is still on the entity form. If I click it I get the message that the account can't be found. Why is the link to the account only removed from the list view and not the form itself? I have installed rollup 6.

    /c
    Thursday, October 22, 2009 7:24 AM

Answers

All replies

  • Hi, Christian.

    You have to modify relation behaviour between entities in this way .

    Truth is opened the prepared mind My blog - http://a33ik.blogspot.com
    Thursday, October 22, 2009 7:41 AM
    Moderator
  • I set it to remove link but its only removed from the view and not the form.
    Thursday, October 22, 2009 7:42 AM
  • Hi.

    This will work for future actions but not for existing records. For existing records you have to manually clear lookup fields and save records.
    Truth is opened the prepared mind My blog - http://a33ik.blogspot.com
    Thursday, October 22, 2009 7:44 AM
    Moderator
  • Is the link only removed from the custom entity form as the account is actually deleted from the system and not just marked to be deletion? If I'm not mistaken the delete job only runs once every 24 hours.

    Thursday, October 22, 2009 8:07 AM