none
Code inserted in code block not formatted RRS feed

  • Question

  • I have noticed that code inserted in code blocks do not appear formatted correctly when viewed as posted to any of the forums that I have visited and posted to.  I always use a code block and normally specify C++ when posting C++ or C# code.

    What could be the problem and can anyone offer a fix?

    Thanks in advance
    Jer 29:11
    Wednesday, November 18, 2009 12:49 PM

Answers

All replies

  • It does not even work properly in IE8.

    Regards,
    Jai
    Wednesday, November 18, 2009 4:40 PM
  • It does not even work properly in IE8.

    Regards,
    Jai

    In a way that's good to know since I am using Firefox.  Still don't know why code is appearing in a large font and not properly formatted

    Jer 29:11
    Wednesday, November 18, 2009 5:53 PM
  • We have a bug on this. The font size issue was a bug regression caused by the new MSDN Re-design page. No ETA on a fix.

    Thanks.
    Forums Test Lead
    • Marked as answer by alleyes Friday, November 20, 2009 2:43 PM
    Thursday, November 19, 2009 10:41 PM
  • We have a bug on this. The font size issue was a bug regression caused by the new MSDN Re-design page. No ETA on a fix.

    Thanks.
    Forums Test Lead

    Don,

    Thanks for responding.  Are you suggesting that all code block posts since the re-design have this bug?
    Jer 29:11
    Friday, November 20, 2009 2:43 PM
  • Mostly for MSDN brand (http://social.msdn.microsoft.com/forums). If you look at the other brands such as technet (replace the msdn in the url) and or microsoft. The font issue after using the insert code block looks fine in the thread.
    Forums Test Lead
    Friday, November 20, 2009 5:30 PM
  • Is this knowledge widely known?  I have been receiving complaints about posted code and I am following all the guidelines. 

    Jer 29:11
    Friday, November 20, 2009 6:14 PM
  • Yes, this issue in particular is mentioned in the Announcement Forums (Latest Thread).

    http://social.msdn.microsoft.com/Forums/en-US/announce/threads


    Forums Test Lead
    • Marked as answer by alleyes Friday, November 20, 2009 6:33 PM
    Friday, November 20, 2009 6:30 PM