locked
CRM 2013 Javascript "There was an error with this field's customized event" - occurs on some page loads. RRS feed

  • Question

  • After our upgrade to CRM 2013, we are getting this error when the form opens but only occasionally. We are using Silverlight webresources and use the JavaScript Onload event to access the WebResource and call a method in it. This works ok most of time but the following can happen:

    1. Open a Create new form that has an onload event calling the webresource
    2. Message box pops up with the error "There was an error with this field's customized event"  Field: Window  Event:onload Error:  blank.
    3. Close the form window
    4. Open the form again, no issue reported and the onload function works.
    5. Open the form again with data or another new entity and the onload function works.

    It seems as if that form has been open / loaded before it works but first time it fails with this error.   This happens on any entity form that we have customized, first time the onload fails, subsequent times it works ok.  

    Has anyone come across this before?  Many thanks, Caz

    Tuesday, January 28, 2014 11:44 AM

All replies

  • Hi Caz,

    We have found the same issue in multiple tenancies post upgrade of a 2011 solution to 2013 and are still unable to identify the cause.  Have you had any further luck?

    kind regards

    PM

    Monday, May 26, 2014 7:28 AM
  • I also face the same error in CRM online version and have seen many others raise the issue. I read somewhere that it is an IIS related error( Rewrite module related). As i am accessing the online version and have no access to the IIS I I am not sure about this.
    Monday, June 23, 2014 3:45 AM