locked
CRM2011 UR17 - Backspace does not work RRS feed

  • Question

  • Hi,

    Today CMR2011 UR17 was installed and within all form fields (text) the backspace button no longer works.

    This only happens in IE11 - within Chrome/Firefox backspace does work.

    This is very annoying and users are complaining - hope you have a (hot)fix for this.

    Best regards,

    Jacco

    Wednesday, May 28, 2014 10:37 AM

Answers

  • Jacco,

    i am also having this issue so i called CRM support they showed me how to get the backspace button to work but if you have any scripts that run on load of a form it will break them.  so you need to weigh out which is more important to you.  the fix is go to settings then adminisration, choose system settings, then go to customization tab and check the box to run in latest version of IE.  that enables the backspace key.  BUT like i said messes up any scripts that run on entity load.  i am waiting to hear back from support for another fix for that.

    • Proposed as answer by Jacob Drager Thursday, May 29, 2014 12:42 PM
    • Marked as answer by J. Manneken Thursday, May 29, 2014 4:28 PM
    • Unmarked as answer by J. Manneken Thursday, May 29, 2014 4:28 PM
    • Marked as answer by J. Manneken Thursday, May 29, 2014 4:29 PM
    Wednesday, May 28, 2014 5:16 PM

All replies

  • Hi,

    This is most probably a known issue with UR 17 for CRM 2011.


    Admin QuikView Solution for CRM 2013

    Wednesday, May 28, 2014 10:38 AM
  • Hi Jacco,

    did you try running in Compatibility mode? if not try it to see if this resolve this issue while MS resolve this.

    to add your web site in Compatibility mode go to Tools - >Compatibility View Settings and add your CRM URL to this list.

    Hope this helps..


    MayankP
    My Blog
    Follow Me on Twitter

    Wednesday, May 28, 2014 3:02 PM
    Answerer
  • Jacco,

    i am also having this issue so i called CRM support they showed me how to get the backspace button to work but if you have any scripts that run on load of a form it will break them.  so you need to weigh out which is more important to you.  the fix is go to settings then adminisration, choose system settings, then go to customization tab and check the box to run in latest version of IE.  that enables the backspace key.  BUT like i said messes up any scripts that run on entity load.  i am waiting to hear back from support for another fix for that.

    • Proposed as answer by Jacob Drager Thursday, May 29, 2014 12:42 PM
    • Marked as answer by J. Manneken Thursday, May 29, 2014 4:28 PM
    • Unmarked as answer by J. Manneken Thursday, May 29, 2014 4:28 PM
    • Marked as answer by J. Manneken Thursday, May 29, 2014 4:29 PM
    Wednesday, May 28, 2014 5:16 PM
  • Jacob,

    Thank you for sharing this info! Luckily we don't have any scripts that run on load of a form. Changed to 'run latest version of IE' and backspace is working again!

    Thanks!

    Jacco

    Wednesday, May 28, 2014 6:10 PM
  • Another thing to remember.  When an update breaks things in CRM you can call support you will have to give them a credit card to start the call but they will not charge you after they determine the issue was caused by the update.
    Thursday, May 29, 2014 12:44 PM
  • Hi Jacob,

    We are starting the process of upgrading our 4.0 organization to CRM 2011 and when I saw this it concerned me a bit.  I have been able to reproduce the non working backspace "feature" but have not been able to see the onload script issue yet.

    I'm curious about how it screws up the onload scripts?.  I've set up a test onload script and it seems to run fine with the "run in latest version" box checked.  It's just an alert,a getValue and a setValue call so nothing too in depth but it works.  Can you expand on what scripts (or calls in the scripts) that don't run correctly for you in the onload with the checkbox set?

    Many Thanks!

    Monday, June 2, 2014 11:33 AM
  • Eric,

    i have scripts that run onload to disable specific fields so they cannot be changed after the form is created.  they do not load when the setting for using latest version of IE is set.  i have tried it in firefox and chrome as well but they still dont load.

    Wednesday, June 4, 2014 6:20 PM
  • Thanks Jacob!

    I don't know if it will help, but I just added:

    Xrm.ui.controls.get("yourfield").setDisabled(true);

    and it worked successfully in IE 11 (I don't have chrome or firefox per company policy so I can't test those) with the run in latest browser checkbox checked.

    Are you disabling the fields in a different way?

    Thanks!

    Eric

    Wednesday, June 4, 2014 8:44 PM
  • This is possible because of following fix in the UR17:

    When you have an HTML web resource on a form, the web resource is removed when clicking the backspace button in Internet Explorer

    http://blog.sonomapartners.com/2014/05/crm-2011-ur17-has-been-released.html

    Cheers

    Vikas

    Tuesday, June 10, 2014 10:22 AM
  • Interesting Info. Learnt new things today. Thank you.

    Thank you,
    Venkatesan Prabu.J
    KaaShiv InfoTech

    http://kaashivinfotech.com
    http://inplanttrainingchennai.com
    http://inplanttraining-in-chennai.com
    http://inplanttraining-in-chennai.com
    http://inplant-training.org

     

    Venkatesan Prabu .J www.kaashivinfotech.com http://venkattechnicalblog.blogspot.com/



    Tuesday, June 10, 2014 10:46 AM
  • I expierenced the same behaviour in UR18.

    My Problem occured on the following steps:

    -) Field is readonly 

    -) Onload script sets field setDisabled(true)

    -) Onchange script setDisabled(false)

    -> The HTML Tag readonly will stay on the field -> you can write in it and you can delete via "DEL" Key but Backspace will be ignored. 

    My Workaround:

    Set Field not readonly (because onload sets it disabled) -> now it works for me but it's a nasty bug...

    Cheers,

    Christoph

    Thursday, October 2, 2014 8:47 AM