locked
Error importing a report RRS feed

  • Question

  • When trying to import a report created in VS I am getting this error

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: The number of defined parameters is not equal to the number of cell definitions in the parameter panel.Detail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147188072</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>The number of defined parameters is not equal to the number of cell definitions in the parameter panel.</Message>
      <Timestamp>2016-10-24T15:34:18.194815Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>

    but if I try and import a blank report with no datasource it imports fine


    Dont ask me .. i dont know

    Monday, October 24, 2016 3:36 PM

Answers

  • Hi Pete,

         What version of Visual Studio are you using? What version of CRM are you using? On-prem or online? Are you able to preview your report from VS?

    I would start by checking VS for what version of the .NET Framework the project is built with, as a mismatch there seems to cause weird errors. You may also want to check permissions against the DataSource - is it possible that the account the report is running as doesn't have the necessary permissions to the data being returned by the FetchXML query?

    • Marked as answer by Pete Newman Wednesday, October 26, 2016 12:52 PM
    Tuesday, October 25, 2016 8:22 PM

All replies

  • Hi Pete,

         What version of Visual Studio are you using? What version of CRM are you using? On-prem or online? Are you able to preview your report from VS?

    I would start by checking VS for what version of the .NET Framework the project is built with, as a mismatch there seems to cause weird errors. You may also want to check permissions against the DataSource - is it possible that the account the report is running as doesn't have the necessary permissions to the data being returned by the FetchXML query?

    • Marked as answer by Pete Newman Wednesday, October 26, 2016 12:52 PM
    Tuesday, October 25, 2016 8:22 PM
  • Hi John,

    Thanks for the help, finally figured it out. VS2015 was causing the problem.  I went back and used VS2012 and it works fine


    Dont ask me .. i dont know

    Wednesday, October 26, 2016 12:54 PM