locked
Error while trying to create a workflow RRS feed

  • Question

  • Guys,

    When I try to create a new workflow I get this message:

    Exception of type 'System.Web.HttpUnhandledException' was thrown.


    Full Stack:

    [NullReferenceException: Object reference not set to an instance of an object.]
      at Microsoft.Crm.Application.Platform.CustomActivityInfoMetadata.GetActivityInfo(Guid pluginTypeId)
      at Microsoft.Crm.Web.SFA.WorkflowDetailPage.ConfigureCustomActivityStepMenu(CommandBarPopup addStepButton)
      at Microsoft.Crm.Web.SFA.WorkflowDetailPage.ConfigureWorkflowStepMenu(WorkflowStep workflowStep)
      at Microsoft.Crm.Web.SFA.WorkflowDetailPage.ConfigureMenus()
      at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
      at System.Web.UI.Page.HandleError(Exception e)
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest()
      at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
      at System.Web.UI.Page.ProcessRequest(HttpContext context)
      at ASP.quadrem_sfa_workflow_edit_aspx.ProcessRequest(HttpContext context)
      at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
      at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    

    Has anyone experience any similar error ?


    Yojan
    Thursday, March 24, 2011 10:57 PM

Answers

  • Just in case,

    This was solved. Problem was due that code was making reference to a clasee no existent anymore.

    So all workflows had to be removed.


    Yojan
    • Marked as answer by Yojan Wednesday, May 4, 2011 4:57 PM
    Wednesday, May 4, 2011 4:56 PM

All replies

  • Have you installed latest Rollup

    Check http://support.microsoft.com/kb/949256


    Mahain : My Dynamics CRM Blog
    Friday, March 25, 2011 4:19 AM
    Moderator
  • I have roll ups 5, 7, 8 and 9 in server.

    I am not sure what cause this problem. I can not create a new workflow :(

    Exception type: NullReferenceException   
    Exception message: Object reference not set to an instance of an object.
    Request information: 
    Request URL: http://pcrmweb/Quadrem/sfa/workflow/edit.aspx?id=68711bdd-cf8e-4cbf-81a9-d48348c23d80    
    Request path: /Quadrem/sfa/workflow/edit.aspx
       
    User host address: 10.16.6.63

    Has anyone experience any similar problem ? .. How can I see the real problem ?.

    I have three environmenst Development - Evrething is okay. UAT - okay too - PROD I can not create a new workflow

    Is there any entity that is used by a workflow so I can export/import from the other environments ?

    Thanks in advance

    AAP

     


    Yojan
    Saturday, April 2, 2011 8:18 PM
  • Hi Yojan,

    I think you are using a custom workflow. Are you passing any input parameters to your code? If you using input parameters, you have to check null for those values. CRM sends null when an input parameter value is not set.

    Thanks and Regards

    Ramu

    Osmosys

    Sunday, April 3, 2011 5:59 PM
  • Thanks for the reply,

    However this problem appears when I try to create a new workflow using the wizard interface.

    I select an entity write a name for workflow and click ok then problem appears.

    So problem is in: http://pcrmweb/Quadrem/sfa/workflow/edit.aspx?id=68711bdd-cf8e-4cbf-81a9-d48348c23d80

    Any system entity might be corruped ? so I can replace it from another env ?

    I'd appreciate any help.

     

     


    Yojan
    Monday, April 4, 2011 2:44 PM
  • Hi Yojan,

    One more check to do, Is your CRM Asynchronus service running?

    The hyperlink in your previous post is saying "IE cannot display this page". Please check once.

    Ramu

    Osmosys

     

    Tuesday, April 5, 2011 12:59 AM
  • Yes service is up.

    Because the workflows that were created previously are working normally without any problem. Besides plugin works normally too.

    Problem is when I try to create a new workflow. (Just in case server was restarted but with same results)

    Regards

     

     


    Yojan
    Tuesday, April 5, 2011 3:17 PM
  • Just in case,

    This was solved. Problem was due that code was making reference to a clasee no existent anymore.

    So all workflows had to be removed.


    Yojan
    • Marked as answer by Yojan Wednesday, May 4, 2011 4:57 PM
    Wednesday, May 4, 2011 4:56 PM