locked
Customizations and Solutions RRS feed

  • Question

  • Hi I am new to Dynamic CRM.

    I am trying to create a custom view of the CRM system.

    Steps 1: Solutions, Created new solution, added existing, Selected the required

    Step 2: Components, entities, leads, forms, new.

    I have created a new lead form.

    The problem:

    Before I created a new lead form. A lead form that came with the system, already existed and was set as "form type" main.

    I cant publish the new lead form that I have created, the existing form always appears.

    I have amended form order and tried to delete the original lead form but the computer says no. The component cant be deleted because of the configuration of its managed properties.

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #6F5FB4CCDetail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220970</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #6F5FB4CC</Message>
      <Timestamp>2013-06-20T13:16:20.1574441Z</Timestamp>
      <InnerFault>
        <ErrorCode>-2147160014</ErrorCode>
        <ErrorDetails xmlns:d3p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
        <Message>The 'Delete' operation on the current component(name='SystemForm', id='e3b6ddb7-8df0-4410-ac7b-fd32e5053d38') failed during managed property evaluation of condition: 'Microsoft.Crm.BusinessEntities.IsComponentDeletionEnabledCondition'</Message>
        <Timestamp>2013-06-20T13:16:20.1574441Z</Timestamp>
        <InnerFault i:nil="true" />
        <TraceText i:nil="true" />
      </InnerFault>
      <TraceText i:nil="true" />
    </OrganizationServiceFault>

    Anyone got a clue how to publish my own solution. I have checked all the add existing entities I added and they all have an existing form, so assume that I will have this problem with all customization.

    Any help would really be appreciated,

    Regards Matthew

    Thursday, June 20, 2013 1:23 PM

Answers

  • You can create new forms in CRM 2011, but in order to see them you'll have to secure them to a specific security role.  The user in that role will then see your form instead of the 'main' default form.  If you want everyone to see the custom form, you'll modify the main form itself and put that in your solution.
    • Marked as answer by mg00a Thursday, June 20, 2013 1:54 PM
    Thursday, June 20, 2013 1:30 PM

All replies

  • You can create new forms in CRM 2011, but in order to see them you'll have to secure them to a specific security role.  The user in that role will then see your form instead of the 'main' default form.  If you want everyone to see the custom form, you'll modify the main form itself and put that in your solution.
    • Marked as answer by mg00a Thursday, June 20, 2013 1:54 PM
    Thursday, June 20, 2013 1:30 PM
  • You can have multiple main forms. Each form can have a seperate set of security roles assigned to it to determine who can see the form itself. As an administrator you should be able to see all forms. As for what form shows up within the solution when you click on the main form link to list all forms for that entity you will see an option in the subgrid menu that is called form order. Click on this menu item and select main form set. From here you can order which form shows up by default. I would also remove access to the default main form"information" from everyone by the system administrator this way no one else will see the old main form.

    Thursday, June 20, 2013 1:40 PM
  • Thank you, tried these setting but must have missed something, retired on your response and it works.

    Thank you once again.

    Regards Matthew

    Thursday, June 20, 2013 1:54 PM