locked
multiple duplicate emails case is created RRS feed

  • Question

  • I have a workflow that sends out an email to myself every time a case is created. when I create a case, I get 10 duplicate emails in the Case's history as well as in my inbox. the email router seems to be running fine. does anyone know what might happen here? Am I missing anything for configuration? thanks.
    Wednesday, October 7, 2009 4:14 AM

Answers

  • I figured out cause of the issue. SMTP server on the Exchange server has not added the CRM server to relay for outgoing mail. Once I added it in and restarted SMTP server and it works great. Here's the link how to configure outgoing SMTP for Exchange:
    http://support.microsoft.com/default.aspx/kb/939402/en-us
    • Marked as answer by homerwire Wednesday, October 7, 2009 7:54 PM
    Wednesday, October 7, 2009 7:54 PM

All replies

  • hi
    well this might be an exchange problem.Just check if it is not the exchange server that creates the problem.

    Build in a check condition when the case is created maybe flag the record with a "bit" to set email done.the set the workflow to check for the bit value as well before sending the email.Test this to see if the email router sends out more than one message.

    Look at the email router log files for more info

    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Wednesday, October 7, 2009 4:45 AM
  • I just tested out the email router and noticed that the email router sends out more than one message IF the email address for an account/contact/user is external. If I were to update a customer account with my company internal email address, the email router only sends out one message. Is this the problem with the email router not able to send email to any external email address and as result it tries to re-send 10 times? thanks. 

    Wednesday, October 7, 2009 1:28 PM
  • I figured out cause of the issue. SMTP server on the Exchange server has not added the CRM server to relay for outgoing mail. Once I added it in and restarted SMTP server and it works great. Here's the link how to configure outgoing SMTP for Exchange:
    http://support.microsoft.com/default.aspx/kb/939402/en-us
    • Marked as answer by homerwire Wednesday, October 7, 2009 7:54 PM
    Wednesday, October 7, 2009 7:54 PM