locked
Default call destination for OC Public Beta RRS feed

  • Question

  • Hello,
    We recently migrated our OCS Beta 3 testing environment to OCS public Beta. We are testing Remote Call Control with our ToIP products. The first problem we have found is that the default behaviour in OC Public Beta is that clicking on the phone of a contact calls the destination contact computer, instead of the destinations PBX phone (as was the behaviour of Beta 3)

    Anyone knows how to configure the default destination device for a contact in OCS/OC public Beta?

    Thanks in advance,
    Cristian Alonso
    Friday, April 20, 2007 8:28 AM

Answers

  • Thom,
    we were stuck until someone answered this in another post.
    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1722226&SiteID=57

    The behaviour changed in Public Beta from Beta 3, that is why it stopped working in our environment.

    Thanks for your help,
    Cristian
    Friday, June 22, 2007 7:53 PM

All replies

  •  Cristian Alonso wrote:
    Hello,
    We recently migrated our OCS Beta 3 testing environment to OCS public Beta. We are testing Remote Call Control with our ToIP products. The first problem we have found is that the default behaviour in OC Public Beta is that clicking on the phone of a contact calls the destination contact computer, instead of the destinations PBX phone (as was the behaviour of Beta 3)

    Anyone knows how to configure the default destination device for a contact in OCS/OC public Beta?

    Thanks in advance,
    Cristian Alonso


    I tried changing some values in the registry but could not find any key that changed this annoying behaviour.  Anybody knows any registry keys, policies, API's, ANYTHING to start searching for a solution? I had 20 users with Beta 3 that will be very upset with this change... Sad

    Any help would be apreciated.
    Regards,
    Cristian
    Thursday, April 26, 2007 10:24 AM
  • Hi Cristian Alonso,

    I am just trying to understand your situation. Are you saying that when you installed Beta 3, the default behavior was that the user's pbx phone was called when someone called another user from inside MOC 2007? And now when a user calls someone in MOC it dials the other user's MOC client?

    Have you looked at the communicator.adm administrative template that came with the public documentation? Or the Excel spreadsheet that comes with the public beta documentation? Does the TelephonyMode setting listed in the spreadsheet sound like it would fix your issue? It looks like the default value for public beta is computer to computer only. Try changing the value to 2 or 3 and let us know back here.

    Thursday, April 26, 2007 10:35 PM
  • Thom,
    First, thanks for your help, I will investigate communicator.adm template to see if it helps.
    Regarding your question, I will try to explain the situation better.

    Let's say I have two users, both of them with remote call control enabled. With Beta 3 when I opened MOC and clicked the phone icon of a contact that had RCC enabled, my desk phone rang and called through the PBX the destination phone of the contact, not the computer.

    The sequence of things was:
    1. Click on destination phone icon
    2. MOC issues a uaCSTA command to ask the PBX to put both phones in contact and shows the call control popup
    3. My phone rings and autoanswers.
    4. Destination phone rings and destination phone shows incoming call popu
    I think that is the desirable behaviour when RCC is enabled, and I think that was the default behaviour in Beta 3 (at least I don't remember changing anything, but of course I may have forgotten about it Smile )


    In Public Beta, what happens is that default destination is the computer, so IF user A with RCC enabled calls user B with RCC enabled, by default it uses my PC to call the destination MOC, which in this case is not what I expected, at least it did not work that way in Beta 3.


    Hope this helps to clarify things.
    Thanks again for your help, will let you know if I am finally able to change this behaviour.
    Regards,
    Cristian
    Friday, April 27, 2007 8:18 AM
  • Hi Cristian,

    Can you let us know the status of your situation? Did you check out communicator.adm? Please let us know.

    Monday, May 7, 2007 8:49 PM
  • Sorry Thom, did not find the time to answer this.
    I finally found some time to test this, and the situation has not improved.

    What I did first is reinstall Beta 3 client (working with Public Beta server), and the behaviour is consistent with what I described in this thread: if I point to the telephone icon the default destination is "work" and preferred calling device is "phone". This two parameters have been configured on the active directory (communications tab->Additional Options->Enable Remote Call Control). I can confirm than no additional policies nor the local registry of the cliente machine have been changed/enforced (all default values).

    So far so good. Went to another PC with public beta client installed, and started playing with group policy options, in particular with the Telephony Mode parameter using the same user account. I was not able to find any other relevant parameter to play with (please let me know any other parameters you think are relevant)

    Results:

    • If I set this parameter to 2 (RCC Enabled), the behaviour is exactly the same, PC to PC calling even when RCC is enabled and my preferred calling device is set to "phone"
    • If I set this parameter to 1 (UC Enabled), RCC is broken and "enable integration with your phone system" is automatically unchecked (as should be expected). Clicking on a contact phone icon  calls from PC to PC.
    • If I set this parameter to 3 (Dual mode) is similar to value 1, although "enable integration with your phone system is not automatically unchecked. PC to PC calling works. Docs say this value is not supported.
    • communicator.adm does not provide value 4 (RCC without computer calling), but I edited the file and set it to 4, and everything breaks up, the phone icon does not do anything. I even started a packet capture to see if the communicator client sent anything when clicking on the phone icon, but no SIP or uaCSTA packets were generated.


    My conclusion: I think this issue is definitely broken in Public Beta regarding RCC, and from my users perspective I would recommend changing it to the default Beta 3 behaviour, or at least make it configurable. It is really annoying.

    In my opinion (this is just an opinion, I would like to hear what you guys think), It would be great to be able to work in both enterprise mode and RCC (what is called Dual Mode). For example, when I am on the road with my laptop it would be great to use MOC as my phone, and when I am in the office use it with RCC enabled, for the same account. I remember hearing somewhere that this dual mode working was not going to be supported, I was glad to find it in the excel file, although it does not seem to be working at all now.

    I would be happy to test anything else anybody can think of.

    In case this is a bug, Is there any official way of progressing this information to the developers so they are able to fix it in the official release?

    Thanks again for your help/support,
    Cristian Alonso
    Tuesday, May 8, 2007 1:24 PM
  • I seem to be running into a similar issue with the Public Beta.  I have edited the group policy in communicator.adm with 'TelephonyMode' set to '3 = Dual Mode' and I don't see any signaling from the MOC client PC when I attempt to call a 'work' phone.  I can call or IM direct between MOC clients without a problem, it's only when I try to call over to a CallManager-controlled phone that MOC doesn't seem to be doing anything.

     

    Randy

    Wednesday, May 9, 2007 6:45 PM
  • Hi Cristian,

    Thanks for doing such a detailed test and posting it here. I am going to try to bring in some additional help with this.

    Wednesday, May 9, 2007 10:19 PM
  • Thanks Thom, let me know how I can help.
    Regards,
    Cristian
    Friday, May 11, 2007 3:18 PM
  • In my setup RCC works with TelephonyMode set to 2. Just make sure you have RCC correctly configured and select phone as preferred calling device.
    Regards,
    Cristian
    Friday, May 11, 2007 3:20 PM
  • Cristian,

     

    Has this issue been resolved?

     

    Thanks!

     

    Chad A. Lacy

    OCS 2007 Beta Support

    Thursday, May 17, 2007 3:52 PM
  • Chad, unfortunately not, it has not been resolved. Please refer to my previous post explaining the current situation.
    Feel free to contact me if you need further info.
    Regards,
    Cristian

    Thursday, May 17, 2007 4:27 PM
  • Cristian,

     

    On the OC contact, if you hover of hte phone icon you should see a drop down. From here the SIP URI should be highlighted by default. If you select the work phone number instead it should then call that number. I believe from then on it will use that number if you just click on the phone icon. In other words, the icon will use whatever you selected last. So, for every user the phone icon defaults to the number you used last to call them on.

    Thursday, May 17, 2007 7:30 PM
  • Chad,
    that is exactly my problem with public Beta, if a click on a destination contact phone on the drop down menu it does call the PBX phone, but the next time it does not, which is annoying for users, a common mistake.

    I always have to drop down the menu to call the phone, if not, it calls from my PC to the destination PC, even when my preferred calling device is set to "phone" and RCC is enabled.
    In my opinion (just my opinion, I know it is easier to describe functionalities than to implement them, I've been a developer for 10+ years), there are three things to fix here:
    1. When RCC is enabled and I click on a contact that also has RCC enabled, the default destination should be his phone, not his PC. At least, it would be nice to be able to be able to configure this behaviour, or inhibit the possibility of calling the destination PC (a mistake very common in our RCC scenarios). At least, OCC shoul remember the last option selected, that is, maintain the Beta 3  funcionality that you have described.
    2. If I have RCC enabled and my preferred calling device is set to "phone", the call should always be generated from my phone (using uaCSTA protocol)  no matter of the destination selected by the user (I should be able to call from my IP-PBX phone to the OCC client of another contact, why not? It's all IP).
    3. If a double click on a contact to send and IM, and I want to call him afterwards, the call is always generated from my PC to the destination PC, even when selecting the destination phone on the phone drop down menu.
    I would be wiiling to test any possible solution you can think of, maybe we are doing something wrong, but I can assure you that with OCC Beta 3 in the same setup issues 1 and 3 work fine.

    Thanks for your support,
    Cristian



    Friday, May 18, 2007 9:55 AM
  • Hi Cristian,

    Have you been able to find a resolution? Have you been working with Chad offline? If so, can you let us know the status? If not, please let me know.

    Thanks.

    Friday, June 22, 2007 3:49 PM
  • Thom,
    we were stuck until someone answered this in another post.
    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1722226&SiteID=57

    The behaviour changed in Public Beta from Beta 3, that is why it stopped working in our environment.

    Thanks for your help,
    Cristian
    Friday, June 22, 2007 7:53 PM