locked
Import Contacts into CRM 4.0 RRS feed

  • Question

  • Hi there, can you please help as I am struggling with CRM 4.0.

    Let me start by explaining I know very little about this program, I am "flying by the seat of my pants" in helping out with this.

    Basically, I work for a company that have taken on IT support for a Hotel.  They use an old system for contacts, which has a facility to export the data to CSV.  I have created a CSV with the following headers:

    Salutation,First Name,Middle Name,Last Name,E-mail,Business Phone,Address 1: Street 1,Address 1: City,Address 1: State/Province,Address 1: County,Address 1: Country/Region,Address 1: ZIP/Postal Code,Fax,Job Title,Mobile Phone

    The CSV export from the old system is very patchy, not all columns are filled out some have significant bits missing.

    I am using the Web Console for CRM as we havent got the outlook facility working yet.  I follow the following process to import the CSV.

    1.) Click on Tools
    2.) Click on Import
    3.) Select my data file from the "Import Data Wizard" dialog box
    4.) Choose "none" for the data delimiter (as there is none in my CSV) and "," as the field delimiter
    5.) Click next
    6.) I select "Contacts" as the Record Type and "automatic" appears in the data maps box
    7.) Next Next Finish

    However the import ALWAYS fails.

    Please, for the love of god - Tell me what I am doing wrong as I am getting rather frustrated with it.

    Many Many thanks!


    • Edited by _Jonnie Thursday, April 5, 2012 6:59 PM
    Thursday, April 5, 2012 6:58 PM

Answers

  • Ive sorted this now thanks.

    I had to remove SQL instances and completely re-install CRM (not something someone with a highly populated CRM can do but ours is a fresh install).  After I had done this I used exactly the same method, using exactly the same CSV file and it worked straight away.

    Cant explain it further than "a software re-install fixed the problem" however I'm a happy bunny at least.

    Thanks!


    Regards JH

    • Marked as answer by _Jonnie Thursday, April 12, 2012 6:19 PM
    Thursday, April 12, 2012 6:19 PM

All replies

  • Can you post the specifics of the failure?  that will be very relevant to resolving the issue.

    There is also the CRM 4.0 Data Migration Manager.  It's a pain to use, but it's much more powerful and flexible than the native CRM 4.0 data loader.  http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=15311


    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Thursday, April 5, 2012 8:01 PM
  • Thanks for the reply Wayne..  I'll look into the Data Loader.

    I cant really help you with specifics of the error, all I see is this...  (unless I'm looking in the wrong place)

    Thursday, April 5, 2012 8:25 PM
  • OK so I downloaded and installed CRM DMM, when loading for the first time it asks me for the web address to connect to the server.

    In a web console I input http://server1:5555 (which works) when I type that into the CRM DMM box it simply says:

    Thursday, April 5, 2012 8:46 PM
  • If you open the Please Work job, it should give you a "Failed Records" area on the left.  In there will be detailed descriptions on why it's failing.  Try there, and post the failure messages.

    As for DMM, try the fully qualified domain name.  DMM is extremely picky, and it's almost more work to make it work than the native import tool.


    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Monday, April 9, 2012 7:52 PM
  • Ive sorted this now thanks.

    I had to remove SQL instances and completely re-install CRM (not something someone with a highly populated CRM can do but ours is a fresh install).  After I had done this I used exactly the same method, using exactly the same CSV file and it worked straight away.

    Cant explain it further than "a software re-install fixed the problem" however I'm a happy bunny at least.

    Thanks!


    Regards JH

    • Marked as answer by _Jonnie Thursday, April 12, 2012 6:19 PM
    Thursday, April 12, 2012 6:19 PM
  • Glad you worked it out.  :)

    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Friday, April 13, 2012 2:54 PM