locked
CRM 4.0 Installer Disappears during Install RRS feed

  • Question

  • I am currently trying to do an upgrade from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0. This is being done on three VM's - the Domain Controller, the SQL Server box and the Microsoft CRM box. SQL Server has SP2 installed, and Reporting Services has been "upgraded" to SP2 as well. The .Net framework on the CRM machine has been upgraded to .Net Framework 3.0.

     

    Everything goes smoothly in the installation up to the point where the Microsoft Visual C++ Runtime is being installed. The installation completes for the C++ Runtime, but as soon you click on the next button to go to the next screen for the upgrade / installation, the installation screen just disappears. I had a look in the Task Manager, but the setupserver.exe process goes missing right after you click the Next button on the C++ Runtime screen. I had a look in the Event viewer, and got the following error: "Faulting application microsoft.crm.setup.server.exe, version 4.0.7333.3, stamp 475915d5, faulting module kernel32.dll, version 5.2.3790.3959, stamp 45d70ad8, debug? 0, fault address 0x0000bee7.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.". The source for this error in the Event viewer  is .Net Runtime 2.0 Error Reporting.

     

    I came across someone else on the web who had the same problem, but with a different environment (see the following forum: http://www.microsoftdynamicsforums.com/forums/forum_posts.asp?TID=2321&PID=8746#8746 ). I have tried the solution supplied on the forum and made the change in the registry, but I am still running into the same problem.

     

    If anyone has any help or ideas, it would be greatly appreciated. 

    Monday, January 19, 2009 12:39 PM

All replies

  • In the C:\Documents and Settings\greg.groenewald\Application Data\Microsoft\MSCRM\Logs\crm40svrsetup.log file, is the following info:

     

    07:55:34|   Info| === Setup bootstrap logging started 1/21/2009 7:55:34 AM ===
    07:55:35|   Info| Bootstrap version: 4.0.7333.3.
    07:55:36|   Info| User: greg.groenewald.
    07:55:36|   Info| Managed Setup exited with code -532459699.
    07:55:37|   Info| === Setup bootstrap logging ended 1/21/2009 7:55:37 AM ===

     

    The rest of the file is pretty much the same.

     

    I have found another post ( http://www.eggheadcafe.com/software/aspnet/31470967/crm-3-to-4-upgrade.aspx )where the same file has different exit code (-2). I have tried to Google this error code for CRM, but could not find anything usefull.

     

    Any ideas / help would be greatly appreciated, because i am running out of ideas...

     

    Wednesday, January 21, 2009 10:37 AM