locked
How do I disabe permissions to 'Create a New Task' form PWA RRS feed

  • Question

  • I did the following, but the option is still available under PWA> Timesheet> Insert Row.

    1. Log into PWA with Administrator permissions.
    2. Click the Server Settings link in the Quick Launch menu.
    3. Click the Manage Groups link in the Security section of the Server Settings page.
    4. Click the Team Members group to open it for editing.
    5. In the Categories section of the page, click the My Tasks category.
    6. In the Permissions for My Tasks data grid, deselect the Allow setting for the Create New Task or Assignment permission.
    7. Click the Save button.

    However,  when I try to use this options I get the following error msg:

     

    You have no projects available for new task creation.

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 60809b76-7d99-4455-a644-2acd0d72b215

    Date and Time: 2/7/2011 12:49:03 PM

    Monday, February 7, 2011 5:49 PM

Answers

  • Hi lyddie,

    Have you applied Dec CU of Project Server 2010 to your environment? seems like you haven't - please apply the CU contains the hotfix for this error. look into my blog for the detail review of the bug: http://khurramjamshed.blogspot.com/2011/01/project-server-2010-team-member-group.html

    Once you done with the CU, if you requirement is to not to allow the Team members group users to edit the Project Plan - simply deny the permissions of Open Project/Publish Project/Save project to the server, this will server the purpose for you. Because denying the create new task permission not let the user to send New Task approval request to the Project manager, which i believe is a best practice to follow in case of allowing team members to request for addition of the task in the project plan.

    Let me know if it answers you query.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Tuesday, February 8, 2011 5:48 AM

All replies

  • Hi lyddie,

    Have you applied Dec CU of Project Server 2010 to your environment? seems like you haven't - please apply the CU contains the hotfix for this error. look into my blog for the detail review of the bug: http://khurramjamshed.blogspot.com/2011/01/project-server-2010-team-member-group.html

    Once you done with the CU, if you requirement is to not to allow the Team members group users to edit the Project Plan - simply deny the permissions of Open Project/Publish Project/Save project to the server, this will server the purpose for you. Because denying the create new task permission not let the user to send New Task approval request to the Project manager, which i believe is a best practice to follow in case of allowing team members to request for addition of the task in the project plan.

    Let me know if it answers you query.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Tuesday, February 8, 2011 5:48 AM
  • Hi Khurram,

     

    Thanks for your reply, we will apply the hot fix and let your know how that works for us.  If I deny permissions for the Team Members by simply dening the permissions of Open Project/Publish Project/Save project to the server, then they will not be able to 'Insert Task' or 'Add yourself to a Task'.  Correct? 

    Tuesday, February 15, 2011 4:40 PM
  • Hi Khurram,

    You might like to check if the "New Task Assignment" In Global Permission under general is checked. If not, please select the option and try. I believe this wil help resolve your issue. Thanks


    Dolly Pandey

    Wednesday, March 26, 2014 12:04 PM
  • That Fixed my problem. Thank you!
    Tuesday, February 24, 2015 9:50 PM