locked
Problem with report published for external use RRS feed

  • Question

  • Hi,

    We have two reports both with identical set up and published for external use. Until recently they both worked fine both within CRM and the external ones.

    Suddenly one of them throws the exception that the data source was not found.

    We have always used a different name to the standard MSCRM_DataSource for the data source, and they were fine with this (one still is). I have tried changing the name to MSCRM_DataSource and it still says it is not found, even though the data source exists (I can see it on the reporting services web pages).

    The report works fine from within BIDS, CRM and if we go to http://{server}/reports, but not from http://{server}/reportserver or if we try and execute it externally.

    They are both published in the correct location under the orgname folder.

    The connection is a sql one as we are unable to get what we need from fetch. 

    The data source is not shared (same as the one that works) and uses windows credentials (same as the one that works).

    I've tried restarting reporting services in case it was some caching issue but to no avail..

    Any ideas?

    Regards

    Chris

    Wednesday, August 6, 2014 10:02 PM