none
Very buggy forum RRS feed

  • Question

  • This is a surprisingly buggy forum.

    Here is a list with some of the problems/bugs I found. Some of them may not be news but that's even worse.

    1) Lots of duplicate (or even triplicate) posts
    2) Out of order posts
    3) When click "Ask a question", first time nothing happens except the window scrolls up to the top. Only the second time the edit control appears.
    4) When writing a post if click some links, such as "Mark as answer", the edit area dissapears. If then try to click "Reply", a message pops up:"You must close first the edit window" (or something like that), although no such window anymore and no way to get it back.
    5) When writing a post, Enter key insert a blank line. Have to use Shift+Enter instead.
    6) No spell check

    I'm using IE8 and WinXP prof

    Saturday, June 5, 2010 3:20 AM

Answers

  • Interesting. Lots of issues here.

    #1 has been fixed a few times (for a few different cases/reasons). #2 seems to be fixed. #3 seems to be fixed. #4 seems to be fixed, but a few scenarios still exist that are "by design". The design is that you should only do one thing at a time, but your exact issue seems to be fixed. #5 seems to be fixed. #6 is interesting. That feature used to exist. It was removed because it was causing too much trouble and we moved to a better editor without the feature. Many web browsers now build that feature in, so it was out of scope/plan.

    Thanks!



    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Sunday, May 13, 2012 4:36 AM

All replies

  • Interesting. Lots of issues here.

    #1 has been fixed a few times (for a few different cases/reasons). #2 seems to be fixed. #3 seems to be fixed. #4 seems to be fixed, but a few scenarios still exist that are "by design". The design is that you should only do one thing at a time, but your exact issue seems to be fixed. #5 seems to be fixed. #6 is interesting. That feature used to exist. It was removed because it was causing too much trouble and we moved to a better editor without the feature. Many web browsers now build that feature in, so it was out of scope/plan.

    Thanks!



    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Sunday, May 13, 2012 4:36 AM
  • Many ore people will notice that now thanks to the Windows 10 preview. For example, this page:

    http://social.technet.microsoft.com/Forums/en-US/home?category=WinPreview2014&forum=WinPreview2014Feedback%2CWinPreview2014General%2CWinPreview2014Setup%2CWinPreview2014Feedback%2CWinPreview2014General%2CWinPreview2014Setup&filter=alltypes&sort=lastpostdesc&brandIgnore=true&page=1

    lists 6 Windows 10 preview forums, that is, each is listed twice.

    This did not happen immediately, I had to navigate in the forum for a while.

    Strange MS did not polish this kind of stuff before the Preview.

     BTW, I typed plain text only and just pressed DEL. Thad DEL made the font of the line above much smaller. I wonder if the change makes it to the displayed post. 
    Wednesday, October 1, 2014 7:26 PM