locked
Device Connectivity Component RRS feed

  • Question

  • Hello togehter!

    I have a mobile device with Windows CE 5.00
    I am developing a new application and I want to synchronize the db using

    Microsoft.Synchronization.Data.SqlServerCe      3.5.6000.0
    Microsoft.Synchronization.Data                  1.0.6000.0

    When I try to deploy the project I get the following error:
    Fehler 1 0x89731705 Device Connectivity Component 
    (No idea what this means)

    If I continue I get the following MissingMethodException when I create the SqlCeClientSyncProvider:
    Could not load type 'Microsoft.Synchronization.Data.SqlServerCe.SqlCeClientSyncProvider' from assembly 'Microsoft.Synchronization.Data.SqlServerCe, Version=3.5.6000.0, Culture=neutral, PublicKeyToken=3BE235DF1C8D2AD3'.

    Any ideas why that happens?

    Thanks a lot in advance.

    Greetings
    Markus



    If I i
    • Moved by Max Wang_1983 Thursday, April 21, 2011 10:29 PM forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Tuesday, November 24, 2009 4:20 PM

Answers

  • Hello Yunwen Bai!

    Thanks for your reply, but everyhing was correct.

    As the device was not knew when I got it, I reseted the device completely und installed everything new and now it works.

    Thanks for your help.

    Greetings
    Markus

    Saturday, November 28, 2009 9:10 AM

All replies

  • Hi Markus,

    What version of Sync Services did you install and how did you install these bits.
    Were there any installation errors?
    This posting is provided AS IS with no warranties, and confers no rights
    Tuesday, November 24, 2009 7:00 PM
  • Hello Dudgikar!

    Thanks a lot for your fast answer.

    I installed the Sync Services for ADO.NET v1.0 in my pc in the folder:
    C:\Programme\Microsoft Synchronization Services\ADO.NET\v1.0

    Then I copied the cab file from the device folder (the one for windows ce as I have windows ce) and installed it on the device.

    Is there a problem with that installation?

    Thanks a lot.

    Greetings
    Markus
    Wednesday, November 25, 2009 12:19 PM
  • would you please check with version of the SQLCE engine and System.Data.SqlserverCE.dll on the device ? Please make sure they are version 5691.xx and 3.5.1.

    thanks
    Yunwen
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, November 25, 2009 9:59 PM
    Moderator
  • Hello Yunwen Bai!

    Thanks for your reply, but everyhing was correct.

    As the device was not knew when I got it, I reseted the device completely und installed everything new and now it works.

    Thanks for your help.

    Greetings
    Markus

    Saturday, November 28, 2009 9:10 AM