none
MPICH2 - smpd passphrase RRS feed

  • Question

  • I am doing LAMMPS simulations and want to use the MPI function. I downloaded the MS-MPI MPICH2 on a 64 bit windows 8. (I have mpiexec, smpd, and input files in the same directory)
    I did the following under cmd as an admin:
    smpd -install
    mpiexec -remove
    mpiexec - register (used username and password)
    mpiexec -validate ( success)
    smpd -status (it says it is running)
    mpiexec.exe -np 4 -localonly lmp_win_mpi < in.crack
    This last line asks me for the passphrase, however the correct passphrase does not work, and I have to abort out of the screen.
    Any help would be greatly appreciated.
    Friday, November 8, 2013 3:11 PM

All replies

  • Hi Yonaton,

    Are you sure you are using matching binaries?  What version of MS-MPI are you using?

    You should be able to find out which binaries you are running for smpd.exe and mpiexec.exe using the 'where' command:

    >where smpd.exe

    I suspect you are running a different MPI implementation's smpd/mpiexec, not the MS-MPI version, as we don't support the -install and -status options to smpd.exe, nor the -remove, -register, -validate, -localonly as options to mpiexec.

    If you are running MS-MPI 2012 SP1, and running locally, you should automatically get the same behavior as -localonly (no firewall popups).  You do not need to have smpd running, either, for mpiexec to launch MPI jobs locally.

    For your application, the command line should be:

    >mpiexec -np 4 lmp_win_mpi < in.crack

    This should run lmp_win_mpi under the same credentials used to run mpiexec.

    Let us know if that works for you.

    Cheers,
    -Fab

    Friday, November 8, 2013 8:51 PM
  • Hi Yonaton,

    You will need a version of LAMMPS built against MS-MPI, as it seems LAMMPS doesn't support runtime selection of the MPI library.

    Cheers,
    -Fab 

    Monday, November 11, 2013 10:13 PM
  • Hi, I'm having a similar issue as Yonaton.

    So, I tried running with command you stated, I got the error saying user Credentials for connecting to Tanmay (i.e. name of my m/c).

    So I tried running in cmd ass admin, now it gives a error 

    Fatal protocol Error: check versions between Mpiexec.exe, Msmpi.dll, and Smpd.exe

    Pls help.

    Thursday, September 24, 2015 8:36 PM
  • Hi Tanmay,

    The error you are seeing is likely due to mixing different binaries - either different versions of MS-MPI binaries, or binaries from different MPI distributions (MPICH, Intel MPI, and MS-MPI all the same names due to common ancestry).  Can you make sure all the binaries are the same version?

    Can you give more details about the application you are trying to run, and your configuration?  Are you trying to run across multiple machines?  What version of MS-MPI are you running?

    Cheers,
    -Fab

    Monday, September 28, 2015 3:48 AM