Enteprise Edition pool back-end discovery failure RRS feed

  • Question

  • Hi,

    I would like to install OCS Enterprise edition.

    I managed to get a separate instance for OCS usage on a dedicated SQL box (there are more existing instances there with different versions, but the one 1 want to use is SQL 2005 Enterprise edition SP2). Followed the manual, and created the pool running the OCS installer on SQL box. Also configured the pool on SQL box.

    Now I want to add a server to the pool, so I moved to OCS box. But it fails to receive data from SQL box.

    It seems a network connectivity OR permission problem. So I checked, if OCS box can connect to SQL box. Simulated a new pool creation from OCS box, and it also fails see the following picture:

    Are there any configuration steps specific to OCS connection (SQL service user has to be RTCSERvice or RTCComponentService or something similar setting, that is not mentioned in the EE deploy guide?)

    Facts:  - no firewall running, ping of SQLBOX is successfull
    - enabled TCP/IP access (configured for every IP in that list) and Named pippe access on the instance
    - locally it can be reached be SQLCMD command

    eg. SQLCMD -S SQLBOX \ OCSinstance
    1>    waiting for input

    Running from OCS machine I notice a timeout, and then the following error message:

    C:\Program Files\Microsoft SQL Server\90\Tools\binn>sqlcmd -S SQLBOX\ocs

    HResult 0xFFFFFFFF, Level 16, State 1
    SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
    Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establi
    shing a connection to the server. When connecting to SQL Server 2005, this failu
    re may be caused by the fact that under the default settings SQL Server does not
     allow remote connections..
    Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.

    But I am able to connect to the SQLBOX\default instance.

    Thanks in advance!
    Wednesday, November 14, 2007 2:00 PM


  • Luckily it was solved by STARTING the disabled SQL Browser Service. It has to be running for finding named SQL instances Sad
    Wednesday, November 14, 2007 3:50 PM