locked
Outlook CRM can't authenticate. RRS feed

  • Question

  • Hi,

    We have an issue related to the CRM for Outlook ADD-in authentication step.

    The CRM for Outlook is initialy installed and configured so that it will remember the password of the user. Everything works well at first. Then after a while (can be couple of days to a month, something goes wrong and the authentication phase will ask for the user password. Even when entering the correct password, the add-in refuse to authenticate the credentials.

    We have tried to diagnose the problem without much success.
    When the problem appears, we have the following messages in the Event Log of the client machine in that order :

    Log 1 :
    There was a problem communicating with the system tray process. Close down Microsoft Outlook (and close the Microsoft.Crm.Application.Hoster process via Task Manager or the System Tray if appropriate) and restart. HR=0x8004d224. Context=. Function=CAddin::HrActivateAddin. Line=448

    Log 2 :
    The Microsoft CRM Outlook add-in could not be initialized correctly. Restart Microsoft Outlook and try again. HR=0x80070057. Context=. Function=CAddin::OnConnectionInternal. Line=217.

     

    Additional Notes :
    The Client access the CRM in IFD mode and we have SSL (HTTPS).
    The Client has CRM Update Rollup 5 installed.
    When the problem arise, the client can still access the CRM with Internet Explorer and the authentication is successfull. Just not from Outlook.
    This problem is happening A LOT. We have around 100 active client and our support recieve dayly calls, sometimes up to 10 calls regarding this issue.
    Reseting the Active Directory password of the client resolves the problem but is not desireable.

    Thursday, December 17, 2009 3:59 PM

Answers

  • See if you have files in the C:\Documents and Settings\<UserName>\Application Data\Microsoft\Outlook

    Copy them to a safe place and delete them one by one.
    I think it was the outlookcmd.dat file that I deleted.

    I've seen a post somewhere quite a while ago that suggested to remove the profile.
    Bad Idea in my book.
    Surgical strike is better.

    Now if it works, please post which file was causing the problem, ok.
    Thanks.
    • Marked as answer by Jim Glass Jr Friday, December 18, 2009 7:05 PM
    Thursday, December 17, 2009 9:23 PM
    Moderator

All replies

  • Rollup 7 is available and there were considerable improvements with this rollup for the Outlook Client.

    If that will take a while , I was able to get some client machines going by removing a  file from the user profile Local Settngs \Application Data folder that holds the configuration for thier Outlook install.

    The location of which escapes me at the moment.
    Thursday, December 17, 2009 5:37 PM
    Moderator
  • Rollup 7 is available and there were considerable improvements with this rollup for the Outlook Client.

    If that will take a while , I was able to get some client machines going by removing a  file from the user profile Local Settngs \Application Data folder that holds the configuration for thier Outlook install.

    The location of which escapes me at the moment.

    Thanks for the quick reply.

    You are correct, Rollup 7 will take a while for us. If there is a relative certainty that it would resolve our issue, I could push for its integration sooner then later.

    However I'm very interested in your workaround concerning the removal of a file from the client drive. However, I would need additionnal info. concerning the exact file and the potential negative side effects.

    Thanks
    Thursday, December 17, 2009 6:33 PM
  • See if you have files in the C:\Documents and Settings\<UserName>\Application Data\Microsoft\Outlook

    Copy them to a safe place and delete them one by one.
    I think it was the outlookcmd.dat file that I deleted.

    I've seen a post somewhere quite a while ago that suggested to remove the profile.
    Bad Idea in my book.
    Surgical strike is better.

    Now if it works, please post which file was causing the problem, ok.
    Thanks.
    • Marked as answer by Jim Glass Jr Friday, December 18, 2009 7:05 PM
    Thursday, December 17, 2009 9:23 PM
    Moderator