locked
A vueltas con la función "SUMAR.SI()" de Excel.

    Question

  • Es la 2ª vez que planteo este tema. En la 1ª fué muy leído pero sólo obtuve una contestación, la de KL, a quien le agradezco su atención, todo porque no lo planteé bien. Mis disculpas a todos. Y ahora vuelvo a la "carga" creyendo que, esta vez, sí me explicaré bien.

     

    La cuestión es saber si esta dichosa función admite más de un criterio.

     

    Sea el ejemplo siguiente:

    La col. A contiene carácteres "U" ó "V" y sólo uno de los dos en cada celda.

    La col. B contiene carácteres "S" ó "N" y sólo uno de los dos en cada celda.

    La col. C contiene valores numéricos.

    Se trata de hayar la suma (col. C) que correspondería a los carácteres "U" (col. A) cuando van seguidos de los carácteres "S" (col. B) en la misma fila.  Hay varias conbinaciones entre las col. A y B pero sólo expongo esta para abreviar.

     

    Parecido problema ocurre con la función "CONTAR.SI()"

     

    Gracias de antemano a quien me pueda ayudar.

     

    Luis.

    Monday, July 2, 2007 4:04 PM

All replies

  •  

    El tema de los criterios múltiples los podés manejar usando las funciones =Y  =O en conjunto con la función =SI. La 1ra evalúa si todas las condiciones son Verdaderas para dar un resultado  Verdadero. La otra (=O) siempre da Verdadera a menos que todas las condiciones sean Falsas.

     

    =SI(Y(A1>10;A2<20);"Hola";"Chau") Si A1 es mayor a 10 y A2 es menor a 20 aparece Hola, de lo contrario Chau.

     

    =SI(O(A1>10;A2<20);"Hola";"Chau") Siempre aparece Hola, salvo cuando A1 no es mayor a 10 ni A2 es menor a 20.

    Thursday, August 9, 2007 8:59 PM
  • Recien encuentro tu pregunta, perdona que sea tanto tiempo después pero estoy empezando en este foro.

    Creo que no han entendido bien tu pregunta.

    Con Sumar.si no he podido utilizar criterios múltiples, lo que he hecho para hacerlo es emplear en una columna oculta una suma o unión de los criterios que quiero emplear y luego utilizo la función con ese criterio.

    No sé si me explico bien, en tu caso sería algo así:

    Según tu explicación:
    Col A  "U" o "V"
    Col B  "S" o "N"
    Col C  ###

    Yo correría los valores de Col C a Col D y en la columna C agregaría una fómula:  =A# & B# (# igual número de fila)

    y luego cuando quiero sumar los valores que cumplen U y S utilizo la función: =sumar.si( C#Big Smile# ;"US"; D#Big Smile#)


    Espero que me haya sabido explicar, no sé si es lo que buscabas pero soluciona tu problema.

    Saludos,

    Daniel

    Friday, February 29, 2008 2:46 PM
  • Lo que Luis40 creo que quiere preguntar es:
    si tengo
    Erick Alejandro 5-Aug-08 3.45
    Erick Alejandro 12-Aug-08 3.24
    Erick Alejandro 12-Aug-08 2.95
    Erick Leonides 1-Aug-08 0.00
    Erick Leonides 2-Aug-08 1.95
    Erick Leonides 4-Aug-08 1.84
    Jorge Humberto 9-Aug-08 3.02
    Jorge Humberto 10-Aug-08 1.50
    Jorge Humberto 11-Aug-08 2.50
    Jorge Humberto 12-Aug-08 2.38
    Jorge Humberto 13-Aug-08 0.50
    Jorge Humberto 14-Aug-08 0.80
    Jorge Humberto 15-Aug-08 0.41
    Jorge Luis  11-Aug-08 3.00
    Marcos Emilio 2-Aug-08 2.58

    con que funcion de SUMATORIA puedo seleccionar: de la primera columna solo a "Jorge Humberto", de la segunda columa fechas de Jorge Humberto del "11-aug-08" al "14-aug-08" y que me sume los resultados de la tercera columna, es decir la formula me deberia sumar los valores 2.50, 2.38, 0.50 y 0.80 y darme un total de "6.18", (mi excel es en ingles, asi que alguien sabe como hacer esta formula, por favor escriba comando en ingles)

    Gracias.

    Leonel Pineda
    • Proposed as answer by Chia O Friday, May 28, 2010 4:34 PM
    Friday, August 15, 2008 3:58 PM
  • buenas tardes, considero que Leonel Pineda tiene una muy buena interpretacion de lo que Luis 40 requiere.

    A la verdad, desconozco la funcion a utilizar, pero requiero si alguien tiene la respuesta, la publique a la brevedad.

    El punto es que solo requiero saber que funcion nos permite sumar los datos de una columna estableciendo como criterio un rango de fechas para arrogar los resultados, por eso comento que Leonel es muy acertado.

    muchas gracias a buen dia a todos.

     

    Friday, May 28, 2010 4:39 PM