locked
Change to Spanish language problem RRS feed

  • Question

  • All,

    I have installed the Spanish Language pack on our CRM 2011 server and it installed successfully.  However, when I go to File > Options > Languages tab > select Spanish for User Interface Language > click OK; the page reloads in Spanish, but when I click Archivo ('File') in the top left, the screen goes haywire.  Buttons are invisible.  The entire UI is essentially missing.  Here are two screenshots, before and after:

    Before clicking Archivo:

    After clicking Archivo:

    I am using Internet Explorer 9 and our CRM server is on Rollup 11.
    Has anyone ever run into this issue?  This is serious as we have user testing coming up and they won't be able to use the system.  HELP!  

    Wednesday, January 23, 2013 10:13 PM

Answers

  • As it turns out, this is a bug with Update Rollup 12 of the Language pack.  I spoke with Microsoft support today and they confirmed it.  They are now having their development team work on a resolution.  A workaround for the time being--uninstall Update Rollup 12 for the Language pack on you CRM server.  Once you do this, the UI is back to normal.
    • Marked as answer by wikky2007 Wednesday, January 30, 2013 1:24 AM
    Wednesday, January 30, 2013 1:24 AM

All replies

  • Nobody?
    Thursday, January 24, 2013 3:54 AM
  • Hi,

    Please can you provide us below information.
    1. The links/Buttons which are not appearing are custom link (for custom entities) or out of box links.
    2. Did you import the translation file (from base language to Spanish language).

    Chandan - http://mscrm-chandan.blogspot.in/ I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful !!!

    Thursday, January 24, 2013 5:49 AM
  • To respond to your questions:

    1. EVERYTHING IS MISSING. Only the out of the box icons you can see in my previous screenshot (not including c360 which is third-party software) show up. As soon as I click File (Archivo in Spanish), the only out of the box stuff that shows up are New Activity (Nueva actividad), New Record (Nueva registro), Tools (Herramientas), Help (Ayuda) and c360 tools (custom).  The rest of the screen is blank!

    2. Yes, I was testing the import/export translation functionality. I exported the translations, updated a single field to Spanish and imported the translations. Could this really cause a problem?  


    • Edited by wikky2007 Thursday, January 24, 2013 9:21 PM
    Thursday, January 24, 2013 9:21 PM
  • Hi,

    It should not be a problem. If translation is not available, CRM should display the text in base language.  
    As you mentioned that You exported the translation, updated a single field to Spanish and imported the translations, so are you able to see that field in CRM in Spanish?
    If Yes then update the translations for all custom field/text/label to Spanish and imported the translations to CRM. 
    This is a general practice, before enabling the Language in CRM make sure translation has been done. 



    Chandan - http://mscrm-chandan.blogspot.in/ I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful !!!

    Friday, January 25, 2013 4:50 AM
  • You have the same problem but with french language

    Tuesday, January 29, 2013 4:15 PM
  • As it turns out, this is a bug with Update Rollup 12 of the Language pack.  I spoke with Microsoft support today and they confirmed it.  They are now having their development team work on a resolution.  A workaround for the time being--uninstall Update Rollup 12 for the Language pack on you CRM server.  Once you do this, the UI is back to normal.
    • Marked as answer by wikky2007 Wednesday, January 30, 2013 1:24 AM
    Wednesday, January 30, 2013 1:24 AM