locked
Blank screen after CRM 2011 install: errors on page RRS feed

  • Question

  • Hi Guys,

    Am facing a post install issue that I haven't encountered before.

    Install went smooth, all prereqs met, no errors in the logs, all components are up and running but am getting a blank page in IE with an errors on page alert.

    This is what I get from the error log:

     <CRMScriptErrorReport>

    Error initializing component with element id=’null’ and with type=’null’ :Object expected

    I'm also getting a similar error about the RibbonManager, crmLookupMru, crmRecentlyViewed, crmHistorymanager

    Have any of you crossed path with this issue?

    Any idea to resolve the matter is welcome :-)

    Cheers,

    :~D




    :~DaDynamixFan
    Thursday, February 2, 2012 1:32 PM

Answers

  • Hi folks,

    I resolved the issue: it was stemming from a GPO that set an authorisation rule in IIS that disabled anonymous authentication.

    Since CRM authenticate once for the session then uses anonymous access to load the remaining components such as the JScripts files the page would not load properly...

    Oh well, these pesky network admins ;-)

    Regards,


    :~DaDynamixFan


    • Edited by DaDynamixFan Friday, February 17, 2012 10:51 AM
    • Marked as answer by DaDynamixFan Friday, February 17, 2012 10:51 AM
    Friday, February 17, 2012 10:51 AM

All replies

  • Hi

    You getting this error from client side or server itself

    Thursday, February 2, 2012 2:16 PM
  • Hi,

    From the server in IE.

    Have you experienced this before?


    :~DaDynamixFan
    Thursday, February 2, 2012 2:37 PM
  • Actually no.

    But trying to think what could be the possible reason.

    Can you check, if you are able to access CRM site from IIS

    Thursday, February 2, 2012 2:46 PM
  • Same issue from IIS, same issue from deployment manager...

    Also tried to recreate an org but same results.

    All services are up and running, windows authentication is set...

    BTW: services are setup using dedicated accounts, could that have an impact?

     

    Regards,


    :~DaDynamixFan
    Thursday, February 2, 2012 3:10 PM
  • Hi,

    Download Fiddler Tool from this link http://fiddler2.com/fiddler2/version.asp

    Open the Fiddler application and access the CRM through IE and check for traces.

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    Thursday, February 2, 2012 3:20 PM
  • Hey there,

    I used the diagtool for the trace. Does Fiddler bring any additional functionality?

    Here are some of the errors found:

    << at MasterSiteMapGroup..ctor(SiteMapArea parentArea, XmlNode groupNode)

    at MasterSiteMapArea..ctor(SiteMap siteMap, XmlNode areaNode, IOrganizationContext context)

    at MasterSiteMap..ctor(XmlNode xml, DynamicMetadataCache metadataCache, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMapInternal(DynamicMetadataCache metadataCache, Boolean useReferenceXml, Boolean retrieveLatest, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMap(DynamicMetadataCache metadataCache, Boolean retrieveLatest, IOrganizationContext context)

    at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)

    at SiteMap.GetSiteMapForUser(IUser user, Client client, Boolean isOffline, String forceGroupProfiles)

    at AppNavBar..ctor()

    at gescacmaq_main_aspx.__BuildControlcrmAppNav()

    at gescacmaq_main_aspx.__BuildControlTree(gescacmaq_main_aspx __ctrl)

    at gescacmaq_main_aspx.FrameworkInitialize()

    at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    at Page.ProcessRequest()

    at Page.ProcessRequest(HttpContext context)

    at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    at ApplicationStepManager.ResumeSteps(Exception error)

    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    >Sitemap Group with id "ResourceCenter" has an empty title (groups have to have titles).>>

     

    << at MasterSiteMapSubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode)

    at SiteMapEntitySubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode, EntityMetadata entityMetadata)

    at SiteMapEntitySubArea.Create(SiteMapGroup parentGroup, XmlNode subareaNode)

    at MasterSiteMapGroup.ProcessSiteMapAreaNode(XmlNode node, IDictionary subAreaTitles)

    at MasterSiteMapGroup..ctor(SiteMapArea parentArea, XmlNode groupNode)

    at MasterSiteMapArea..ctor(SiteMap siteMap, XmlNode areaNode, IOrganizationContext context)

    at MasterSiteMap..ctor(XmlNode xml, DynamicMetadataCache metadataCache, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMapInternal(DynamicMetadataCache metadataCache, Boolean useReferenceXml, Boolean retrieveLatest, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMap(DynamicMetadataCache metadataCache, Boolean retrieveLatest, IOrganizationContext context)

    at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)

    at SiteMap.GetSiteMapForUser(IUser user, Client client, Boolean isOffline, String forceGroupProfiles)

    at AppNavBar..ctor()

    at gescacmaq_main_aspx.__BuildControlcrmAppNav()

    at gescacmaq_main_aspx.__BuildControlTree(gescacmaq_main_aspx __ctrl)

    at gescacmaq_main_aspx.FrameworkInitialize()

    at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    at Page.ProcessRequest()

    at Page.ProcessRequest(HttpContext context)

    at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    at ApplicationStepManager.ResumeSteps(Exception error)

    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    >Sitemap subArea with id "nav_workflow" has empty Title. Created title Inconnu51 for it>>

     

    << at MasterSiteMapSubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode)

    at SiteMapEntitySubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode, EntityMetadata entityMetadata)

    at SiteMapEntitySubArea.Create(SiteMapGroup parentGroup, XmlNode subareaNode)

    at MasterSiteMapGroup.ProcessSiteMapAreaNode(XmlNode node, IDictionary subAreaTitles)

    at MasterSiteMapGroup..ctor(SiteMapArea parentArea, XmlNode groupNode)

    at MasterSiteMapArea..ctor(SiteMap siteMap, XmlNode areaNode, IOrganizationContext context)

    at MasterSiteMap..ctor(XmlNode xml, DynamicMetadataCache metadataCache, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMapInternal(DynamicMetadataCache metadataCache, Boolean useReferenceXml, Boolean retrieveLatest, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMap(DynamicMetadataCache metadataCache, Boolean retrieveLatest, IOrganizationContext context)

    at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)

    at SiteMap.GetSiteMapForUser(IUser user, Client client, Boolean isOffline, String forceGroupProfiles)

    at AppNavBar..ctor()

    at gescacmaq_main_aspx.__BuildControlcrmAppNav()

    at gescacmaq_main_aspx.__BuildControlTree(gescacmaq_main_aspx __ctrl)

    at gescacmaq_main_aspx.FrameworkInitialize()

    at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    at Page.ProcessRequest()

    at Page.ProcessRequest(HttpContext context)

    at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    at ApplicationStepManager.ResumeSteps(Exception error)

    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    >Sitemap subArea with id "nav_goalrollupqueries" has empty Title. Created title Inconnu50 for it>>

     

    << at MasterSiteMapSubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode)

    at SiteMapEntitySubArea..ctor(SiteMapGroup parentGroup, XmlNode subareaNode, EntityMetadata entityMetadata)

    at SiteMapEntitySubArea.Create(SiteMapGroup parentGroup, XmlNode subareaNode)

    at MasterSiteMapGroup.ProcessSiteMapAreaNode(XmlNode node, IDictionary subAreaTitles)

    at MasterSiteMapGroup..ctor(SiteMapArea parentArea, XmlNode groupNode)

    at MasterSiteMapArea..ctor(SiteMap siteMap, XmlNode areaNode, IOrganizationContext context)

    at MasterSiteMap..ctor(XmlNode xml, DynamicMetadataCache metadataCache, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMapInternal(DynamicMetadataCache metadataCache, Boolean useReferenceXml, Boolean retrieveLatest, IOrganizationContext context)

    at MasterSiteMap.LoadMasterSiteMap(DynamicMetadataCache metadataCache, Boolean retrieveLatest, IOrganizationContext context)

    at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)

    at SiteMap.GetSiteMapForUser(IUser user, Client client, Boolean isOffline, String forceGroupProfiles)

    at AppNavBar..ctor()

    at gescacmaq_main_aspx.__BuildControlcrmAppNav()

    at gescacmaq_main_aspx.__BuildControlTree(gescacmaq_main_aspx __ctrl)

    at gescacmaq_main_aspx.FrameworkInitialize()

    at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    at Page.ProcessRequest()

    at Page.ProcessRequest(HttpContext context)

    at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    at ApplicationStepManager.ResumeSteps(Exception error)

    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    >Sitemap subArea with id "nav_goals" has empty Title. Created title Inconnu48 for it>>

     

    and it keeps going for different titles.

    Here is a warning I found in the trace that does corroborate the error report from IE:

    << at MapOrgUtility.SetOrganizationInformation(HttpApplication application, LocatorService locator, Guid orgId)

    at MapOrgEngine.GetOrganizationFromPath(Object sender)

    at SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    at ApplicationStepManager.ResumeSteps(Exception error)

    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    >MapOrgEngine: Unable to retrieve the OrgId for URL[http://xr0004m2:81/GESCACMAQ/main.aspx].>>

     

    Thanks for your help.

    Regards,

     


    :~DaDynamixFan
    Thursday, February 2, 2012 4:19 PM
  • I am experiencing the same problem. Upgrade from CRM 4, run windows updates to apply UR6, reboot a few times. Blank screen upon hitting the CRM URL with the "Error initializing component with element id=’null’ and with type=’null’ :Object expected"

    Did you solve this?

    Wednesday, February 8, 2012 9:02 PM
  • Hi folks,

    I resolved the issue: it was stemming from a GPO that set an authorisation rule in IIS that disabled anonymous authentication.

    Since CRM authenticate once for the session then uses anonymous access to load the remaining components such as the JScripts files the page would not load properly...

    Oh well, these pesky network admins ;-)

    Regards,


    :~DaDynamixFan


    • Edited by DaDynamixFan Friday, February 17, 2012 10:51 AM
    • Marked as answer by DaDynamixFan Friday, February 17, 2012 10:51 AM
    Friday, February 17, 2012 10:51 AM
  • Forgive me for asking a dumb question, but where exactly did you find the GPO that caused the issue?

    Thanks!!


    Sam majam

    Thursday, May 24, 2012 12:34 AM
  • HI ,

    I am also facing the same issue . I have installed on win 2012 server with 2011 installation . For the first time it got installed and was working but after 2 days I was not able to open deployment manager also so I uninstalled and started again. Now every time it is giving new error. Now it says

    'Error initializing component with element id='crmHistoryManager' and with type='null': Object doesn't support this action'.

    TIA

    Friday, September 19, 2014 12:28 PM