locked
Client cannot connect to home server console nor can I connect with RDC RRS feed

  • Question

  • I know this problem is listed else where but the other trhreads seem to be old and probably not visited with the same frequency as a new thread.

    I have tried all the suggestions I can find on this site and others.

    I can't run RDC or console from any of my clients. (I have reported this in another thread but it was an old thread so might not be recieving current attention)

    This is the fourth time this has happened. Each time I have ended up re-installing Home server and the problem is fdixed for several weeks. Then all of a sudden it restarts usually after a server update. Once it has started I lose connection with all my clients for RDC and console, but I can ping by name, access shares, backup etc.

    I have DNS set to my router. I am using Netbios over Tcp/ip and every other recommendation listed on this site.

    After the problem starts , I can run the connector install from the server directory which uninstalls and reinstalls the connector.

    I enter my password and it joins the server and configures the backups.

    but I still can't access wih RDC or Console.

    ---------------------------
    Windows Home Server Console
    ---------------------------
    This computer cannot connect to your home server. Check your network connection and make sure your home server is powered on. If your home server has recently restarted, try again in a few minutes.
    ---------------------------
    OK  
    ---------------------------

    I have my server defined in myhost files.

    The problem is clearly with the server end as it runs for weeks OK then fails for all clients at the same time.

    I have tried re-booting my router - no change. The only change is that the server has recently installed updates and was rebooted. But after the reboot the problems start. The only way I can clear this is with a 5 hour server re-build then every thing will be fine for a few weeks.

    BTW I have no addin on my server.
    Here is the data from my clients system.

    My server has two cards 77 and 78 my server response is below the client response.

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\Kevin>net view \\reid-server
    Shared resources at \\reid-server



    Share name                 Type  Used as
                    Comment

    -------------------------------------------------------------------------------
    Clip Art                   Disk
                    Clip Art to browse
    Films                      Disk
                    Movies
    Golf                       Disk
                    Otley Golf Rabbits and more
    Harwood Property Holdings  Disk

    IPod Photo Cache           Disk

    Music                      Disk
                    Shared folder for music
    OneNote                    Disk

    Outlook                    Disk

    Photos                     Disk
                    Shared folder for photos
    Public                     Disk
                    Shared folder for miscellaneous files
    Reid IT services           Disk
                    Business Files
    Software                   Disk
                    Shared folder for software installation programs
    Users                      Disk
                    Personal folders for users
    Videos                     Disk
                    Shared folder for videos
    The command completed successfully.


    C:\Users\Kevin>ping reid-server

    Pinging reid-server [192.168.1.77] with 32 bytes of data:
    Reply from 192.168.1.77: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.77: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.77: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.77: bytes=32 time=1ms TTL=128

    Ping statistics for 192.168.1.77:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    C:\Users\Kevin>ping 192.168.1.78

    Pinging 192.168.1.78 with 32 bytes of data:
    Reply from 192.168.1.78: bytes=32 time=11ms TTL=128
    Reply from 192.168.1.78: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.78: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.78: bytes=32 time=1ms TTL=128

    Ping statistics for 192.168.1.78:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 11ms, Average = 3ms

    C:\Users\Kevin>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Kevs-Laptop
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : home

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : home
       Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Con
    nection
       Physical Address. . . . . . . . . : removed   DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::ad2d:f868:608f:ff61%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.70(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 03 December 2008 08:16:54
       Lease Expires . . . . . . . . . . : 04 December 2008 08:19:00
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DNS Servers . . . . . . . . . . . : 192.168.1.254
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection*:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:d5c7:a2ca:3836:2d88:3f57:feb9(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::3836:2d88:3f57:feb9%12(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{E2923977-E02F-422B-BEA8-DEA79CF9B
    CF6}
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\Users\Kevin>nslookup
    Default Server:  api.home
    Address:  192.168.1.254

    > latte
    Server:  api.home
    Address:  192.168.1.254

    *** api.home can't find latte: Non-existent domain
    > reid-server
    Server:  api.home
    Address:  192.168.1.254

    Name:    reid-server.home
    Address:  192.168.1.77

    >


    Server response

    Microsoft Windows [Version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\Documents and Settings\Administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : reid-server
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Unknown
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : home

    Ethernet adapter Local Area Connection 2:

       Connection-specific DNS Suffix  . : home
       Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adapter
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IP Address. . . . . . . . . . . . : 192.168.1.78
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DNS Servers . . . . . . . . . . . : 192.168.1.254
       Lease Obtained. . . . . . . . . . : 03 December 2008 10:26:01
       Lease Expires . . . . . . . . . . : 04 December 2008 10:26:01

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : home
       Description . . . . . . . . . . . : SMC EZ Card 10/100 Fast Ethernet PCI Netw
    ork Adapter
       Physical Address. . . . . . . . . : removed
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IP Address. . . . . . . . . . . . : 192.168.1.77
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DNS Servers . . . . . . . . . . . : 192.168.1.254
       Lease Obtained. . . . . . . . . . : 03 December 2008 10:26:01
       Lease Expires . . . . . . . . . . : 04 December 2008 10:26:01

    C:\Documents and Settings\Administrator>ping kevs-laptop

    Pinging kevs-laptop.home [192.168.1.70] with 32 bytes of data:

    Reply from 192.168.1.70: bytes=32 time=288ms TTL=64
    Reply from 192.168.1.70: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.70: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.70: bytes=32 time=1ms TTL=64

    Ping statistics for 192.168.1.70:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 288ms, Average = 72ms

    C:\Documents and Settings\Administrator>nslookup
    Default Server:  api.home
    Address:  192.168.1.254

    > reid-server
    Server:  api.home
    Address:  192.168.1.254

    Name:    reid-server.home
    Address:  192.168.1.77

    >

    Monday, January 26, 2009 9:43 AM

Answers

  • Kev Reid said:

    Used RDC with IP address and by server name in the past but now neither work.

    I cant find RDP port 3389 in Netstat - only TCP and UDP ports listed and none of these are port 3389

    How do I start it listening on this port?

     

    Thanks

     

    Kev



    You should definitely find TCP local address port 3389 listening on your server 

    Please go to the terminal services configuration (Start, Run, tscc.msc), check properties for listed tcp-rdp connection (and write them down), delete this connection, restart server. After booting go again to tscc.msc, create a new connection, restart server once again. This will probably fix your issue but NOT prevent the issue from happening again. 

    I've seen this happen on W2K3 servers, and this solution worked for me, never got to the bottom of this though. You could have a look at this thread, I think this probably describes the root of the problem and provides a more permanent solution. Never checked this personally though.

     

    EDIT: AFAIK this only happens if reboot is intiated from a remote desktop connection or automatically (windows update). You could also choose to install the updates manually (set automatic updates to download only) and then install when logged on to to server desktop (not RDC)

    Monday, January 26, 2009 6:51 PM
    Moderator

All replies

  • Hello,Kev.

     Do you installed NVIDIA or ATI display driver to your WHS?
    Such problem caused by non-supported display drivers.

    Please uninstall display driver,and  try again.

    Thanks.

    Monday, January 26, 2009 11:46 AM
  • The first thing I would suggest is removing or disabling one of your server's two network interfaces. Windows Home Server does not support, and may not function correctly in, a multi-homed network environment.
    I'm not on the WHS team, I just post a lot. :)
    Monday, January 26, 2009 12:15 PM
    Moderator
  •  If it is a NVidia video card driver, you can also alter the registry.

    Copy following lines into a text file, save it with extension .reg, log in locally to your server, import the file with a doubleclick and reboot the server.

    Windows Registry Editor Version 5.00
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
    "SessionImageSize"=dword:00000020

    Best greetings from Germany
    Olaf

    Monday, January 26, 2009 12:50 PM
    Moderator
  • Thanks for your speedy replies unfortunately none worked.

    I have disabled a network card and rebooted - no change

    My Video card a ATI Radeon 7000 VE Family - the drivers are the drivers that WHS loads on install. I can't roll them back

    I uninstalled them and did nothing when widows was re-booted - still can't connect with RDC or Console.

    If I have to reload WHS again to get rid of this problem I will probably throw the system through the windows and go back to Acronis on each client system.

    Thanks for trying to help

     

    Kev

    Monday, January 26, 2009 3:09 PM
  • 1.  Have you ever tried RDC using server IP instead of server name, so enter 192.168.1.77 in the computer name field?

    2. Please check if your server is listening on RDP port 3389 (netstat -an from command prompt)

    Monday, January 26, 2009 4:08 PM
    Moderator
  • Used RDC with IP address and by server name in the past but now neither work.

    I cant find RDP port 3389 in Netstat - only TCP and UDP ports listed and none of these are port 3389

    How do I start it listening on this port?

     

    Thanks

     

    Kev

    Monday, January 26, 2009 6:06 PM
  • Hi Kev,

    did you remove the second network interface in the meantime? (Disable in device manager.)

    You can try to login locally, click Start, right click My Computer and select Properties. On the Remote tab uncheck "Enable Remote Desktop on this Computer" and click Apply. Now check thhe checkbox again and apply the setting.

    Try again to use the console from another machine. If this is still not working, you can check the Windows Firewall. The Remote Desktop exception should be enabled for the local subnet scope.

    Could also be a security suite on the client, which is blocking RDP access.

    Best greetings from Germany
    Olaf

    Monday, January 26, 2009 6:28 PM
    Moderator
  • Kev Reid said:

    Used RDC with IP address and by server name in the past but now neither work.

    I cant find RDP port 3389 in Netstat - only TCP and UDP ports listed and none of these are port 3389

    How do I start it listening on this port?

     

    Thanks

     

    Kev



    You should definitely find TCP local address port 3389 listening on your server 

    Please go to the terminal services configuration (Start, Run, tscc.msc), check properties for listed tcp-rdp connection (and write them down), delete this connection, restart server. After booting go again to tscc.msc, create a new connection, restart server once again. This will probably fix your issue but NOT prevent the issue from happening again. 

    I've seen this happen on W2K3 servers, and this solution worked for me, never got to the bottom of this though. You could have a look at this thread, I think this probably describes the root of the problem and provides a more permanent solution. Never checked this personally though.

     

    EDIT: AFAIK this only happens if reboot is intiated from a remote desktop connection or automatically (windows update). You could also choose to install the updates manually (set automatic updates to download only) and then install when logged on to to server desktop (not RDC)

    Monday, January 26, 2009 6:51 PM
    Moderator
  • Thanks Brubber - I am nearly there -

    I ran tscc.mcs and there were no connections showing at all so unfortuately nothing to write down. I created a new connection and took the default path thru the questions.

    I can now open the console and RDC intyo the desktop again but both as for a repeat of the login credentials - should I have selected a different option somewhere when I set up the connection. I remeber leaving authentication as basic perhaps I should have selected none.

    could you please check your settings and let me know what they should be.

    I will set to manual update so that the server doesn't reboot. My guess is that there has been an automatic reboot just prior to the clients loosing the connection every time this has happened - every few weeks or couple of months.

    Thanks again for the diagnosis. If you can let me know what the settings should be I will get it working properly again.

    Thanks for saving me having to repair a window - I was very close to throwing the server thru one.

    Kev

    Monday, January 26, 2009 7:46 PM
  • Hi Kev,

    your description looks relatively similar to the issue described in this thread. So may be the solution there may help you as well.

    Best greetings from Germany
    Olaf

    Monday, January 26, 2009 11:20 PM
    Moderator
  • Hi Kev,

    If you find no connections listed at all that's clearly the root of your problem. Lucky you have a machine with console access! Here are my settings:

    Type = Microsoft RDP5.2

     

    General Tab:

                Security: Negotiate

                            Encryption Level: Client Compatible

                            Certificate: Choose the one issued to your servername

                Use Standard Windows Logon Interface: NOT checked

     

    Logon Settings Tab:

                Use Client-provided logon information checked

     

    Session Tab:

                NONE of the override options checked

     

    Environment Tab:

                Run intial program specified..... checked

     

    Remote Control Tab:

                Use remote control with default user settings checked

     

    Permissions Tab:

                Administrators: Full Control

    Local Service: Special Permissions (Advanced, Permissions: Allow Query Information and Allow Message)

    Network Service: Special Permissions (Advanced, Permissions: Allow Query Information and Allow Message)

                Remote Desktop Users: User Access and Guest Acces

                System: Full Control

     

    Client Settings Tab:

                Use Connection settings from user settings checked

                Limit Maximum Color Depth checked, setting 24 bit

                Disable the following:

                            Audio mapping checked

    Network Adapter Tab:

                All Network adapters configured with this protocol

                Maximum connections = 2

    Tuesday, January 27, 2009 5:38 AM
    Moderator
  • Thanks Brubber

    all fixed up again - at least now when it happens I can put it back. I have turned automatic updates off to give me some manual control over the server re-starts

     

    Thanks again

     

    kev

    Tuesday, January 27, 2009 4:41 PM
  • Kev Reid said:

    Thanks Brubber

    all fixed up again - at least now when it happens I can put it back. I have turned automatic updates off to give me some manual control over the server re-starts

     

    Thanks again

     

    kev



    Your welcome! This solution definitely beats server reinstall.
    Tuesday, January 27, 2009 7:19 PM
    Moderator