none
SyncToy 2.0 not running via scheduler on windowx xp service pack 3.0 RRS feed

  • Question

  • I have been trying to schedule the synctoycmd.exe with no luck. I have followed the suggestions in this forum but none of the related scheduler threads have helped me.

    anyway, I am running windows xp professional service pack 3.0 and using the latest Synctoy Version (2.0)

     

    on the scheduler task this is what I have: "C:\Program Files\SyncToy 2.0\SyncToyCmd.exe"  -R in order to run all folder pairs.

    If I look at the SyncToy Log I see the following information:

     

    SYNC: 09/23/2008 09:29:00:609: -------------------------------------------------------------------------
    SYNC: 09/23/2008 09:29:00:609: Starting SyncToy, version 2.0.100.0, built 8/12/2008 2:07:12 PM.

     

    but that is all that is processed.  it seems that it exits with an error but no error is registered in the log.

    If I run the application manually (open SyncToy.exe) all runs well and the log registers every step taken

    Have anyone experienced this problem?  and is there a solution?

    Thanks

    Tuesday, September 23, 2008 1:30 PM

Answers

  • While validating the source of the error code "0x1", I stumbled upon the solution of the problem.

    my computer is part of a computer network domain and I belong to the Network Administrators Group.  

     

    "SyncToy Help" states that you must have administrative privileges in order to install the application, specially if you don't have the Microsoft Sync Framework.  Since I have administrator privileges I installed Synctoy with my user profile and on the scheduler task I had the "Run As" Field As the local Administrator.

     

    It turns out that if you install SyncToy with a profile that is not Administrator:

     

    1)  You must use that same profile in the "Run As" Field on the Task Tab, as in "YourDomain\yourprofilename"

    2)  also, you have to mark the "Run only if logged on" checkbox.

    3)  Remember to set your password also.

     

    The scheduler is now running the SyncToyCmd correctly.

     

    for more information on scheduler issues see   http://support.microsoft.com/default.aspx/kb/308558 

     

    Thanks everyone for your help.

     

    Monday, September 29, 2008 2:55 PM

All replies

  • by the way, I am trying to synchronize to an external usb disk.  And the directories being synchronized are on the local computers c:\ drive.

     

    Tuesday, September 23, 2008 1:32 PM
  • I personally haven't acutally run the new SyncToy through the schedualer directly, but I have been running a batch file that also handles the shutting down and restarting of certain programs so they don't interfere with the proper backing up of all my files due to anything being 'locked'. 

    Just call each folder pair on a different line in the batch file.  It will step through each one, waiting for each particular pair to finish before returning to the next step in the batch file.

    Here's a sampling from my batch file.

     

    Code Snippet

     

    cd C:\Program Files\SyncToy 2.0\
    title Synctoy Step 1
    synctoycmd.exe -R"Step 1"
    title Synctoy Step 2
    synctoycmd.exe -R"Step 2"
    title Synctoy Step 3
    synctoycmd.exe -R"Step 3"
    title Synctoy Step 4
    synctoycmd.exe -R"Step 4"

     

     

    Make SURE that there is no space between the -R and the "step #" name. 

     

    Not the BEST solution, but it IS a solution. 

     

    Once you have your batch file crafted to your liking, you can use that in the Scheduled Tasks.

     

    d

    Thursday, September 25, 2008 5:35 PM
  •  

    Thank you for your reply. 

    I tried that but it did not work.  I tried running the batch file manually and it runs OK, but something is preventing it from running thru the windows scheduler.  I have checked the security issues and the task scheduler service and all seems fine.

    All I have are two folder pairs.  here is the contents of the batch file:

     

    Code Snippet

    cd C:\Program Files\SyncToy 2.0\
    SyncToyCmd.exe -R"MyDocuments"
    SyncToyCmd.exe -R"Projects"

     

     

    I have also checked the windows event viewer.  There are critical or warning messages related to the task either.

     

    any other suggestions?

    Friday, September 26, 2008 1:25 PM
  • When you set the batch file to run in the Scheduled Tasks program and let the scheduled time pass, what is the code that shows in the "Last Result" column?

    d
    Friday, September 26, 2008 5:10 PM
  • I solved a similar problem by using 8.3 names in the task propierties tab.

     

    First I tried to copy the original command in the execute option (in the start menu) and I had the message that "C:\archivo."  cannot  be found (why so short?, I said)

     

    So I tried with the 8.3 DOS names (be carefull with the .0 of the synctoy dir, it makes me go crazy for some minutes)

     

    Finally with  "C:\Archiv~1\Syncto~1.0\SyncTocmd.exe -R" (Please note that you should change "archiv" for the six first letters of your program folder) worked fine, but I had a flash black screen whit an unreadable message..... I have changed the unit and need a new syncro with the windows util. After that, everything worked fine.

     

    Hope I helped you

     

    Saturday, September 27, 2008 7:17 PM
  •  

    drougnor , the last result shown is "0x1"

    I really don't know what that result means.

    Monday, September 29, 2008 1:57 PM
  • jugosali,

    although I really don't think that 8.3 Dos Names would solve the issue I am having with SyncToy, I verified and tested anyway your suggestion.  Nonetheless, the issue stands, but thanks any way for your help.

    crames.

    Monday, September 29, 2008 2:16 PM
  • The 0x1 means it completed with an error being returned.  Most likely cause is that your pc is being sensitive to the spaces in 'Program Files' and so forth.  The above poster is on to something with using the 8.3 naming convention, but I'd try something a little more simple.

    Try to alter your cd command just a little.

    cd "c:\program files\.....

    The quotes tells windows to follow the absolute path, and not to see the space as the end of the command.

    Give that a try and let us know if that helps.

    d
    Monday, September 29, 2008 2:20 PM
  • While validating the source of the error code "0x1", I stumbled upon the solution of the problem.

    my computer is part of a computer network domain and I belong to the Network Administrators Group.  

     

    "SyncToy Help" states that you must have administrative privileges in order to install the application, specially if you don't have the Microsoft Sync Framework.  Since I have administrator privileges I installed Synctoy with my user profile and on the scheduler task I had the "Run As" Field As the local Administrator.

     

    It turns out that if you install SyncToy with a profile that is not Administrator:

     

    1)  You must use that same profile in the "Run As" Field on the Task Tab, as in "YourDomain\yourprofilename"

    2)  also, you have to mark the "Run only if logged on" checkbox.

    3)  Remember to set your password also.

     

    The scheduler is now running the SyncToyCmd correctly.

     

    for more information on scheduler issues see   http://support.microsoft.com/default.aspx/kb/308558 

     

    Thanks everyone for your help.

     

    Monday, September 29, 2008 2:55 PM
  • Yes,

    Had the same problem. The point is that if you don't want cmd window to popup while you are working, you must run scheduled task as another user. Sync toy remembers folder pairs on per-user basis, so the user that's running scheduled task must be the same guy that created the pairs.

    v.
    Thursday, December 31, 2009 9:49 AM
  • This post is over a year after the original, but I stumbled on to it by experiencing the same issues with useing a scheduled task with SyncToy.  Essentially, you have to schedule the task to run under the same context as the user account that created it.  If you have a sevice account you want to use, you must log into the machine with that account name, setup synctoy then schedule the task.  And if you're one to cleanup user profiles and forget that you used your service account to set up synctoy you'll end up deleting your pairs if you remove the profile.

    I would reccomend another program, cheap (but more expensive than free), under $30 bucks and will sync in real time, no need for scheduled tasks.  You set the service account on the service for user context.  It's loaded with options...highly reccomend (and i have no ties to the company whatsoever other than being an end user.)

    http://secondcopy.com
    Tuesday, January 5, 2010 2:46 PM
  • I was also getting the same error code, After running the command lines in CMD windows it would not run either telling me I had to do a manual Sync first. Hopefully that fixes my error
    Wednesday, September 5, 2012 9:15 PM
  • Just in case anyone else stumbles across this in the future (there are very little resources for this):

    I have found a solution, I had a scheduled task that was working on a 2003r2 x64 box, so I connected to that box with Task Scheduler and exported the job to an XML.

    I then imported the job back into the local box task scheduler. I re-worked some of the aspects of it (like run with highest privileges) and then re-exported it.

    This job is now successfully running on my 2008r2 x64 systems without problem.

    I now have a secondary backup of my files.

    Below is the XML output, so you can copy, paste and import it as functional task scheduler job:

    <?xml version="1.0" encoding="UTF-16"?>
    <Task version="1.1" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
      <RegistrationInfo>
        <Author>administrator</Author>
      </RegistrationInfo>
      <Triggers>
        <CalendarTrigger>
          <StartBoundary>2012-12-11T10:00:00</StartBoundary>
          <Enabled>true</Enabled>
          <ScheduleByWeek>
            <DaysOfWeek>
              <Saturday />
            </DaysOfWeek>
            <WeeksInterval>1</WeeksInterval>
          </ScheduleByWeek>
        </CalendarTrigger>
      </Triggers>
      <Principals>
        <Principal id="Author">
          <UserId>administrator</UserId>
          <LogonType>InteractiveTokenOrPassword</LogonType>
          <RunLevel>HighestAvailable</RunLevel>
        </Principal>
      </Principals>
      <Settings>
        <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
        <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
        <IdleSettings>
          <StopOnIdleEnd>false</StopOnIdleEnd>
          <RestartOnIdle>false</RestartOnIdle>
        </IdleSettings>
        <Enabled>true</Enabled>
        <Hidden>false</Hidden>
        <RunOnlyIfIdle>false</RunOnlyIfIdle>
        <WakeToRun>false</WakeToRun>
        <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
        <Priority>5</Priority>
      </Settings>
      <Actions Context="Author">
        <Exec>
          <Command>C:\Program Files\SyncToy 2.1\SyncToyCmd.exe</Command>
          <Arguments>-R</Arguments>
          <WorkingDirectory>C:\Program Files\SyncToy 2.1</WorkingDirectory>
        </Exec>
      </Actions>
    </Task>


    Rule your day, you never know when it might be your last.

    Tuesday, July 30, 2013 5:44 PM