locked
Moving reports from CRM 2011 to CRM 2013 RRS feed

  • General discussion

  • Hi all,

    I've just migrated an environment from CRM 2011 to CRM 2013. It's gone pretty well but I'm having trouble with a couple of custom reports. These were written in Report Builder 2.0 as SQL-based reports and worked quite well. I've changed the server and database they're looking at so that should be it.

    However, when I upload them to CRM, there's a problem. Firstly, there's one report that runs of a list of specified values - this works fine. All the other reports use a query to get a list of Accounts and then the report is run against this account. When these are uploaded into CRM, the report runs but the list is empty so I can't select any accounts.

    Now, I've run the SQL query in SQL Management Studio and it returns the list of Accounts. I've run this report in Report Builder 2.0 and, again, the list is there. I've also been into the browser and opened up the report server, found and run the report and, again, the list is there.

    I've even shrunk down my SQL so that it's simply "SELECT Name, AccountId FROM FilteredAccount ORDER BY Name"

    Can anyone think of a reason why this list is not being filled in when I'm accessing it via CRM?

    Wednesday, November 5, 2014 12:45 PM

All replies

  • Absolutely no idea why this should be the case but it turned out that using an SQL statement to populate a drop down does not work when using an embedded connection. This was changed to a shared connection that I created on the report server and this meant that the reports worked. It also needed to be written in Report Builder 3.0.
    Thursday, November 6, 2014 5:42 PM