locked
WHS shuts down and starts up on it own RRS feed

  • Question

  • Don't know why this is happening, but shortly after I use "Shutdown" on my server, like the bathtub scene with Glenn Close in Fatal Attraction, the server comes back to life. The only solution I have is turn it off at the plug.

    I subsequently realised that when I start up the server, it will decide to shut itself down after a period (varies, but can be any period between 20 minutes to an hour - very roughly)

     
    Other factors I've looked into:
    - I've got Lights Out installed, but the only setting enabled there is an auto shutdown at 11pm every night, so I don't think that's the culprit.
    - I've also got Wake-on-LAN enabled, but I've checked and there's nothing that should be sending magic packets. 
    - Am running WHS RC 2011.

    Can anyone out there offer some suggestions to troubleshoot this?!  Is there a log file that would help isolate this?  If so, where would I find it.
     

    Thanks in advance,

    G

    Saturday, March 5, 2011 10:42 PM

All replies

  • Oh - a bit more detail about my setup:

    OS: Windows Home Server RC 2011
    Motherboard: Asus P5G41-M LX
    Router: Netgear Wireless-N 300 Router

    Saturday, March 5, 2011 10:44 PM
  • Sounds like a hardware issue.  I might try disabling lights out, and see if the problem persists, but my guess would be hardware.  Power supply, motherboard, ect.

    D.W.
    Saturday, March 5, 2011 10:46 PM
  • Don't know why this is happening, but shortly after I use "Shutdown" on my server, like the bathtub scene with Glenn Close in Fatal Attraction, the server comes back to life. The only solution I have is turn it off at the plug.

    I had this issue with WHS v1, but the Team resolved it. And, no, it wasn't a hardware issue with that particular Dell computer. Of course, I'm not using the same computer for WHS 2011 as with v1, though.

    Have you ever had another OS on the computer, and if so, did you have the same shutdown problem?


    Nancy Ward
    Sunday, March 6, 2011 2:06 AM
  • Nancy,

    From a cmd prompt, run "shutdown /?" and take a look at the various options. "shutdown /s" should turn you off and "shutdown /r" should give you a restart.  You can access the gui with "shutdown /i".  The /s, /r, and /i are some of the options I frequently use when connected with RDP to various computers and servers.


    _______________

    BullDawg
    In God We Trust
    _______________
    <Nancy Ward> wrote in message news:fbb4805a-bda5-4774-8cd8-c03b228fb94f@communitybridge.codeplex.com...

    Don't know why this is happening, but shortly after I use "Shutdown" on my server, like the bathtub scene with Glenn Close in Fatal Attraction, the server comes back to life. The only solution I have is turn it off at the plug.

    I had this issue with WHS v1, but the Team resolved it. And, no, it wasn't a hardware issue with that particular Dell computer. Of course, I'm not using the same computer for WHS 2011 as with v1, though.

    Have you ever had another OS on the computer, and if so, did you have the same shutdown problem?


    Nancy Ward


    BullDawg
    Sunday, March 6, 2011 2:17 AM
  • Whoops, it wasn't Nancy that was asking!  The NNTP Bridge has scrambled my threading!  The comment is directed at whoever Nancy was responding to!


    _______________

    BullDawg
    In God We Trust
    _______________
    <BullDawg> wrote in message news:6e47eeb0-502d-491e-a423-d6de6bd26c57@communitybridge.codeplex.com...

    Nancy,

    From a cmd prompt, run "shutdown /?" and take a look at the various options. "shutdown /s" should turn you off and "shutdown /r" should give you a restart. You can access the gui with "shutdown /i". The /s, /r, and /i are some of the options I frequently use when connected with RDP to various computers and servers.


    _______________

    BullDawg
    In God We Trust
    _______________
    <Nancy Ward> wrote in message news:fbb4805a-bda5-4774-8cd8-c03b228fb94f@communitybridge.codeplex.com...

    Don't know why this is happening, but shortly after I use "Shutdown" on my server, like the bathtub scene with Glenn Close in Fatal Attraction, the server comes back to life. The only solution I have is turn it off at the plug.

    I had this issue with WHS v1, but the Team resolved it. And, no, it wasn't a hardware issue with that particular Dell computer. Of course, I'm not using the same computer for WHS 2011 as with v1, though.

    Have you ever had another OS on the computer, and if so, did you have the same shutdown problem?


    Nancy Ward

    -- BullDawg


    BullDawg
    Sunday, March 6, 2011 2:19 AM
  • Whoops, it wasn't Nancy that was asking!  The NNTP Bridge has scrambled my threading!  The comment is directed at whoever Nancy was responding to!

    That gave me a laugh. :) Because even after following all the 'structions of the v1 Team, I still couldn't get a true shutdown. Until they fixed it in the code. Then it worked fine.


    Nancy Ward
    Sunday, March 6, 2011 2:59 AM
  • Sounds like a hardware issue.  I might try disabling lights out, and see if the problem persists, but my guess would be hardware.  Power supply, motherboard, ect.

    D.W.

    Hi D.W.

    Sorry for the late response on this.  Have finally managed to do a bit of work on this.

    Interestingly, I think it's to do with with the Launchpad installed on the laptops on my network.  I have a number of devices connected to the network (printer, 4 Logitech squeezeboxes and...my two laptops).  If I close the lids on the laptops then the shutdown/reboot cycle doesn't seem to happen. 

    Have you ever had another OS on the computer, and if so, did you have the same shutdown problem?

    Hi Nancy - When I had the previous OS (Ubuntu) this didn't occur, which also leads me to think that Launchpad may be the reason.

    Do either of you know whether Launchpad fires Magic Packets?  Could this be the reason? And, if so, is there a way to configure it so it doesn't send packets periodically?

    Thanks for any help!

    GG

    Tuesday, March 8, 2011 5:36 AM
  • Hi Nancy - When I had the previous OS (Ubuntu) this didn't occur, which also leads me to think that Launchpad may be the reason.

    Do either of you know whether Launchpad fires Magic Packets?  Could this be the reason? And, if so, is there a way to configure it so it doesn't send packets periodically?Thanks for any help!

    Of course, I know nothing about Ubuntu; I was actually asking about Win 7, Vista, etc. :) i.e. there were no shutdown problems with the Dell when I had Vista installed on it (prior to installing WHS v1).

    Although Launchpad has gotten a tad bit smarter, I still can see no reason for it. And, I don't know what a Magic Packet it. :( And although I don't care for Launchpad (I shut it down immediately after a reboot), I've never had any issues with it. Other than that great big fat blob in the middle of my very clean, no icons whatsoever, desktop.

    OK, I'm going to reboot and check out the Launchpad to be sure I haven't "let my fingers overload my . . ."


    Nancy Ward
    Tuesday, March 8, 2011 2:56 PM
  • OK, I'm going to reboot and check out the Launchpad to be sure I haven't "let my fingers overload my . . ."

    Well, forevermore! I guess I've shut down the Launchpad one too many times because it no longer jumps onto my desktop on bootup! It's not in the area on the right either.

    I don't know where it's gone.


    Nancy Ward
    Tuesday, March 8, 2011 3:10 PM
  • On Tue, 8 Mar 2011 15:10:33 +0000, Nancy Ward wrote:

    Well, forevermore! I guess I've shut down the Launchpad one too many times because it no longer jumps onto my desktop on bootup! It's not in the area on the right either.

    I don't know where it's gone.

    Start/All Programs/Windows Home Server 2011/Launchpad


    Paul Adare
    MVP - Identity Lifecycle Manager
    http://www.identit.ca
    Software:  Typically silk nighties, nylons, garter belts.  Contrast with
    hardware.

    Tuesday, March 8, 2011 3:12 PM
  • You can set the launchpad to start when the computer does.  You can also set it not to.  Check the settings in the launchpad.
    D.W.
    Tuesday, March 8, 2011 3:20 PM
  • "I shut it down immediately after a reboot"
     
    Nancy- when you have a reboot and Launchpad starts you can use the "down arrow" just to the left of the "X" and on that is where the settings are for this. You can, like I do, tell it not to start on reboot or Windows start. That way you reboot, startup or whatever and Launchpad doesn't run. To get the icon in the taskbar you then go to the app and click on it so it starts at that point.

    --
    Don
    Wednesday, March 9, 2011 1:08 AM
  • Go to the start menu/all programs/windows home server 2011 and click on Launchpad.
     
    The reason it is no longer starting is probably in the settings I mentioned above.

    --
    Don
    Wednesday, March 9, 2011 1:10 AM
  • You can set the launchpad to start when the computer does.  You can also set it not to.  Check the settings in the launchpad.

    Maybe that's what I did and forgot I did it. :) Prolly need some more RAM for this old brainstem. :)


    Nancy Ward
    Wednesday, March 9, 2011 4:00 AM
  • Nancy- when you have a reboot and Launchpad starts you can use the "down arrow" just to the left of the "X" and on that is where the settings are for this. You can, like I do, tell it not to start on reboot or Windows start. That way you reboot, startup or whatever and Launchpad doesn't run. To get the icon in the taskbar you then go to the app and click on it so it starts at that point.

    Probably what I did, Don, and quickly forgot about it. :) I keep the Dashboard icon in my QuickLaunch bar, because that's pretty much the way I start WHS.


    Nancy Ward
    Wednesday, March 9, 2011 4:02 AM
  • ME:
    Hi Nancy - When I had the previous OS (Ubuntu) this didn't occur, which also leads me to think that Launchpad may be the reason.

    Do either of you know whether Launchpad fires Magic Packets?  Could this be the reason? And, if so, is there a way to configure it so it doesn't send packets periodically?Thanks for any help!

    NANCY:
    <snip> And, I don't know what a Magic Packet is.

    A "magic packet" is essentially a signal used to wake up a computer on a network.  In my case, I have remote controller for my Logitech Squeezebox, where, if I hit a button on them, they send a message via the squeezebox that wakes my server.  They're also used for client PCs to wake up other PCs or servers...which I suspect is what's happening here.  That's one of the hypotheses I have about what's waking (and then shutting down) my server.  The other hypothesis was that the Lights-Out add-in might be doing this, but this seems unlikely.  Although I've got the Launchpad installed on both my client laptops, only one has the Lights-Out add-in installed and that one's been disconnected from the network at the times the server has been starting/stopping.

    Any other suggestions from anyone on this group would be hugely appreciated.

    Sunday, March 13, 2011 3:06 AM
  • A "magic packet" is essentially a signal used to wake up a computer on a network.  . . . They're also used for client PCs to wake up other PCs or servers...which I suspect is what's happening here.

    Aha! Thanks for the info, although I've never heard it called a "magic packet". Your suspicion is right though, in that when the Connector is installed, there's an option to "wake the [client] computer for backup if it's asleep". Thing is, when my client gets awakened, it won't go back to sleep.

    I've never used anything to make WHS go to sleep. I think it may have been either discouraged or not possible in V1, so didn't do it with this build/beta either.


    Nancy Ward
    Sunday, March 13, 2011 5:45 AM
  • ...when the Connector is installed, there's an option to "wake the [client] computer for backup if it's asleep".
    Nancy Ward

    You mention it's an option, but I can't find any settings to turn it off. Any suggestions on where to find this?

    Also, it seems odd (not to mention annoying) that if you haven't signed in, the Connector still tries to boot up the computer.  It would be good if the option includes the ability to only wake the server only after signing in. 

    Cheers,

    GG

    Sunday, March 13, 2011 10:38 PM
  • ...when the Connector is installed, there's an option to "wake the [client] computer for backup if it's asleep".

    You mention it's an option, but I can't find any settings to turn it off. Any suggestions on where to find this?

    OK, let's run through installing the Connector to the client computer from the Start:

    1. Open IE and type in: http://servername/connect where "servername" is what you named your server without the quotes.
    2.A green window will come up. Click on the green arrow (Download software for Windows).
    3. A window will come up that says: Do you want to run or save this file. Click on the Run button.
    4. Do you want this program to make changes to your computer? Click Yes.
    5. The "Connect Computer to the Server" wizard enables you to:
    *Connect your computer to the server, *Monitor the health of your computer, *Back up your computer daily, *Manage your server using this computer
    This wizard first verifies that your computer meets the minimum requirements to connect to the server. Click the Next button.
    6. Your computer may restart several times during the installation.
    If Microsoft .NET Framework 4.0 or later is not installed, then it will be installed as part of the connection process.
    You will be asked to enter your server password as part of the installation. Click the Next button.
    7. Verifying . . .
    8. Enter the Windows Home Server 2011 password. Click the Next button.
    9. The name of your client computer comes up under Computer description. (Here's where you change it if you want. I don't.) Click the Next button.

    10. Here's the option to turn on your computer for backup if it's asleep:
    Do you want to automatically wake up this computer to back it up?
    Choose if you want to wake this computer to create its backup.
    O Yes, wake up this computer if it is either in sleep or hibernate mode to back it up. (I choose this radio button to wake up.)
    O No, only back up this computer if it is turned on.
    Note: After backup is finished, a return to sleep or hibernate mode does not occur with some computers. Click the Next button.

    11. You're asked if you want to participate in the Windows Customer Experience. (I say yes if it's a beta, no if it's an RTM.)

    12. The software is configured, your computer is connected to the network and you can now log onto the server.

    Also, it seems odd (not to mention annoying) that if you haven't signed in, the Connector still tries to boot up the computer.  It would be good if the option includes the ability to only wake the server only/after/ signing in.

    I don't understand what you mean here. Which computer is the Connector trying to boot up? Is this something to do with Lights Out? If so, I do not use it, so have no knowledge of it.

    Cheers,

    GG

    http://


    Nancy Ward
    Monday, March 14, 2011 3:41 AM
  • Hi Nancy,


    Thanks for this.  I've actually already got Connector installed, so was wondering what I need to do to get to the Settings and tell it not to automatically send commands from clients to boot up the server.

    Apologies - To clarify the second point, what I mean is that  even though I'll have a client computer running, with the Launchpad started* but not signed in, Launchpad appears to send a wake command to bootup the server.  Then, bc it's not signed it in, after 5 minutes it shuts down, which seems a crazy and wasteful loop.  I'd like to instruct Launchpad/Connector to not send commands to bootup the server, UNLESS i've signed into Launchpad.

    I hope that clarifies everything.


    GG

    *I have Launchpad as one of the apps in my Startup folder

    Monday, March 14, 2011 10:23 PM
  • If you have lights out installed as an addin, one of its client options is to wake the server when the computer is started. You can enable or disable this from the dashboard, lights out tab, computers sub tab. Double click the computer concerned and alter the properties as you see fit. I personally have not set the server to wakeup with the clients and start it manually from the "Lights Out system tray icon" when I need the server running.

    I doubt if it's Lights Out causing your problem unless you have it misconfigured, as to required usage. I have it installed on the server and 2 clients and it behaving exactly as I expected.

    One option would be to temporarily uninstall lights out from the server and clients. This would enable you to see whether the problem persists or goes away. Will help eliminate lights out as a suspect or not.

    Just another thought, if one of your machines is a media centre and turns on to record a TV program, if lights out is set to wake up the server on start the server will fire into life with the MC.

    Dave 

     

     


    The Frog on the Lilypad at Home
    • Edited by frogz1 Monday, March 14, 2011 11:41 PM Extra Info
    Monday, March 14, 2011 11:38 PM
  • what I mean is that  even though I'll have a client computer running, with the Launchpad started* but not signed in, Launchpad appears to send a wake command to bootup the server.  Then, bc it's not signed it in, after 5 minutes it shuts down, which seems a crazy and wasteful loop. 

    Just had a re-read of the thread and noticed that although you mentioned lights out at the beginning but you have removed it further on.

    My query is as follows. Your description above is just about a perfect description of what happens with a bog standard lights out client install.  If I am remembering correctly, the default installation will wake up the server when the client boots and the default hibernation time on the server is 5 minutes. So the client starts and, unless being monitored to keep the server running is ticked, the server will go back into hibernation 5 minutes later. 

    Your problem still sounds like a lights out addin issue of some sort.

    When the server is not running and I try to login either via Launchpad or Dashboard it simply fails as it cannot find the server.

     

    Dave

     


    The Frog on the Lilypad at Home
    • Edited by frogz1 Tuesday, March 15, 2011 8:52 AM Extra Info
    Tuesday, March 15, 2011 8:26 AM
  • Hi GG,

    is this issue still alive? Have you configured your network card as documented in the Lights-Out manual: http://www.axonet.de/vail/beta1/Lights-Out%20for%20Windows%20Home%20Server%202011.pdf

    Some network cards support wake-up from pattern match and may wake the server when dashboard tries to connect. Change this to magic packet only to prevent that.

    Have you tried to run a shutdown and then immediately disconnect the LAN cable?

    BTW: The official support forum for Lights-Out on Vail is here: http://forum.wegotserved.com/index.php/forum/299-lightsout/


    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Tuesday, March 15, 2011 5:33 PM
    Moderator
  • I have a similar issue:  mine shuts down on its own.  This is a WHS shutdown, not hardware.  I actually see the shutdown screen working.  I am hoping this is resolved in the RTM version.
    When in doubt empty the magazine...
    Friday, March 18, 2011 8:28 AM
  • I've had a similar issue since I started using Lights Out on 5th March.  I had clients to shutdown after backing up around 23:00 with the server suspending itself at 01:00 to conserve energy costs.  However, every other day, network restarted between 03:12 & 03:42.

    This really bugged me as I could not track down what was causing this event.  Posted the query on the WGS forum under the Lights Out section & the developer came back with a possible answer: -

    Check Windows Updates:  I did so & found that it was set to 03:00.  Changed it over to 12:00 & thought that the problem would be resolved - It wasn't but that was due to me.  I forgot to change the Windows Update settings on ALL client machines.

    Since then, Lights Out has been running ok with the shutdowns/suspend & restarts working as scheduled.

     

    This might not be the solution to other's problems but it may help.

    Saturday, March 19, 2011 1:31 PM
  • I had hoped this problem would go away with the last RC.  It is still there and very random.  I have done several clean re-installs.  I really want this OS to work so I can have a decent media server setup.  I don't even mind not having DE.
    When in doubt empty the magazine...
    Thursday, March 24, 2011 2:12 AM
  • Apologies - To clarify the second point, what I mean is that  even though I'll have a client computer running, with the Launchpad started* but not signed in, Launchpad appears to send a wake command to bootup the server. Then, bc it's not signed it in, after 5 minutes it shuts down, which seems a crazy and wasteful loop.  I'd like to instruct Launchpad/Connector to not send commands to bootup the server, UNLESS i've signed into Launchpad.

    That's what I thought you were saying and Launchpad is not the guilty culprit here, as Dave said. :)

    Sorry to be so long in replying but I've been forced offline with the Community Bridge (reads forums) and I'm not all that great with reading forums. I can never tell where I'm at; between the a and the t or wherever!


    Nancy Ward
    Saturday, March 26, 2011 4:27 AM