locked
OCS R2 and CS1000 inbound call RRS feed

  • Question

  • Hi,
    we have deployed OCS R1 two years ago with CS1000 (without dualfork) anche work correctly. Now we have deployed OCSR2 (also with CS1000) and we have a problem with inbound call from pstn. If i call from MOC to pstn work correctly, if I call from pstn to MOC, my MOC ring, but when I pic-up the call is dropped with error message "call was not completed or has ended". On client I have installed the hotfix KB 967673 but without improvement.
    I have logged on OCS and the is following error (see below).

    Some one have idea about this problem?
    Thanks,
    Elia.

    TL_INFO(TF_PROTOCOL) [0]0CF4.0A30::04/29/2009-08:13:21.715.00075be8 (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(122))$$begin_record

    Instance-Id

    Direction

    Peer

    Message-Type

    Start-Line

    From

    To

    CSeq

    Call-ID

    MAX-FORWARDS

    VIA

    ROUTE

    CONTENT-LENGTH

    $$end_record

    : 0USER-AGENT: RTCC/3.5.0.0 MediationServerMs-diagnostics: 10010;source="OCSR2Mediation.pilot.local";reason="Gateway side Media negotiation failed";component="MediationServer";ValidationError="Gateway GetAnswer Error: Object reference not set to an instance of an object.";GatewayFqdn="mydomain.it"Message-Body:
    : <sip:ocsr2.pilot.local:5061;transport=tls;opaque=state:T;lr>
    : SIP/2.0/TLS 192.168.0.22:2844;branch=z9hG4bK595d08b
    : 70
    : 0301f011-a1cc-4ea3-ac66-c2348afc97ce
    : 17 BYE
    : <sip:623;phone-context=LocationProfile_TEST@pilot.local;user=phone>;epid=f70d125600;tag=f3a4ab6605
    : BYE sip:myname@pilot.local;opaque=user:epid:8FF1IfIbU1uxErImgBouxQAA;gruu SIP/2.0: <sip:3465065xxx;phone-context=+39@pilot.local;user=phone>;epid=065AF8A082;tag=4cc73f6da4
    : request
    : OCSR2Mediation.pilot.local:2844
    : incoming
    : 00000952
    Wednesday, April 29, 2009 8:55 AM

All replies

  • Elia,

    You probably need to give more information about your environment. What does the architecture from the PSTN look like?

    PSTN -> Gatewy -> CS1000 -> ???????

    Let us know the inbound path of the call. It looks like there 'might' be a codec mismatch issue "Gateway side Media negotiation failed"

    So if everything is configured exactly the same as when you were on R1, perhaps R2 codecs changed (not sure that's the issue though).

    More information would be helpful.

    --Matt

    Friday, May 1, 2009 8:37 PM
  • Hi Elia,

    Did you upgrade to CS1000 Rel. 5.5 and Nortel MCM 4.0.0.16?  These are the only certified versions for OCS R2.

    We are actually in the middle of implementation but we are currently stuck in the Proxy server installation and MCM 4.0 install.  The proxy server installs and activates correctly but the service refuses to start up.  Did you have a problem with this as well?  If so, how did you fix it?

    The error I see in the Event Log when trying to start the OCS Proxy Service is:

    Event 14352, OCS Protocol Stack

    Unable to start the stack

    Error: 0x0xC3E93C62 (SIPPROXY_E_NO_DEFAULT_OUTGOING_CERT).



    I have the Nortel documentation detailing the new details when integrating CS1000 5.5 with OCS R2, let me know if you want it.

    Regards,

    Manuel.-
    Sunday, May 3, 2009 4:53 PM
  • Thank You Manuel,
    I don't have update  the environment (I still have 5.5 and mcm 3.5 and old version of ocsproxy).
    Next step then, is to update the environment. :-)

    If you  could indicate to me where download the new version of Nortel documentation, it would be very helpful.

    Regards,
    Elia.
    Monday, May 4, 2009 7:59 AM
  • Hi, a detail that I forgot:

    my test are without MCM and OCSProxy,  I don't ahve full integration but simple sip trunk between CS1000 and Mediation (I don'thave media gateway).
    We have installed on CS1000 some new patch.
    The path for inbound call is: PSTN-->CS1000-->Mediation-->OCS (the same as the R1).

    Thanks and Kind Regards,
    Elia.
    Monday, May 4, 2009 8:33 AM
  • Hi Elia,

    I have zipped and uploaded the 2 documents here:

    http://files.me.com/malvarez/6mixs1

    The documents also say all the PEPs that must be installed in the CS1000.

    The link will expire in 1 week, so be sure to downloaded it before then.

    EDIT:  I just saw that one of the documents says this:

    "Information for a Direct SIP configuration between CS1000 Rls. 5.5 and OCS 2007 R2 is not included in this document. 

    The Direct SIP configuration is currently in the validation process and availability will be announced in a later bulletin. "


    Regards,

    Manuel.-
    • Proposed as answer by jcff Thursday, November 12, 2009 7:06 PM
    Monday, May 4, 2009 12:56 PM
  • Elia or Manuel,

    Did you ever get your CS1000 to work?  We are having nearly identitcal problems.  Inbound call cannot be answered on MOC client with the same error above.

    We are running CS 1000 v5.5 and MCM 4.0.16.  Just curious if there was something special you needed to do.

    Richard
    Tuesday, May 19, 2009 5:33 PM
  • We are still in the process of upgrading our CS1000.  Although we have OCS R2 running, we haven't begun the integration with the CS1000.  I'll let you know when we are in the phase.
    Tuesday, May 19, 2009 6:06 PM
  • Thanks for the info.  We just did a direct connection from the CS1000 to the mediation server and still get the error.  So the only good thing I can say it that we can eliminate the MCM/Proxy server as being the problem.  We have a ticket open with MS on this issue so if I hear something I will post it here.
    Tuesday, May 19, 2009 9:44 PM
  • Hello dawho9nine.

    We are in a migration process from RTM to R2. Now we are running into the same problem. We can call the MOC from PBX phone but not from the outside PSTN. Outbound calls are possible without any problems.

    I'm wondering about this SIP URI:

    <sip:3465065xxx;phone-context=+39@pilot.local;user=phone>;

    For me it look's malformed. We can see the same in our logs. I agree with your that the MCM/proxy is not the source of the problem. I think there is an issue with the mediation server.

    Can you provide any new suggestions or a solution from MS Support?

    Thank you,

    Andy

    P.S.: On our mediation server we can log this:

    TL_ERROR(TF_PROTOCOL) [2]19E4.1BFC::06/05/2009-15:01:00.821.00005a2d (MediationServer,GatewayCall.GatewayParticipateComplete:gatewaycall.cs(995))( 0000000002166972 )$$START-MEDIATIONSERVER

    MediationCall

    : 9c016596b70842549e8762994c914ff5

    CallId

    : 1e153e80-fa14a8c0-13c4-40030-ab86f0-5fa6bdb3-ab86f0

    From

    : sip:+49xxxxxxxx@mechcs1k.com;user=phone

    To

    : sip:+49xxxxx4512;ext=4512@mechcs1k.com;user=phone

    Direction

    : Inbound

    Start-Line

    :

    SDP Exchange Exception: Microsoft.RTC.MediationServerCore.MCSignalingException: Gateway SDP Neogiation Error: Gateway GetAnswer Error: Object reference not set to an instance of an object.

    at Microsoft.RTC.MediationServerCore.GatewayCall.GatewayParticipateComplete(IAsyncResult ar)

    $$END-MEDIATIONSERVER

    Friday, June 5, 2009 3:52 PM
  • Our inbound calling issue through the PRI was a Nortel PEP issue.  I don't recall the exact PEP number that needed to be applied but it was a recent one included in Nortel's latest support bulletin for CS1k running 5.5.  (Something from 5/26 if I recall).

    After this we still had some RCC connectivity issues that were resolved after the NRS server was set with proper DNS server settings.  So we now have a fully functional R2 against a CS1k running 5.5.  Kinda nice actually.

    Richard
    • Proposed as answer by AndyGER Tuesday, June 30, 2009 7:06 PM
    Tuesday, June 9, 2009 9:40 PM
  • Exactly. It's BULLETIN ID: 2009009453, Rev 2 (Nortel)

    We have to apply it next week.

    • Proposed as answer by AndyGER Tuesday, June 30, 2009 7:06 PM
    Friday, June 12, 2009 1:05 PM
  • Hi

    Does anyone encoutered problem with MCM Version 4.0.0.16 service which was working fine and suddenly stopped and not starting anymore.

    On event viewer we got:  "Registration with OCS failed".

    Thanks

    Friday, June 12, 2009 10:48 PM
  • Do you have ANY more information for us? Like the MCM log? Did you any changes somewhere, like DNS? Have you checked your certificates for running out of date?
    Saturday, June 13, 2009 5:23 PM
  • Hi

    Please find below MCM log file:

    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:09:01 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:09:11 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:09:14 PM: 4.0.0.16: Debug: OnCustomCommand: got command: update config data
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid secondary NRS address: 0.0.0.0
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid Node IP address: 0.0.0.0
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid LDAP server IP address: 0.0.0.0
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:09:15 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:09:21 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:09:31 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:10:38 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:10:48 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:10:58 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:11:08 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:16:19 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:16:29 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:16:39 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:16:44 PM: 4.0.0.16: Debug: OnCustomCommand: got command: update config data
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid secondary NRS address: 0.0.0.0
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid Node IP address: 0.0.0.0
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: ConfigurationData: ReadConfigFile: Invalid LDAP server IP address: 0.0.0.0
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:16:45 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:16:49 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:39:56 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:40:06 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:40:16 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:40:26 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:40:52 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:41:02 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:41:02 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:41:02 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:41:03 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:41:03 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:41:03 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:41:03 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:41:13 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:41:23 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: MCM: Syslog successfully open, initialization started
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: InitializeADSearchDomains: invoked
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: IMDB constructor: invoked
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: MCM: initialization finished
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: MCM  Main: starting service
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: OnStart: invoked
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: Start: invoked
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: OnStart: AD Cache initializing
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registering
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #1
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: AD Cache: Indices loading
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: AD Cache: Indices loaded
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: AD Cache: initialized
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:43:23 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #2
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:43:33 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: OnStart: OCS Server Application registration attempt #3
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: RegisterApplication: invoked
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: RegisterApplication: new instance is created
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: Register: failed to Register: Exception:
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: RegisterApplication: changes committed
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: ConfigAppOrder: MCM Application not found
    6/12/2009 4:43:43 PM: 4.0.0.16: Debug: RegisterApplication: Applications failed to reorder
    6/12/2009 4:43:53 PM: 4.0.0.16: Debug: OnStart: OCS Server Application failed to register

    Thanks
    Monday, June 15, 2009 7:00 AM
  • Hi, im unsure if this is of any relevance to you, But OCS r2 doesnt support CS1k sip yet DIRECT.


    RTM was supported but R2 isnt as of yet.

    SO if your trying direct SIP into R2 from release 5 ot 5.5 it shouldnt work or if it does itll be problematic.

    Nortel as of last week i think dropped the patch to make this work.


    Your only real way is either a Dialogic Inline gateway or the old school way and a secondry E1 from the CS1k into gateway then to OCS.


    I crossed this bridge 4 weeks ago and hit a a whole world of pain.

    Thanks

    Rob
    Tuesday, June 16, 2009 12:51 PM
  • Hello iso30.

    The MCM stops suddenly, without any changes?

    Please check this:

    - Has the RTCProxy an never expiring password?
    - Are your certificates not expired?
    - Do you have installed all OCS Updates?
    - Do you have installed all PEP updates? What is the release of the CS1k?
    - Are you sure that all DNS is correct and the next hop server is reachable? (try to log communication with wireshark)
    - Do you have re-installed the MCM on a R2 Proxy?

    Andy
    Tuesday, June 16, 2009 5:05 PM
  • Not sure if this helps: We have OCSR2 running with our Nortel CS1000, using Dual-forking. We left our Mediation server / Proxy-MCM 3.5 server at R1 Code....since it was working and we are moving to the Direct-SIP model. (Since MCM doesn't support 64 bit and R2 requires 64 bit - not sure how you are running "pure R2" in this case?) Direct_SIP is not supported - but will be soon (they keep saying), and we have this working with a signaling server => Mediation server directly (still waiting to fully implement). They have documentation - but I can never find it on their site. (I have it locally, from Nov 2008...) Cheers. - Steve Hahn
    Steve Hahn
    Wednesday, June 17, 2009 4:02 PM
  • Hi Guys

    I uninstalled OCSR2 proxy and MCM and reinstalled them and it works now.
    Incoming calls from PSTN->CS1k->MCM->Mediation->OCS communicator works fine and we can ring
    both communicator and nortel soft phone.
    However outgoing call from communicator -> mediation -> MCM->CS1K->PSTN is not working.
    I checked MCM logs and the call is there but it is not leaving MCM to CS1K,
    What i should configure on MCM, on nortel NRS??

    Thanks
    Wednesday, June 17, 2009 8:03 PM
  • Hi Steve.

    You can find the document for R2 integration in BULLETIN ID: 2009009453, Rev 2. But you need to get a direct link from the nortel support to download it.

    We are running the MCM 4.0 as a WOW64 application on the R2 Proxy server and it works fine. We also started with a R2 Pool Server in our RTM installation, but we lost some features like redirection or dual forking. So we decided to migrate to R2.

    Andy
    Thursday, June 18, 2009 5:36 AM
  • Hey guys.

    Now I can confirm the discussed updates as the solution for the inbound call problem. After this updates everything runs well with OCS R2.

    Andy
    Tuesday, June 30, 2009 7:08 PM
  • Has anyone been able to fix this problem yet? I am running a CS1K with release 5.5, MCM version 4.0, and OCS 2007 R2. Everything was working before the upgrade and now it's just not working. I can't call a PSTN number but I can dial communicator configured numbers. Here's one of the errors from my client.

    "488 Not Acceptable Here

    Ms-diagnostics: 10010;source="OCSR2Mediation.contoso.com";reason="Gateway side Media negotiation failed";component="MediationServer";ValidationError="SDP Exchange already failed before SetAnswer: Gateway doesn't offer any valid codec.";GatewayFqdn="10.50.10.123"

    Thanks,

    Georgi


    Georgi
    Thursday, July 23, 2009 4:04 AM
  • Hi Georgi.

    After installing all patches and PEP's for the CS1k R5.5 everything is working fine. You can get the OCS R2 integration document from the Nortel support.

    Andy
    Thursday, July 23, 2009 5:33 AM
  • ok, I'll work with the Nortel team to see make sure all the patches were applied.

    Thanks,

    georgi
    Georgi
    Thursday, July 23, 2009 2:26 PM