locked
Can't Log in to my WHS Remote Page RRS feed

  • Question

  • I am trying to diagnose why my server isn't letting me use Remote Access. One of the first steps I have tried is to access the server from within my LAN I can get to the landing page with the server name as well as the I.P. Then I click on Log In button and get an error page.

     

    Server error in '/ Remote'' Applicatioin is the heading

     

    I have checked and ports 80, and 443 are open, 4125 shows as closed.

     

    Remote Access worked previously. But I recently lost 2 hardrives and had to remove and replace them on my WHS. The WHS works properly now with the exception of remote access.

    Monday, July 5, 2010 1:20 PM

All replies

  •  On 7/5/2010 8:20 AM, RonRock wrote:

    I am trying to diagnose why my server isn't letting me use Remote Access. One of the first steps I have tried is to access the server from within my LAN I can get to the landing page with the server name as well as the I.P. Then I click on Log In button and get an error page.



    Server error in '/ Remote'' Applicatioin is the heading



    I have checked and ports 80, and 443 are open, 4125 shows as closed.



    Remote Access worked previously. But I recently lost 2 hardrives and had to remove and replace them on my WHS. The WHS works properly now with the exception of remote access.

    You may find your answer in some of the other threads from the past two weeks on this (or similar subjects).  Specifically one from antfortas http://social.microsoft.com/Forums/en-US/whssoftware/thread/90c4a16b-b9f0-43e3-8834-08215a6d4ce1 .  In there we tracked the problem down to the IIS website using .NET version 1.1 instead of 2.0.  The steps for fixing this are in that thread (amongst a couple of others).  Look for some threads starting with Olaf Engelke on June 28, 2010 and follow that line (I'm reading this through a different system than you, so it may not appear in a "Threaded" view).

    Have a great day:)
    Patrick.


    Smile... Someone out there cares deeply for you.
    Have you updated today?
    http://update.microsoft.com


    Smile.. Someone out there cares deeply for you.
    Monday, July 5, 2010 6:33 PM
  • I have followed the mentioned thread and my .NET version appears to be correct.

     

    Here is a copy of the page I see when I attempt to Log On to my server from a browser,

     

     

    Server Error in '/Remote' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>

    The WHS connector works fine and the shares are all OK.

     

    Any other thoughts?

    Wednesday, July 7, 2010 12:20 PM
  • Anybody?
    Friday, July 9, 2010 12:40 PM
  • Do you see this also on http://<YourServerName>:55000/enrollid/id.xml?

    Did you install any other software, which may have altered IIS?

    Best greetings from Germany
    Olaf

    Friday, July 9, 2010 9:34 PM
    Moderator
  • Can you explain exactly what I should put into the <YourServerName> brackets? If I Remote Desktop into my WHS it is called server. So am I correct that I need to go to http://server:55000/enrollid/id.xml to get the information you are asking for? Or do I need the <  > brackets? Or do I use my domain name? My domain name is https://ronrockwell.homeserver.com.

    Not trying to be a PITA just unsure and looking for any help.

     

    Nothing installed AFIK. I do have WHS auto update but never messed with update from server desktop. I did follow your previous thread and checked the IIS version and all appears as you suggest should.

     

    "So as mentioned the manual interaction with IIS is the only way to fix such changed configuration without having to reinstall the server. Logon locally or via Remote Desktop as Administrator to your Windows Home Server.

    1. Click Start/Control Panel/Administrative Tools/Internet Information/Internet Information Services Manager.
    2. Click the + icons to open the tree components. Right click the various sites (i.e. WHS Site and the sub folders with the gear icon) and select Properties.
    3. On the ASP.NET tab change the version to 2.0.50727 and click Apply.
    4. Repeat this for every WHS related component in IIS.
    5. After completing, reboot the server.

    Best greetings from Germany
    Olaf"

    Saturday, July 10, 2010 2:22 AM
  • After a bit of research I found others who have tried these IP's so here are the results I get from my LAN;

     

      http://SERVER:55000 takes me to "Windows Home Server Connector Setup" page with buttons to download WHS Connector Setup, WHS Toolkit, and Contact Customer Support.

     

    https://SERVER:56000 takes me to the same page as above after I accept some security restrictions.

     

    http://SERVER takes me to my WHS landing page where I have the "Log On" button

     

    https://SERVER  takes me to my WHS landing page where I have the "Log On" button

     

    When I click on "Log On" in either http, or https I see the same

    Server Error in '/Remote' Application.

    Runtime Error

     

    Saturday, July 10, 2010 2:48 AM
  • I did non have to change my ASP.NET versions. They were and are all set correct at 2.0.50727.
    Saturday, July 10, 2010 10:41 AM
  •  On 7/10/2010 5:41 AM, RonRock wrote:

    I did non have to change my ASP.NET versions. They were and are all set correct at 2.0.50727.

    I found this information about the /Remote error on Microsoft's site.  However, it applies to a different configuration than WHS, so you may want to wait until Olaf or someone else confirms that it won't do more damage.  The link is http://support.microsoft.com/kb/823379  and their advice is


          ASP.NET 2.0

       1. Click Start, click Run, type cmd in the Open box, and then
          click OK.
       2. Switch to the Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
          folder. In this folder, Drive is the drive where Windows is
          installed. To do this, type the following line at the command
          prompt, and then press ENTER:
          cd Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
       3. Add the appropriate permissions to the Network Service group for
          the Temporary ASP.NET Files folder. To do this, type the
          following line, and then press ENTER:
          aspnet_regiis -ir
          Note For more information about the difference between the
          -ir command-line option and the -i command-line option,
          visit the following Microsoft Web site:
          http://msdn2.microsoft.com/en-us/library/k6h9cz8h(vs.71).aspx
          <http://msdn2.microsoft.com/en-us/library/k6h9cz8h%28vs.71%29.aspx>
          (http://msdn2.microsoft.com/en-us/library/k6h9cz8h(vs.71).aspx)

    This link may have some helpful information as well http://www.mediasmartserver.net/forums/viewtopic.php?f=5&t=2095&view=next  In it, I would start by changing the line in your error message to show you what the error is (in the config file), then post the error message here.  If it's something with the .NET Framework not finding a file, then you can try his method at the end of the thread (repairing .NET 2.0 SP1)

    Hope this helps, and have a great day:)
    Patrick.


    Smile... Someone out there cares deeply for you.
    Have you updated today?
    http://update.microsoft.com


    Smile.. Someone out there cares deeply for you.
    Saturday, July 10, 2010 5:11 PM
  • Anyone have another suggestion? Still no joy.
    Tuesday, July 13, 2010 2:28 PM
  • If you try to open the site from the WHS desktop, are the results the same? If this works, check the security software on the client for possible blockings of ports.

    You could try to uninstall Power Pack 3 from your home server, since this also reverts the WHS related webcontent to the preinstallation state. (Assuming your WHS had not Power Pack 3 integrated already).

    Other than that the only thing remains without wasting too much time is to recommend a server reinstall. (another word for "out of senseful ideas")

    Best greetings from Germany
    Olaf

    Tuesday, July 13, 2010 9:45 PM
    Moderator