locked
Mapped network drives rename themselves! RRS feed

  • Question

  • I'm having a weird problem with my PC. I recently re-installed XP (SP2), and now, when I rename my mapped network drives to something short and cute, they rename themselves, after a while, back to their original long names, e.g. "such-and-such share on the so-and-so server". Sometimes the short name will last a couple of hours, sometimes only a minute.

    I use these drives in toolbars, and the long name obliterates them, and no matter what I do, nothing seems to fix this. I've been running things this way for years, and it's never happened before, and I there doesn't seem to be any specific trigger, either. It's driving me nuts!

    I've searched and searched online for an answer, and while I've found a couple of instances of the question, so far, no replies.

    HELP!

    -mu
    Saturday, March 24, 2007 11:36 AM

Answers

  • It's okay, I figured out a workaround (hack).

    First, rename the network drive. Then navigate to...
    My Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

    Your network drive will have its own key something like "##server-name#share-name", right-click the key and get its permissions.

    Basically, you want to have it read-only. So, click the "Advanced" button at the bottom of the dialog, and uncheck the "inherit from parent the permissions.." checkbox. In the dialog that follows, choose "Copy", and <ok> that.

    Back in main permissions dialog, security (the only) tab, unckeck "full control" for all users (there may be a "RESERVED" user, which has read-only access anyway, leave it as it is.) and <ok> back to the registry editor.

    Your mapped drives will now keep their cute names for ever, or at least until you reinstall Windows.

    -mu

    Saturday, March 24, 2007 5:48 PM

All replies

  • It's okay, I figured out a workaround (hack).

    First, rename the network drive. Then navigate to...
    My Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

    Your network drive will have its own key something like "##server-name#share-name", right-click the key and get its permissions.

    Basically, you want to have it read-only. So, click the "Advanced" button at the bottom of the dialog, and uncheck the "inherit from parent the permissions.." checkbox. In the dialog that follows, choose "Copy", and <ok> that.

    Back in main permissions dialog, security (the only) tab, unckeck "full control" for all users (there may be a "RESERVED" user, which has read-only access anyway, leave it as it is.) and <ok> back to the registry editor.

    Your mapped drives will now keep their cute names for ever, or at least until you reinstall Windows.

    -mu

    Saturday, March 24, 2007 5:48 PM
  • is there another way to fix this?

    i've done what's said above with no avail, and there's nothing out there

    this is very strange

    please help

    thanks

    Wednesday, May 16, 2007 6:43 AM
  • I would also like to know the answer to this! I am experiencing the same problem!

    I rename the mapped drive, but as soon as I reboot my machine, it renames it self back to 'username on servername' etc...

    Any help at all would be appreciated!
    Friday, July 20, 2007 2:42 PM
  • Guys! The reg hack works, I can assure you. You either a) didn't do it, or b) didn't do it right.

    If you are getting errors, or don't fully understand the procedure, ask a question, I'll be happy to give more details.

    Try again!

    -mu
    Friday, July 20, 2007 4:49 PM
  • Why is this 'hack' even necessary? On all other PC's on my network, the renaming of the drive REMAINS after reboot...
    Friday, July 20, 2007 5:27 PM
  • At least it's a temporary solution until we can figure out what is causing the problem. It works for me as well Smile
    Saturday, July 21, 2007 5:23 PM
  • The cause is a complete mystery to me. As far as I can see, I haven't altered anything since last time I installed XP. The reg hack is nasty, but it certainly works a treat.

    Most likely, we'll never know the actual cause.

    -mu
    Monday, July 23, 2007 11:40 PM