CRM 4 move organization to another server RRS feed

  • Question

  • I am having issues after moving a crm app from one server to another. I restored the source db to the destination db, imported the organization, and tried both manual mapping the users and auto-mapping them with the same result. The issue is - when a workflow tries to create a Task entity record, it fails. Tracing states that the user does not exist; the guid being reported is the system user from the source application. Both source and destination are in the same domain, and the system user is the same AD service account. It seems that the mapping between system users is not happening, even though I've specified it in the manual user map.

    Monday, October 29, 2012 1:27 PM

All replies

  • Hi,

    If you are moving to a server in the same domain - I suggest using auto mapping. Are you sure that the user being used in the workflow is enabled?

    It could be that the user is being assigned a different GUID in the new organisation - which would mean that the workflow is still referencing the old one. If this is the case, unpublish the workflow, re-select the user and publish again.



    Scott Durow
    Read my blog: www.develop1.net/public     Follow Me on Twitter
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Thursday, November 1, 2012 9:41 AM
  • I guess you have used this:


    Roar Jørstad aka sveroa
    Senior Consultant, EVRY as
    Blog: Notebook, trick & tips
    Please mark as answer or helpful if my post is useful

    Thursday, November 1, 2012 1:41 PM
  • I've tried the auto-map and the kb, thanks. Have a ticket opened with Microsoft now.
    Thursday, November 1, 2012 2:26 PM