locked
ICE-2.0.2 Installation Issue RRS feed

  • Question

  • Attempting to install subject application. Box opened up saying I need Visual C++ Runtime Libraries. Downloaded vcredist_arm.exe, vcredist_x64.exe, and vcredist_x86.exe from Microsoft site. The x64 and x86 exe applications ran and installed. When attempting to run vcedist_arm, I get a pop-up box stating that vcredist_arm.exe is not a valid Win32 application. I have downloaded and attempted to run it numerous times with the same result. I am running W7 SP1 and, as far as I know, I'm up to date.  Assistance requested. Thanks.
    • Edited by TerryL47 Saturday, February 7, 2015 3:27 PM
    Friday, February 6, 2015 1:17 PM

All replies

  • you don't need vcredist_arm, that is for tablet computers
    Friday, February 6, 2015 6:38 PM
  • As stated, I successfully installed the x64 and x86 executables. However, when I run the ICE-2.0.2 install application, I still get the pop-up saying I need the Visual C++ Runtime Libraries. Windows Update tells me that my computer is up to date. Any thought on where I should be looking? 
    Friday, February 6, 2015 8:30 PM
  • Could you check that msvcr120.dll is in your system folder (typically C:\Windows\System32) and let us know the version (just hover over it in file explorer)?
    Monday, February 9, 2015 8:13 PM
  • Yes, msvcr120.dll is in my system folder. Version is 12.0.21005.1 dated 10/04/13. 
    Monday, February 9, 2015 8:52 PM
  • Thanks for confirming, TerryL47.  That's what the ICE installer is looking for, so we're trying to figure out what's going wrong for you and others.  While we continue to investigate, would you mind sending us the following information?

    1. Start > run "msinfo32.exe".
    2. File > Save to "system.nfo" file on your desktop.
    3. Send email to hdview@microsoft.com and attach the "system.nfo" file.  (If it's too large, please upload to OneDrive or DropBox and send us a link.)

    Thanks!


    Eric Stollnitz, Computational Photography Group, Microsoft Research

    Wednesday, February 11, 2015 2:53 AM
    Moderator
  • This answer is a repeat of another reply in an identical thread started by another user.

    This morning after many unsuccessful efforts, for the heck of it, I attempted to install ICE 2.0.2 from my computer's Safe Mode. To my surprise, it was successful and after restarting a normal Windows startup, it ran fine. Could it be that something in my normal startup was preventing the install executable from recognizing that I had the requisite libraries installed?


    • Edited by TerryL47 Wednesday, February 11, 2015 3:59 PM clarity
    Wednesday, February 11, 2015 3:59 PM
  • Glad you got it installed!

    If you wouldn't mind helping us debug this issue further, here is a way to log what is happening during installation:

    http://www.advancedinstaller.com/user-guide/qa-log.html

    So if you could run "msiexec.exe /i ICE-2.0.2-for-32-bit-Windows.msi /L*V ICE.log" and then send us ICE.log that would be great, thanks!

    Friday, February 13, 2015 8:07 PM