none
"Destination Folder Access Denined" on file move RRS feed

  • Question

  • I have been using the WHS for a while without any problems. But when I try to move files from my private user folder to a the Music share I get the error message: Destination Folder Access Denied. You need permission to perform this action.
    Any ideas..?
    Tuesday, March 10, 2009 10:25 PM

Answers

  • I think this is working now..
    I copied all my files to the public folder from the console. So I deleted my user and recreated it. So I copied the files back, and on advanced on security I checked the "replace permissions entries on all child objects with entries here that apply to child objects". So now I have the correct permission on all files..
    • Marked as answer by Milzit Friday, July 3, 2009 10:36 PM
    Friday, July 3, 2009 10:36 PM

All replies

  • Milzit said:

    I have been using the WHS for a while without any problems. But when I try to move files from my private user folder to a the Music share I get the error message: Destination Folder Access Denied. You need permission to perform this action.
    Any ideas..?


    Have you changed the permissions on any of your shares (either through the Console or by right-clicking on a folder and changing the properties)?  Is your Guest account on the server currently enabled?
    Wednesday, March 11, 2009 12:48 AM
    Moderator
  • I have not changed any shares on the folders, but I have created some new shares under my user folder. The time of this error message was approx. on the same time as I created the shared. But I tried to remove the shares without any results. The guest account is diabled, and I'm admin user.
    Wednesday, March 11, 2009 9:18 AM
  • Milzit said:

    I have not changed any shares on the folders, but I have created some new shares under my user folder.
     

    Creating shares in any way other than using the Console is unsupported (and it could be the root cause of your problems).

    Milzit said:

    The time of this error message was approx. on the same time as I created the shared. But I tried to remove the shares without any results. The guest account is diabled, and I'm admin user.

    Can you copy files to the Music share from anywhere else (i.e. your client PC)?  Can you check your permissions in the Console for your user name for the Music share and make sure you have Full Access?  If so, can you check the Security on the Music share (right click on the share, select Properties, then Security tab) and post the results here?
    Saturday, March 14, 2009 6:45 PM
    Moderator
  • Thank you for the information, sorry for the late reply.
    Yes, I can copy files from my client PC to the music folder without any error message.
    On the security tab both of my users have full access, expect for the guest accounts that has "none".
    Tuesday, June 30, 2009 10:28 PM
  • Thank you for the information, sorry for the late reply.
    Yes, I can copy files from my client PC to the music folder without any error message.
    On the security tab both of my users have full access, expect for the guest accounts that has "none".

    Can you please be specific about what you see in the Security tab (every user name, every group name, and permission)?  Feel free to post a link to a pic if it's easier.
    Wednesday, July 1, 2009 12:07 AM
    Moderator
  • Administrator Allow on all actions
    CREATOR OWNER Only gray checkbox on special permissions, all others unchecked
    RO_L  Allow on Read & Execute, List Folder Contents, Read
    RW_L  Alow on all, gray on special permissions
    SYSTEM  allow on all, gray on special permissions
    Thursday, July 2, 2009 8:45 PM
  • Administrator Allow on all actions
    CREATOR OWNER Only gray checkbox on special permissions, all others unchecked
    RO_L  Allow on Read & Execute, List Folder Contents, Read
    RW_L  Alow on all, gray on special permissions
    SYSTEM  allow on all, gray on special permissions

    Although I don't see how this would affect your security, mine does not have the grayed out checkbox for Special Permissions on the RW group as well as the SYSTEM account.
    Friday, July 3, 2009 12:43 PM
    Moderator
  • I think this is working now..
    I copied all my files to the public folder from the console. So I deleted my user and recreated it. So I copied the files back, and on advanced on security I checked the "replace permissions entries on all child objects with entries here that apply to child objects". So now I have the correct permission on all files..
    • Marked as answer by Milzit Friday, July 3, 2009 10:36 PM
    Friday, July 3, 2009 10:36 PM
  • Thanks for this useful post.  It solved my problem.

     

    I had two shares in my Movies folder.  Using Windows 7, one subfolder was accessible and the other was denied.

     

    The permissions for \\WHS\movies\movie1 were set for users RO_L RW_L and that worked from W7.

    The permissions for \\WHS\movies\movie2 were set for users RO_P RW_P and that was locked for access from W7.

     

    By right clicking \\WHS\movies and clicking Advanced Options and selecting "replace permissions entries on all child objects with entries here that apply to child objects", the permissions were changed to

     

     

    The permissions for \\WHS\movies\movie1 were for users RO_L RW_L

    The permissions for \\WHS\movies\movie2 were changed to users RO_L RW_L

     

     

    And both folders were accesible from W7. 

     

    Thanks very much for this useful post.

     

    I could have allowed inherited permissions for RO_L and RW_L for subfolders of WHS\movies but I didn't want to go that route.

    • Edited by BobJoylove Friday, March 4, 2011 1:50 PM Typoz
    Friday, March 4, 2011 1:49 PM