locked
CRM 2011 RU4 - e-mail address is not associated with any approved forward mailbox user or queue record RRS feed

  • Question

  • Anyone seen this and/or know how to resolve?

    We do have queues set up within CRM 2011 RU4 - and 'E-mail Access Configuration' set to :

    E-mail access type- Incoming: Forward Mailbox

    E-mail access type- Outgoing: E-mail Router

    Log Name:      Application
    Source:        MSCRMEmail
    Date:          10/18/2011 12:32:30 PM
    Event ID:      17174
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      crmhost.domain.COM
    Description:
    #17174 - An error occurred while validating the e-mail message with subject "RE: New Case Acknowledgement SOME:0002017" in mailbox valid-email@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: E-mails for address some.other@otherdomain.com in forward mailbox could not be processed as the e-mail address is not associated with any approved forward mailbox user or queue record in CRM.
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.CheckForApprovedForwardMailboxUsersOrQueue(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.ValidateMessageInternal(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSCRMEmail" />
        <EventID Qualifiers="0">17174</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-10-18T19:32:30.000000000Z" />
        <EventRecordID>9311</EventRecordID>
        <Channel>Application</Channel>
        <Computer>crmhost.domain.COM</Computer>
        <Security />
      </System>
      <EventData>
        <Data>#17174 - An error occurred while validating the e-mail message with subject "RE: New Case Acknowledgement SOME:0002017" in mailbox valid-email@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: E-mails for address some.other@otherdomain.com in forward mailbox could not be processed as the e-mail address is not associated with any approved forward mailbox user or queue record in CRM.
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.CheckForApprovedForwardMailboxUsersOrQueue(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.ValidateMessageInternal(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()</Data>
      </EventData>
    </Event>

    Related question:

    Why, in our 'Set Personal Options' - E-mail tab - settings is this grayed out and unable to be checked:

    Allow use of e-mail credentials

    Allow E-mail Router to use my credentials to send and receive e-mail on my behalf

    ??

    • Edited by Brian Williams Tuesday, October 18, 2011 10:03 PM upated bottom of posting
    Tuesday, October 18, 2011 7:50 PM

All replies

  • Are there any users or queues that have the e-mail address some.other@otherdomain.com referenced in this error message:

    An error occurred while validating the e-mail message with subject "RE: New Case Acknowledgement SOME:0002017" in mailboxvalid-email@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: E-mails for addresssome.other@otherdomain.com in forward mailbox could not be processed as the e-mail address is not associated with any approved forward mailbox user or queue record in CRM.

    Also, for all the users and queues, has their e-mail address been approved using the Approve E-mail button?

    Apologies if you have already checked all this. 

    Wednesday, October 19, 2011 5:27 PM
    Moderator
  • I'm working with Brian on this issue, and the problem is that we need ALL external emails to be allowed to send to the forward mailbox, but they are getting moved to the "undeliverable" folder by the CRM email router and it logs the error noted. These emails are coming from external customers and it appears to be rejecting based on the From address. What is interesting is that if we CC a validated CRM User in the email, the router logs the error but still routes the email to CRM regardless of the From.

    So to answer your questions: no, there are no users or queues that have the some.other@otherdomain.com address; and yes all CRM Users and Queues email addresses are approved.

     

    Thanks for your help!

    Wednesday, October 19, 2011 6:10 PM
  • There is mention of something that may be relevant in Update Rollup 5 http://support.microsoft.com/default.aspx?kbid=2567454. I wonder if it is worth trying to install it and see what happens. This is the part that caught my attention:

     

    You cannot import email messages to Microsoft Dynamics CRM 2011 if the From field of the email message contains a sender other than a user or queue in Microsoft Dynamics CRM.

     

    Wednesday, October 26, 2011 9:43 PM
    Moderator
  • I have this problem as well and I've installed UR5 on server, router, srs and mui but this error is still present. The sending email address is matched against queues and/or users instead of the receiving email address. Has anyone successfully set up a forward email box with UR4 or later?

     

     


    Rickard Norström Developer CRM-Konsulterna http://www.crmkonsulterna.se Swedish Dynamics CRM Forum: http://www.crmforum.se
    Wednesday, December 21, 2011 8:27 AM
  • Hi, same issue here running 2011 RU6.
    Thursday, February 2, 2012 5:06 PM
  • Hi guys,

    In order to ungrey the checkbox: Allow email router to use my credentials..." you have to set the DisableSecureDecryptionKey to 1 in the registry.

    Aside from that am running into the same issue: email address xxxx could not be processed as the email address is not associated with any approved forward mailbox user or queue...

    The address is actually a queue email address and it has been approved. Actually even the sender's email is approved since he is a CRM user.

    No infos in the traces, just this unhelpful error message.

    Systems info: CRM 2011, UR6, Exchange 2007 (ews)

    Any of you guys was able to solution this?

    Thanks,

    :~K


    :~DaDynamixFan

    Thursday, April 19, 2012 12:53 PM
  • We had the same issue. We found that we had a queue configured with valid-email@services.domain.com, and when you went to see the inbox it had 10 emails. The queue only read 6 emails and 4 emails were found in the log with the same info.

    The response to our problem was, that the inbox valid-email@services.domain.com also receives emails from valid-email@domain.com (this is the alias), so all the lost emails was because the email router couldnt process the valid-email@domain.com emails. So we configured a new queue valid-email@domain.com with the same  password, and all the messages are already arriving.

    It was curious because if you check the inbox of any of both emails, it had all the messages. But we had to split it in two queues, and using a workflow, we can send all to one queue.

    Hope this was helpful.

    Wednesday, May 2, 2012 11:22 PM
  • Login with the user that has the mailbox some.other@otherdomain.com and delete the forwarding rules. 

    There must be rules created by the wizard who were not erased.


    Wednesday, May 9, 2012 1:34 PM