locked
Report annot be displayed- error on running custom SSRS report in CRM 2013 RRS feed

  • Question

  • Hi,

    We are trying to run a custom SSRS report (created using BIDS) on our upgraded CRM 2013 organization .The report includes few filtered parameters.  When we try to select a value in this filter, we get the following error.

    report cannot be displayed

    The event log generated is as given below:

    Log Name:      Application

    Source:        MSCRMReporting

    Event ID:      19970

    Task Category: None

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Description:

    Report render failure. Error: The operation has timed out

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="MSCRMReporting" />

        <EventID Qualifiers="49152">19970</EventID>

        <Level>2</Level>

        <Task>0</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2014-01-30T04:35:52.000000000Z" />

        <EventRecordID>209093</EventRecordID>

        <Channel>Application</Channel>

        <Computer>xxxx</Computer>

        <Security />

      </System>

      <EventData>

        <Data>The operation has timed out</Data>

        <Data>w3wp</Data>

        <Data>C:\Program Files\Microsoft Dynamics CRM\CRMWeb\</Data>

      </EventData>

    </Event>

    The same report is working fine when accessed from report server and also on the visual studio (BIDS) where it is created but gives the above mentioned error from when run from CRM.

    The user in all the cases is CRM System administrator who also have administrator role in Report Server Manager.

    Is there any other setting that I am missing? Or anything that needs to be configured for accessing report in CRM 2013?

    Any suggestions/information would be of great help.

    Thanks,

    Swapnil


    Thursday, January 30, 2014 5:31 AM

All replies

  • hi Swapnil,

    just make sure that you have set the dataset name to MSCRM or CRM

    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Thanks

    Subhash

    Thursday, January 30, 2014 6:45 AM
  • Hi

    Are you using CRMAF prefix to get the records on which you are running the record.

    If not, chances are that your report is running for all the records in that entity hence getting timedout.

    Here is some information on it : http://xrmdevel.blogspot.se/2011/09/ssrscrmaf-auto-filter-on-multiple.html

    Thursday, January 30, 2014 9:14 AM
  • Your error message shows a timeout error. Try the following to extend the timeout since the report runs on the report server.  You may have to exercise some patience to see if the report actually runs or continues to fail depending on how large the report is.  We had a report in CRM 2011 that basically reported on everything for the year and took well over 10 minutes to generate.

    Create OleDBTimeout Key

    a. Open the registry (regedit)

    b. Go to HKEY_LOCAL_MACHINE>SOFTWARE>MICROSOFT>MSCRM

    c. Create a new DWORD Value (do this by right clicking on MSCRM and selecting new).

    d. Call the key OleDBTimeout

    e. Double click on the key name and give it a value of 86400 and select hexadecimal.

    Create ExtendedTimeout Key

    a. Open the registry (regedit)

    b. Go to HKEY_LOCAL_MACHINE>SOFTWARE>MICROSOFT>MSCRM

    c. Create a new DWORD Value (do this by right clicking on MSCRM and selecting new).

    d. Rename the DWORD value to "ExtendedTimeout." 

    e. Right-click the DWORD value, and then click Modify. 

    f. In the Edit DWORD Value dialog box, type 1000000 in the Value data field, and then click OK.

    Note You can enter a value that is larger than 1000000 in the Value data field. 

    g.  After this is done, do an IISRESET

    If the report runs in CRM after you do the above, you will need to look at either redesigning your report to be more efficient and/or look at indexing on tables that are referenced by the report to help speed up the process.  I am assuming that the upgrade would have set default indexing during the upgrade but you may need some additional indexing.

    Note that you don't want to keep the timeout keys from above in place once you see that the report works in CRM because you are over riding default settings that may cause you problems down the road.  When done you should remove them from the registry.


    Jason Peterson

    • Proposed as answer by CRM-Developer Saturday, October 29, 2016 12:13 PM
    Thursday, January 30, 2014 10:02 AM
  • You may also have some useful information in the Reporting Services logs - http://mscrmuk.blogspot.co.uk/2012/11/reporting-services-log-files.html


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk


    Thursday, January 30, 2014 11:05 AM
    Moderator
  • I've run into the same error when running any sub-report.

    Despite the "The operation has timed out", it takes less than a second to get an error, so I suspect that error is masking a "could not connect to host xyz" error.

    Monday, November 24, 2014 10:36 PM
  • Are you using a Shared Data Source in your report in BIDs? In custom CRM reports you should not use Share Data Source. Id doesn't work.


    Sachith Chandrasiri

    Tuesday, November 25, 2014 12:55 AM
  • In my case, the reports have been working, and continue to work in all but one environment. The reports are the same in every environment, so it must be some configuration difference on the report or crm servers with the error.

    I just noticed the thread's title is about 2013. I'm seeing the same scenario/errors with 2011.

    Tuesday, November 25, 2014 3:00 AM
  • Hi,

    Please check the input parameters your are using in the report. This kind of errors will be occurred when there is a lot of data need to be loaded to the Parameters. While loading the report, it will be failing when it try to add more data to the parameters. Please check by loading less number of records to input parameters and try in CRM.

    Regards,

    Syai Reddy D


    Regards, Syai, Osmosys


    • Edited by Syai Tuesday, November 25, 2014 6:49 AM
    Tuesday, November 25, 2014 6:30 AM
  • It turned out, in my case, to be the URL used to access the CRM tenant.

    It works with the F5 load-balancer URL, and does not if the tenant is accessed with one of the web servers' host names.

    So I suspect that the issue is that an authentication chain is broken if some host names don't line up.

    It would be nice if the trace log had the actual error and details, instead of the bogus time-out message.

    Tuesday, November 25, 2014 8:22 PM
  • Thanks a lot. It worked
    Saturday, October 29, 2016 12:13 PM