locked
Home built WHS refuses to add external hard drive RRS feed

  • Question

  • I converted my old Dell Latitude to WHS. Everything was working fine. After experimenting I realised that the hard drive on the laptop is not enough so I bought an Iomega 1TB external (desktop) USB hard drive.

    I plugged it in and tried adding it through the Server Storage Option. It failed. I got a message saying that the Wizard failed to add the hard drive.

    Any help will be appreciated.

    Thanks

    Thursday, March 25, 2010 7:45 AM

All replies

  • Hi,

    Quite often USB external drives come with extra software or special paritioning that foxs Windows Home Server.  You should connect this drive to another computer and using diskpart/disk manager clean the drive and try it again on your Windows Home Server.  If that doesn't work then creating a partition on the other compute should be okay - make sure to use the whole of the disk for _one_ partition only.

    Cheers,
    Al


    --
    Thursday, March 25, 2010 10:46 AM
  • Thanks Al,

    By cleaning, I assume you mean Format. I will try that.

    Thanks,

    Vin

    Thursday, March 25, 2010 11:14 AM
  • No I mean cleaning the drive of any partitions - or removing the drive of partitions - the command in diskpart is clean. 

    If I meant format I would have said that - Windows Home Server will format the drive when it can see it may use it, so there is no point in formatting it first.

    Depending on which tool you are going to use please read up on it first - it's very easy to get the wrong drive and have data lost forever.


    --
    Thursday, March 25, 2010 11:51 AM
  • Hi Al,

    Used Diskpart. Cleaned the Hard Drive, Created a Partition - all using another PC. Then plugged in to the WHS. Same problem.

    I can use the USB Hard Drive as an additional drive with a different drive letter, but that defies the purpose.

    Do you think I am doing something wrong?

    Thanks

    Thursday, March 25, 2010 4:17 PM
  • What model of drive are you using? Can you link it on Newegg or Amazon?
    I'm not on the WHS team, I just post a lot. :)
    Thursday, March 25, 2010 4:28 PM
    Moderator
  • You don't seem to be doing anything wrong if you are adding the drive from the console.  Try adding it as a backup drive first, go with the option to format.  Then when it's added remove it permanently and then try to add it as a storage pool drive.

    --

    • Edited by Al West Thursday, March 25, 2010 6:00 PM
    Thursday, March 25, 2010 5:20 PM
  • I tried it. When I added it as a backup drive. It worked fine. Then I removed it and added it to the storage pool. Back to square one. Same error.

    One thing I noticed though, when the wizard is almost through, the server gives a notification that the backup service and the media connect service are not running. Not sure if they are related.

    Thanks,

    Vin

    Thursday, March 25, 2010 5:54 PM
  • I can't think of any reason why there might be a problem other than there is a fault with the drive.  That said there could be an error on your current drive.  Would you run chkdsk on both c: and d: and your new USB drive?

    Though you are running on a laptop and I'm wondering if their is a power saving issue when using USB. Try setting the power managements in your laptop to always off in Windows Home Server - or even off in your BIOS.

    Other thing is does your laptop support USB 2.0 - some older laptops have some ports that support only USB 1.1.


    --
    Thursday, March 25, 2010 5:56 PM
  • The Power saving is off on the Laptop. Ditto in the BIOS. Chkdsk returned no errors on C, D & the USB Drive.

    The USB is 2.0.

    Don't understand - WHS recognises the HDD. Let's me add it as a backup or leave it as a standalone, but does not let me add it to the storage pool.

     

    Thursday, March 25, 2010 6:11 PM
  • How about if you turn off your server and boot it with the drive attached, then try and add the drive?

    In Device Manager are all your devices healthy? - i.e. no uninstalled drivers, problematic drivers, yellow exclaimation marks etc.


    --
    Thursday, March 25, 2010 6:39 PM
  • Thanks Al. already done that. Nada. I am totally perplexed. Do you think I should change the disk? At the same time it defies logic. Are there any logs which are generated after the wizard is run?

    Does the wizard stop the backup service? Because there is always a 'Critical Network' error towards the end of the wizard running - backup service not running.

    Thanks

    Thursday, March 25, 2010 6:41 PM
  • Guys,

    I tried adding another disk - a Hitachi and guess what - same problem.

    I scanned the server for malware.

    Uninstalled Orb & Tversity.

    Still the same problem.

    Do you think I have to reinstall the Server?

    Monday, March 29, 2010 9:00 PM
  • I think it would be worth spending money on new hardware, to be honest.
    I'm not on the WHS team, I just post a lot. :)
    Monday, March 29, 2010 9:38 PM
    Moderator