locked
Can't view code. "The operation could not be completed" Error RRS feed

  • Question

  • I have a project I am trying to edit and when i'm attempting to view class code an error occurs. "The operation could not be completed". Its allowing me to view my forms and form code but not the code in my classes. 

    Version: Visual Studio 2015

    Monday, April 16, 2018 9:48 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Run visual studio as administrstor and check it if the issue persists.

    You can also delete C:\Users\**username**\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache. Try to delete the Your_Solution_FileName.suo file. The .suo file should be in the .vs folder, the .vs folder might be hidden.

    If all of these doesn't work, create a new project and see if it has the same problem.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 17, 2018 3:05 AM
  • I have done all of these things and the problem still persists.

    Even when i create a new project after i save and load it up again the same issue arises. This isn't happening on all my programs however, just certain ones

    I have also reinstalled visual studio ...
    • Edited by _Yikes_2018 Tuesday, April 17, 2018 8:21 AM
    Tuesday, April 17, 2018 8:16 AM
  • Hi,

    Thank you for the update.

    >>Even when i create a new project after i save and load it up again the same issue arises. This isn't happening on all my programs however, just certain ones

    What are types of these project, winform or something else?

    open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run these commands:

                    devenv /safemode

    It prevents all third-party VSPackages from loading when Visual Studio starts, check it again.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 17, 2018 9:46 AM
  • This is an XNA program. So when i run in safe mode i can't access the solution at all. All i can access in safemode is the integrated Form system i created.
    Tuesday, April 17, 2018 10:08 AM
  • Hi,

    Thank you for the update.

    >>Even when i create a new project after i save and load it up again the same issue arises. This isn't happening on all my programs however, just certain ones

    This is an XNA program.

    If you have no problem with the other project in visual studio 2015, you can go to XNA forum to talk about it.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 18, 2018 10:32 AM