none
Can not add computenodes - no nodes are discovered

    Question

  • I am student trying to set up a windows hpc server 2008 at my university.

    Its just a small test cluster, with 4 nodes and 1 headnode.

    Each node had already win2k8 hpc installed.

    I configured the headnode after installing hpc pack 2008 on it.

    I decided to use Network-Type 2, with enterprise network and compute network.

     It doesnt really matter, because each node has 2 interfaces connected to the same switch.

    Each node has 2 static ips:

    the compute-ips are  in range 192.168.1.1-4 and the headnode ist 192.168.1.253 (internally)

    This is why i disabled the dhcp server on the node. I also decided to use a template without an os image included (preconfigured node). - I don't really want to touch the nodes, which are also running a linux cluster if booted otherwise.

    Each node is added inside the domain, where i have created a new account for it as mentioned in the todo-list of the head-node config. (Maybe i am missing some user-rights here?) But i am still doing the config by hand.

    What i did next was installing HPC 2008 Pack on each node, and selecting "join" to add it to a head node.

    No error occured while installation. As Headnode i specified: 192.168.1.253.

    Selecting "install with client utils"-checkbox gives the the cluster manager which automatically connects sucesfully on the head node.


    The problem now is, if i am inside the cluster manager (rdp on headnode/computenode), i am not able to add a compute node (preconfigured). I just see an empty box with no nodes inside. There is a info-message which says, that discovering all nodes could take a few minutes, but 30min should really be enough.

    Whats wrong with my hpc? any idea?

    I really need your help! thx

    Tuesday, June 30, 2009 11:30 PM

Answers

  • can you ping the head node from the compute node?
    and compute node(s) from the head node?

    If the network connectivity is fine, you should be able to 'add' the pre-configured nodes via add node wizard.
    look at the event log on the head node to see if there are any errors. There could  group policy /firewall issues blocking the compute nodes from contacting the head node.
    Another thing to try is to move to network topology 5, since all the nodes are essentially connected to the same network via both the NICs, topology 5 ensures that there is no DHCP or PXE/TFTP server enabled on the head node.

    -parmita
    pm
    Thursday, July 2, 2009 5:48 PM
    Moderator

All replies

  • Hi,

      You should look at the events logged by HPC server with the Server Manager on the head node 
      And also which regionnal setting did you used on the nodes and the head node?

    Best regards, Tom
    Thursday, July 2, 2009 2:46 PM
  • can you ping the head node from the compute node?
    and compute node(s) from the head node?

    If the network connectivity is fine, you should be able to 'add' the pre-configured nodes via add node wizard.
    look at the event log on the head node to see if there are any errors. There could  group policy /firewall issues blocking the compute nodes from contacting the head node.
    Another thing to try is to move to network topology 5, since all the nodes are essentially connected to the same network via both the NICs, topology 5 ensures that there is no DHCP or PXE/TFTP server enabled on the head node.

    -parmita
    pm
    Thursday, July 2, 2009 5:48 PM
    Moderator


  • I decided to use Network-Type 2, with enterprise network and compute network.

     It doesnt really matter, because each node has 2 interfaces connected to the same switch.

    AFAIK a switch can only serve for one subnet. So most probably one of your networks will not be able to communicate. That might be a first step towards a solution. I would try the setup with just an internally network over the switch and let the headnode do NAT to the enterprise network.

    Of course this is not the case if you have a more advanced switch with different VLANs configured

    JH
    Friday, July 3, 2009 7:31 AM